aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-15 15:44:36 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-15 15:44:36 +0000
commit7f1969a357048c33e6317de1ec1968d541651ccd (patch)
treedec575436d83f9479a0299d483050aa63637c60a /www/squid
parent9669e20176bf9d709676ec74b35b0436a28a227c (diff)
downloadports-7f1969a357048c33e6317de1ec1968d541651ccd.tar.gz
ports-7f1969a357048c33e6317de1ec1968d541651ccd.zip
Integrate two vendor patches being published on
<http://www.squid-cache.org/Versions/v2/2.5/bugs/>: - Fix wbinfo_group.pl to correctly work with the wbinfo command from samba-3.0.21 (squid bug #1472) - Fix a crash when accessing async IO function counters via the cachemgr CGI in cases where squid was compiled for aufs support but not actually using it (squid bug #1464) While at it, remove an unneeded patch from the ICAP core patchset. PR: ports/91831 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=153570
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile6
-rw-r--r--www/squid/distinfo6
-rw-r--r--www/squid/files/icap-2.5-core.patch37
3 files changed, 10 insertions, 39 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 08f5725df41e..195e0938355c 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -73,7 +73,7 @@
PORTNAME= squid
PORTVERSION= 2.5.12
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
@@ -86,7 +86,9 @@ DISTNAME= squid-2.5.STABLE12
DIST_SUBDIR= squid2.5
PATCH_SITES= http://www.squid-cache.org/Versions/v2/2.5/bugs/
-PATCHFILES= squid-2.5.STABLE12-SMB_BadFetch.patch
+PATCHFILES= squid-2.5.STABLE12-SMB_BadFetch.patch \
+ squid-2.5.STABLE12-wbinfo_group.patch \
+ squid-2.5.STABLE12-asyncio_counters.patch
PATCH_DIST_STRIP= -p1
MAINTAINER= tmseck@netcologne.de
diff --git a/www/squid/distinfo b/www/squid/distinfo
index 3e55ac8d1717..a0989aff77c9 100644
--- a/www/squid/distinfo
+++ b/www/squid/distinfo
@@ -4,3 +4,9 @@ SIZE (squid2.5/squid-2.5.STABLE12.tar.bz2) = 1075111
MD5 (squid2.5/squid-2.5.STABLE12-SMB_BadFetch.patch) = 8e83b776c0d015bd4137cc1ca08f6d38
SHA256 (squid2.5/squid-2.5.STABLE12-SMB_BadFetch.patch) = 9ca8427c2eb9e5cbdb5a49fb5cb94fc00853ad965f87666f8fc35236e98bc0ae
SIZE (squid2.5/squid-2.5.STABLE12-SMB_BadFetch.patch) = 826
+MD5 (squid2.5/squid-2.5.STABLE12-wbinfo_group.patch) = fe0ab5839d282fda67ffd8eb17f2588d
+SHA256 (squid2.5/squid-2.5.STABLE12-wbinfo_group.patch) = 9aa671be4022f1126071cf83ca800795f609b731aac74237bc70e11d8f069046
+SIZE (squid2.5/squid-2.5.STABLE12-wbinfo_group.patch) = 1615
+MD5 (squid2.5/squid-2.5.STABLE12-asyncio_counters.patch) = 70485fac2c02d836f7027122e65d5767
+SHA256 (squid2.5/squid-2.5.STABLE12-asyncio_counters.patch) = 39bf2ca95a3c1fc90a40c437253dbbf6d71f37763369ada287039340a68b873f
+SIZE (squid2.5/squid-2.5.STABLE12-asyncio_counters.patch) = 497
diff --git a/www/squid/files/icap-2.5-core.patch b/www/squid/files/icap-2.5-core.patch
index 22d209c18fb4..4e50207f2029 100644
--- a/www/squid/files/icap-2.5-core.patch
+++ b/www/squid/files/icap-2.5-core.patch
@@ -1147,43 +1147,6 @@ diff -p -u -b -r1.10 -r1.10.30.2
+#endif
+
#endif /* SQUID_UTIL_H */
-Index: lib/Makefile.am
-===================================================================
-RCS file: /cvsroot/squid/squid/lib/Makefile.am,v
-retrieving revision 1.4
-retrieving revision 1.4.26.2
-diff -p -u -b -r1.4 -r1.4.26.2
---- lib/Makefile.am 21 Nov 2001 23:48:57 -0000 1.4
-+++ lib/Makefile.am 6 Apr 2004 13:04:38 -0000 1.4.26.2
-@@ -8,6 +8,19 @@ SNPRINTFSOURCE=snprintf.c
- else
- SNPRINTFSOURCE=
- endif
-+
-+if NEED_OWN_STRNSTR
-+STRNSTRSOURCE=strnstr.c
-+else
-+STRNSTRSOURCE=
-+endif
-+
-+if NEED_OWN_STRCASESTR
-+STRCASESTRSOURCE=strcasestr.c
-+else
-+STRCASESTRSOURCE=
-+endif
-+
- if NEED_OWN_MD5
- MD5SOURCE=md5.c
- else
-@@ -43,6 +56,8 @@ libmiscutil_a_SOURCES = \
- $(SNPRINTFSOURCE) \
- splay.c \
- Stack.c \
-+ $(STRNSTRSOURCE) \
-+ $(STRCASESTRSOURCE) \
- stub_memaccount.c \
- util.c \
- uudecode.c
Index: lib/strcasestr.c
===================================================================
RCS file: lib/strcasestr.c