aboutsummaryrefslogtreecommitdiff
path: root/www/squid
diff options
context:
space:
mode:
authorAdrian Chadd <adrian@FreeBSD.org>2001-09-01 08:34:14 +0000
committerAdrian Chadd <adrian@FreeBSD.org>2001-09-01 08:34:14 +0000
commit5fa3173ffa62df371b926fd363e600a4f774867d (patch)
tree5fcb53aa61359d788f8607668f061299d1c5a6fe /www/squid
parent6fdf3349dfac45362845a914e0cb501ae54e1e9e (diff)
downloadports-5fa3173ffa62df371b926fd363e600a4f774867d.tar.gz
ports-5fa3173ffa62df371b926fd363e600a4f774867d.zip
Remove the RunCache stuff and let squid handle its own child maintainence.
This now means that 'stop' as an argument works correctly, and doesn't end up having squid restarted. I've added some sleep code to wait for squid to complete its shutdown, but I have commented it out for the time being as I don't know whether its good practice to have your machine sleep during shutdown. I'll research it some more. :)
Notes
Notes: svn path=/head/; revision=47263
Diffstat (limited to 'www/squid')
-rw-r--r--www/squid/Makefile2
-rw-r--r--www/squid/files/squid.sh9
2 files changed, 8 insertions, 3 deletions
diff --git a/www/squid/Makefile b/www/squid/Makefile
index 150ea88cb47a..1d578451efdf 100644
--- a/www/squid/Makefile
+++ b/www/squid/Makefile
@@ -7,7 +7,7 @@
PORTNAME= squid
PORTVERSION= 2.4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= \
ftp://ftp.squid-cache.org/pub/squid-2/STABLE/ \
diff --git a/www/squid/files/squid.sh b/www/squid/files/squid.sh
index e9a3144e8c93..40f655b04f27 100644
--- a/www/squid/files/squid.sh
+++ b/www/squid/files/squid.sh
@@ -7,11 +7,16 @@ fi
case "$1" in
start)
- if [ -x ${PREFIX}/sbin/RunCache -a -f ${PREFIX}/etc/squid/squid.conf ]; then
- (cd /tmp; ${PREFIX}/sbin/RunCache >/dev/null 2>&1 &) ; echo -n ' squid'
+ if [ -x ${PREFIX}/sbin/squid -a -f ${PREFIX}/etc/squid/squid.conf ]; then
+ (cd /${PREFIX}/squid/logs; ${PREFIX}/sbin/squid >/dev/null 2>&1 &) ; echo -n ' squid'
fi
;;
stop)
+ ${PREFIX}/sbin/squid -k shutdown 2>&1
+ # Uncomment this if you'd like the system to (attempt to
+ # wait for) squid to shut down cleanly
+ #echo "Sleeping for 45 seconds to allow squid to shutdown.."
+ #sleep 45
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2