aboutsummaryrefslogtreecommitdiff
path: root/www/swish++
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-27 07:37:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-27 07:37:12 +0000
commitd3007b43e7929d4010bd442883a4813c24f744af (patch)
tree1f3518d0b8a7cc1c1eb810d1900d2b99ca3197da /www/swish++
parent4ba46d90172f391acf2849a192df2d76ed8a8b1d (diff)
downloadports-d3007b43e7929d4010bd442883a4813c24f744af.tar.gz
ports-d3007b43e7929d4010bd442883a4813c24f744af.zip
- Update to 6.1.5
PR: 121091 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=207981
Diffstat (limited to 'www/swish++')
-rw-r--r--www/swish++/Makefile6
-rw-r--r--www/swish++/distinfo6
-rw-r--r--www/swish++/files/patch-elements.c11
3 files changed, 5 insertions, 18 deletions
diff --git a/www/swish++/Makefile b/www/swish++/Makefile
index ac94036d2069..6c5cc43b3aee 100644
--- a/www/swish++/Makefile
+++ b/www/swish++/Makefile
@@ -7,10 +7,9 @@
#
PORTNAME= swish++
-PORTVERSION= 6.1.4
+PORTVERSION= 6.1.5
CATEGORIES= www textproc
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= swishplusplus
+MASTER_SITES= SF/swishplusplus
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple Web Indexing System for Humans: C++ version
@@ -19,7 +18,6 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_PERL5= yes
USE_GMAKE= yes
-USE_GCC= 3.4+
MAKEFILE= GNUmakefile
MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} \
PERL=${PERL} PERL_VER=${PERL_VER}
diff --git a/www/swish++/distinfo b/www/swish++/distinfo
index f0fe8c75ed0b..425890a39bd9 100644
--- a/www/swish++/distinfo
+++ b/www/swish++/distinfo
@@ -1,3 +1,3 @@
-MD5 (swish++-6.1.4.tar.gz) = 08c0eac88e4f08c353037b893e243268
-SHA256 (swish++-6.1.4.tar.gz) = 35e2c3d98a0cfd8c9fac45b7e12d13462e2521f025daac81045e697f403721f7
-SIZE (swish++-6.1.4.tar.gz) = 302123
+MD5 (swish++-6.1.5.tar.gz) = af755e4c7477fd1c05634596d6a9ff00
+SHA256 (swish++-6.1.5.tar.gz) = 497b7d1f5dada146b74d82f787a1767a3713402e018b1e693cb7f6191db88d86
+SIZE (swish++-6.1.5.tar.gz) = 320082
diff --git a/www/swish++/files/patch-elements.c b/www/swish++/files/patch-elements.c
deleted file mode 100644
index ab3bd53c87e5..000000000000
--- a/www/swish++/files/patch-elements.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- mod/html/elements.c.orig 2007-07-31 20:12:01.000000000 +0200
-+++ mod/html/elements.c 2007-07-31 20:12:22.000000000 +0200
-@@ -295,7 +295,7 @@
- // become overly pedantic about casting to enums.
- //
- element::end_tag_type const
-- v = (element::end_tag_type const)(int const)(p[1]);
-+ v = (element::end_tag_type const)(intptr_t const)(p[1]);
- element &e = insert( value_type( *p++, element( v ) ) ).first->second;
-
- switch ( v ) {