aboutsummaryrefslogtreecommitdiff
path: root/www/tclhttpd
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2003-04-24 17:01:19 +0000
committerMikhail Teterin <mi@FreeBSD.org>2003-04-24 17:01:19 +0000
commiteb69ee3b49c0c894cc54fd92f49db1c7994ec48c (patch)
tree970896ddd74f0f1bc1c0ab1d2aa42224b8ce23d6 /www/tclhttpd
parent4bc126887dac2adffe1843f64e1c376c6f4931ab (diff)
downloadports-eb69ee3b49c0c894cc54fd92f49db1c7994ec48c.tar.gz
ports-eb69ee3b49c0c894cc54fd92f49db1c7994ec48c.zip
Upgrade from 3.3 to 3.4.2. Use tcl84 by default.
Notes
Notes: svn path=/head/; revision=79594
Diffstat (limited to 'www/tclhttpd')
-rw-r--r--www/tclhttpd/Makefile9
-rw-r--r--www/tclhttpd/distinfo2
-rw-r--r--www/tclhttpd/files/patch-tcl8446
-rw-r--r--www/tclhttpd/pkg-plist1
4 files changed, 52 insertions, 6 deletions
diff --git a/www/tclhttpd/Makefile b/www/tclhttpd/Makefile
index 00e57d23e575..8de39bab6501 100644
--- a/www/tclhttpd/Makefile
+++ b/www/tclhttpd/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= tclhttpd
-PORTVERSION= 3.3
-PORTREVISION= 1
-CATEGORIES= www tcl${TCL_VER}
+PORTVERSION= 3.4.2
+CATEGORIES= www tcl83
MASTER_SITES= ${MASTER_SITE_TCLTK}
MASTER_SITE_SUBDIR= httpd
DISTNAME= ${PORTNAME}${PORTVERSION}
@@ -16,10 +15,10 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
COMMENT= An http-server implemented in TCL
-RUN_DEPENDS= ${LOCALBASE}/lib/tcllib1.2/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
+RUN_DEPENDS= ${LOCALBASE}/lib/tcllib1.3/pkgIndex.tcl:${PORTSDIR}/devel/tcllib
LIB_DEPENDS= tcl${TCL_VER}:${PORTSDIR}/lang/tcl${TCL_VER}
-TCL_DVER?= 8.3
+TCL_DVER?= 8.4
TCL_VER= ${TCL_DVER:S/.//}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl="${LOCALBASE}/lib/tcl${TCL_DVER}" \
diff --git a/www/tclhttpd/distinfo b/www/tclhttpd/distinfo
index 7c43ef8645f1..c32ea86e49ef 100644
--- a/www/tclhttpd/distinfo
+++ b/www/tclhttpd/distinfo
@@ -1 +1 @@
-MD5 (tclhttpd3.3.tar.gz) = 0cc30bde4173ca1fae33abf593f8d6f2
+MD5 (tclhttpd3.4.2.tar.gz) = d5c6517430023735a78afb5e8d707e83
diff --git a/www/tclhttpd/files/patch-tcl84 b/www/tclhttpd/files/patch-tcl84
new file mode 100644
index 000000000000..0d9b472f8fe0
--- /dev/null
+++ b/www/tclhttpd/files/patch-tcl84
@@ -0,0 +1,46 @@
+--- src/crypt.c Sat Feb 12 19:03:25 2000
++++ src/crypt.c Thu Apr 24 12:04:03 2003
+@@ -12,4 +12,9 @@
+
+ #include "tcl.h"
++
++#ifndef CONST84
++# define CONST84
++#endif
++
+ #ifndef _WIN32
+ #include "unistd.h"
+@@ -20,8 +25,4 @@
+ */
+
+-
+-static int Crypt_Cmd _ANSI_ARGS_((ClientData clientData,
+- Tcl_Interp *interp, int argc, char **argv));
+-
+ #undef TCL_STORAGE_CLASS
+ #define TCL_STORAGE_CLASS DLLEXPORT
+@@ -53,5 +54,5 @@
+ Tcl_Interp *interp; /* Current interpreter. */
+ int argc; /* Number of arguments. */
+- char **argv; /* Argument strings. */
++ CONST84 char *argv[]; /* Argument strings. */
+ {
+ char *result;
+--- src/setuid.c Tue Oct 6 20:12:11 1998
++++ src/setuid.c Thu Apr 24 12:03:18 2003
+@@ -8,4 +8,8 @@
+ #include <unistd.h>
+
++#ifndef CONST84
++# define CONST84
++#endif
++
+ /*
+ * SetuidCmd --
+@@ -19,5 +23,5 @@
+ */
+ int
+-SetuidCmd(ClientData data, Tcl_Interp *interp, int argc, char *argv[])
++SetuidCmd(ClientData data, Tcl_Interp *interp, int argc, CONST84 char *argv[])
+ {
+ int uid;
diff --git a/www/tclhttpd/pkg-plist b/www/tclhttpd/pkg-plist
index 4daeb534fd71..9c145e03108d 100644
--- a/www/tclhttpd/pkg-plist
+++ b/www/tclhttpd/pkg-plist
@@ -227,6 +227,7 @@ share/tclhttpd%%PORTVERSION%%/.tml
@dirrm share/tclhttpd%%PORTVERSION%%/templates
@dirrm share/tclhttpd%%PORTVERSION%%
tclhttpd/custom/README
+tclhttpd/custom/ddehack.tcl
tclhttpd/custom/hello.tcl
tclhttpd/custom/snmpinit.tcl
tclhttpd/custom/tclpro.tcl