aboutsummaryrefslogtreecommitdiff
path: root/www/templatelite
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 01:06:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 01:06:38 +0000
commit98e12f723a6025c6e7c141a26b02f11873f2cb1b (patch)
tree04f6962055aa2f214290c6fe7fa237489dbf446c /www/templatelite
parentb70b2aa47a3d60d4c39625a007fffbd466809bdc (diff)
downloadports-98e12f723a6025c6e7c141a26b02f11873f2cb1b.tar.gz
ports-98e12f723a6025c6e7c141a26b02f11873f2cb1b.zip
Add templatelite 1.90, a smaller, faster alternative to the Smarty
template engine. PR: ports/103460 Submitted by: Alexander Zhuravlev <zaa at zaa.pp.ru>
Notes
Notes: svn path=/head/; revision=173846
Diffstat (limited to 'www/templatelite')
-rw-r--r--www/templatelite/Makefile35
-rw-r--r--www/templatelite/distinfo3
-rw-r--r--www/templatelite/files/pkg-message.in8
-rw-r--r--www/templatelite/pkg-descr4
-rw-r--r--www/templatelite/pkg-plist90
5 files changed, 140 insertions, 0 deletions
diff --git a/www/templatelite/Makefile b/www/templatelite/Makefile
new file mode 100644
index 000000000000..14da7d51a98e
--- /dev/null
+++ b/www/templatelite/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Template Lite
+# Date created: 2006-09-21
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= templatelite
+PORTVERSION= 1.90
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= template_lite_${PORTVERSION}
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= A smaller, faster alternative to the Smarty template engine
+
+NO_BUILD= yes
+USE_PHP= pcre
+WANT_PHP_WEB= yes
+NO_WRKSUBDIR= yes
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC}/src && ${FIND} * | ${TAR} cTf - - | ${TAR} xUCf ${DATADIR} -
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${FIND} * -type f -exec ${INSTALL_DATA} {} ${DOCSDIR} \;
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/templatelite/distinfo b/www/templatelite/distinfo
new file mode 100644
index 000000000000..7a13835234ff
--- /dev/null
+++ b/www/templatelite/distinfo
@@ -0,0 +1,3 @@
+MD5 (template_lite_1.90.tar.gz) = 0e5d62e9a5958dd4e54d4369b8341d72
+SHA256 (template_lite_1.90.tar.gz) = d2468a578792c47c3906e53198fb57648883ebe8e8ac3adc96dd2684ca9c78bf
+SIZE (template_lite_1.90.tar.gz) = 89816
diff --git a/www/templatelite/files/pkg-message.in b/www/templatelite/files/pkg-message.in
new file mode 100644
index 000000000000..ea9e0673dcd9
--- /dev/null
+++ b/www/templatelite/files/pkg-message.in
@@ -0,0 +1,8 @@
+*******************************************************************
+
+You need to adjust php's include_path to contain `%%DATADIR%%'!
+For example, insert
+ include_path = ".:%%DATADIR%%"
+into `%%LOCALBASE%%/etc/php.ini'.
+
+*******************************************************************
diff --git a/www/templatelite/pkg-descr b/www/templatelite/pkg-descr
new file mode 100644
index 000000000000..a3ad7ab95fcb
--- /dev/null
+++ b/www/templatelite/pkg-descr
@@ -0,0 +1,4 @@
+Template Lite is a very fast, small HTML template engine written in PHP.
+The engine supports most of the Smarty template engine functions and filters.
+
+WWW: http://templatelite.sourceforge.net
diff --git a/www/templatelite/pkg-plist b/www/templatelite/pkg-plist
new file mode 100644
index 000000000000..38f37fa1c5e6
--- /dev/null
+++ b/www/templatelite/pkg-plist
@@ -0,0 +1,90 @@
+%%PORTDOCS%%%%DOCSDIR%%/appendix.caching.html
+%%PORTDOCS%%%%DOCSDIR%%/appendix.groups.html
+%%PORTDOCS%%%%DOCSDIR%%/getting.started.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/language.compiler.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/language.config.html
+%%PORTDOCS%%%%DOCSDIR%%/language.filters.output.html
+%%PORTDOCS%%%%DOCSDIR%%/language.filters.post.html
+%%PORTDOCS%%%%DOCSDIR%%/language.filters.pre.html
+%%PORTDOCS%%%%DOCSDIR%%/language.functions.custom.html
+%%PORTDOCS%%%%DOCSDIR%%/language.functions.html
+%%PORTDOCS%%%%DOCSDIR%%/language.modifiers.combining.html
+%%PORTDOCS%%%%DOCSDIR%%/language.modifiers.html
+%%PORTDOCS%%%%DOCSDIR%%/language.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/programming.debug.console.html
+%%PORTDOCS%%%%DOCSDIR%%/programming.methods.html
+%%PORTDOCS%%%%DOCSDIR%%/programming.variables.html
+%%PORTDOCS%%%%DOCSDIR%%/what.is.html
+%%DATADIR%%/class.compiler.php
+%%DATADIR%%/class.config.php
+%%DATADIR%%/class.template.php
+%%DATADIR%%/internal/compile.generate_compiler_debug_output.php
+%%DATADIR%%/internal/compile.include.php
+%%DATADIR%%/internal/compile.section_start.php
+%%DATADIR%%/internal/debug.tpl
+%%DATADIR%%/internal/template.config_loader.php
+%%DATADIR%%/internal/template.fetch_compile_include.php
+%%DATADIR%%/internal/template.generate_debug_output.php
+%%DATADIR%%/plugins/block.capture.php
+%%DATADIR%%/plugins/block.strip.php
+%%DATADIR%%/plugins/block.textformat.php
+%%DATADIR%%/plugins/compiler.debug.php
+%%DATADIR%%/plugins/compiler.tplheader.php
+%%DATADIR%%/plugins/function.counter.php
+%%DATADIR%%/plugins/function.cycle.php
+%%DATADIR%%/plugins/function.db_function_call.php
+%%DATADIR%%/plugins/function.db_result_call.php
+%%DATADIR%%/plugins/function.html_checkboxes.php
+%%DATADIR%%/plugins/function.html_hidden.php
+%%DATADIR%%/plugins/function.html_image.php
+%%DATADIR%%/plugins/function.html_input.php
+%%DATADIR%%/plugins/function.html_options.php
+%%DATADIR%%/plugins/function.html_radios.php
+%%DATADIR%%/plugins/function.html_select_date.php
+%%DATADIR%%/plugins/function.html_select_time.php
+%%DATADIR%%/plugins/function.html_table.php
+%%DATADIR%%/plugins/function.html_textbox.php
+%%DATADIR%%/plugins/function.in_array.php
+%%DATADIR%%/plugins/function.mailto.php
+%%DATADIR%%/plugins/function.math.php
+%%DATADIR%%/plugins/function.popup.php
+%%DATADIR%%/plugins/function.popup_init.php
+%%DATADIR%%/plugins/modifier.array_reverse.php
+%%DATADIR%%/plugins/modifier.bbcode2html.php
+%%DATADIR%%/plugins/modifier.capitalize.php
+%%DATADIR%%/plugins/modifier.cat.php
+%%DATADIR%%/plugins/modifier.count.php
+%%DATADIR%%/plugins/modifier.count_characters.php
+%%DATADIR%%/plugins/modifier.count_paragraphs.php
+%%DATADIR%%/plugins/modifier.count_sentences.php
+%%DATADIR%%/plugins/modifier.count_words.php
+%%DATADIR%%/plugins/modifier.date.php
+%%DATADIR%%/plugins/modifier.date_format.php
+%%DATADIR%%/plugins/modifier.debug_print_var.php
+%%DATADIR%%/plugins/modifier.default.php
+%%DATADIR%%/plugins/modifier.escape.php
+%%DATADIR%%/plugins/modifier.indent.php
+%%DATADIR%%/plugins/modifier.lower.php
+%%DATADIR%%/plugins/modifier.nl2br.php
+%%DATADIR%%/plugins/modifier.number_format.php
+%%DATADIR%%/plugins/modifier.regex_replace.php
+%%DATADIR%%/plugins/modifier.replace.php
+%%DATADIR%%/plugins/modifier.spacify.php
+%%DATADIR%%/plugins/modifier.string_format.php
+%%DATADIR%%/plugins/modifier.strip.php
+%%DATADIR%%/plugins/modifier.strip_tags.php
+%%DATADIR%%/plugins/modifier.truncate.php
+%%DATADIR%%/plugins/modifier.upper.php
+%%DATADIR%%/plugins/modifier.urlencode.php
+%%DATADIR%%/plugins/modifier.wordwrap.php
+%%DATADIR%%/plugins/outputfilter.gzip.php
+%%DATADIR%%/plugins/outputfilter.trimwhitespace.php
+%%DATADIR%%/plugins/postfilter.showtemplatevars.php
+%%DATADIR%%/plugins/prefilter.showinfoheader.php
+%%DATADIR%%/plugins/shared.escape_chars.php
+%%DATADIR%%/plugins/shared.make_timestamp.php
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/internal
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%