aboutsummaryrefslogtreecommitdiff
path: root/www/thundercache/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-06-05 20:58:00 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-06-05 20:58:00 +0000
commit43b24b81902109095a9a97f805d27dcca6be2955 (patch)
treebae46870bf482b44eb5576c2df5a53e94ebcca06 /www/thundercache/Makefile
parent35caeb9a319c52353133a3fa079a511dcdfa9ba6 (diff)
downloadports-43b24b81902109095a9a97f805d27dcca6be2955.tar.gz
ports-43b24b81902109095a9a97f805d27dcca6be2955.zip
- Fix port because it was not installing php5-pdo_pgsql depend
- Add php5-pgsql as RUN_DEPEND to minimize PostgreSQL verisioning conflicts - Bump PORTREVISION PR: ports/146874 Submitted by: Patrick Tracanelli <eksffa@freebsdbrasil.com.br> (maintainer)
Notes
Notes: svn path=/head/; revision=255841
Diffstat (limited to 'www/thundercache/Makefile')
-rw-r--r--www/thundercache/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/www/thundercache/Makefile b/www/thundercache/Makefile
index a98735ee7999..2f8fc0de6cdb 100644
--- a/www/thundercache/Makefile
+++ b/www/thundercache/Makefile
@@ -7,7 +7,7 @@
PORTNAME= thundercache
PORTVERSION= 4.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= www
MASTER_SITES= http://www.bmsoftware.org/freebsd/ \
http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
@@ -57,16 +57,17 @@ WANT_PGSQL_VER= 84
RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.endif
+.if defined(WITH_PHP) && defined(WITH_PGSQL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pgsql.so:${PORTSDIR}/databases/php5-pgsql
+.endif
+
.if defined(WITH_PHP)
-USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql
+USE_PHP+= curl pcre bcmath pdo mcrypt mhash session
.endif
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl:install
-.if defined(APACHE+PHP) && defined(WITH_PGSQL)
-LIB_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
-.endif
-
SUB_FILES= pkg-message log.sh test-deps.sh
SUB_LIST= "GREP=${GREP}"