aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat7
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-06-13 11:22:56 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-06-13 11:22:56 +0000
commit37e7803cfd98f167bf4975f2cae5f841e7e4e99c (patch)
tree1e1b6f520a5d96d792bf3edae401f7e3ae39942d /www/tomcat7
parentc8837d33f55863031450931b51547eac493ec227 (diff)
downloadports-37e7803cfd98f167bf4975f2cae5f841e7e4e99c.tar.gz
ports-37e7803cfd98f167bf4975f2cae5f841e7e4e99c.zip
Add support for custom wait time and increase the default to 30 seconds.
PR: ports/168442 Submitted by: Bruno Ribeiro da Silva <contato@brunoribeiro.org>
Notes
Notes: svn path=/head/; revision=299190
Diffstat (limited to 'www/tomcat7')
-rw-r--r--www/tomcat7/Makefile1
-rw-r--r--www/tomcat7/files/tomcat7.in7
2 files changed, 7 insertions, 1 deletions
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index a448830303cd..54f4a95aa2c1 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tomcat
PORTVERSION= 7.0.27
+PORTREVISION= 1
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-7/v${PORTVERSION}/bin
diff --git a/www/tomcat7/files/tomcat7.in b/www/tomcat7/files/tomcat7.in
index 46e7d7acfec8..0c1e89269432 100644
--- a/www/tomcat7/files/tomcat7.in
+++ b/www/tomcat7/files/tomcat7.in
@@ -54,6 +54,10 @@
# Set to "" by default.
# Java VM args to use.
#
+# tomcat7_wait (int):
+# Set to "30" by default.
+# Set the wait time (in seconds) for Tomcat process startup
+#
# You may symlink this script with other names to run multiple
# instances of tomcat7 with different configurations.
#
@@ -89,6 +93,7 @@ eval "_tomcat_logging_manager=\${${name}_logging_manager:-'org.apache.juli.Class
eval "_tomcat_logging_config=\${${name}_logging_config:-'${_tomcat_catalina_base}/conf/logging.properties'}"
eval "_tomcat_classpath=\${${name}_classpath:-''}"
eval "_tomcat_java_opts=\${${name}_java_opts:-''}"
+eval "_tomcat_wait=\${${name}_wait:-'30'}"
pidfile="/var/run/${name}.pid"
@@ -102,7 +107,7 @@ command_args="-java-home '${_tomcat_java_home}' \
-server \
-user ${_tomcat_catalina_user} \
-pidfile '${pidfile}' \
- -wait 10 \
+ -wait ${_tomcat_wait} \
-outfile '${_tomcat_stdout}' \
-errfile '${_tomcat_stderr}' \
-classpath '%%TOMCAT_HOME%%/bin/bootstrap.jar:%%LOCALBASE%%/share/java/classes/commons-daemon.jar:%%TOMCAT_HOME%%/bin/tomcat-juli.jar${_tomcat_classpath}' \