aboutsummaryrefslogtreecommitdiff
path: root/www/tomcat7
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2010-10-26 08:20:15 +0000
committerAlex Dupre <ale@FreeBSD.org>2010-10-26 08:20:15 +0000
commit7a2f226323bf35b0d373302b0d165a2f43e15b9d (patch)
tree3fd029a6831e0a7f64c57d6d5506584e874fabf4 /www/tomcat7
parent3a0afc777d76c2596c68cae6aafa9f41a5af6146 (diff)
downloadports-7a2f226323bf35b0d373302b0d165a2f43e15b9d.tar.gz
ports-7a2f226323bf35b0d373302b0d165a2f43e15b9d.zip
Update to 7.0.4 release.
Notes
Notes: svn path=/head/; revision=263606
Diffstat (limited to 'www/tomcat7')
-rw-r--r--www/tomcat7/Makefile2
-rw-r--r--www/tomcat7/distinfo6
-rw-r--r--www/tomcat7/files/tomcat7.in16
-rw-r--r--www/tomcat7/pkg-plist2
4 files changed, 17 insertions, 9 deletions
diff --git a/www/tomcat7/Makefile b/www/tomcat7/Makefile
index c4793562b293..dedfc954fe57 100644
--- a/www/tomcat7/Makefile
+++ b/www/tomcat7/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tomcat
-PORTVERSION= 7.0.2
+PORTVERSION= 7.0.4
CATEGORIES= www java
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-7/v${PORTVERSION}-beta/bin
diff --git a/www/tomcat7/distinfo b/www/tomcat7/distinfo
index 450e55916ffe..899c73abf44b 100644
--- a/www/tomcat7/distinfo
+++ b/www/tomcat7/distinfo
@@ -1,3 +1,3 @@
-MD5 (apache-tomcat-7.0.2.tar.gz) = 43b5ba6aec55dd9a30957e035d0aac5f
-SHA256 (apache-tomcat-7.0.2.tar.gz) = 9f48fffa64b16f4bb65701c467d73a068b4598110a5db66ef0bf347b32c37667
-SIZE (apache-tomcat-7.0.2.tar.gz) = 7022527
+MD5 (apache-tomcat-7.0.4.tar.gz) = 340d45b6fb906f6c9a585c2a15167daf
+SHA256 (apache-tomcat-7.0.4.tar.gz) = 000ca894359f41cfa15ba250ff440b78914ab88ab8cee59b4abc9e3d5fc63585
+SIZE (apache-tomcat-7.0.4.tar.gz) = 7066612
diff --git a/www/tomcat7/files/tomcat7.in b/www/tomcat7/files/tomcat7.in
index 08a192de893c..3faa9468bc85 100644
--- a/www/tomcat7/files/tomcat7.in
+++ b/www/tomcat7/files/tomcat7.in
@@ -136,19 +136,27 @@ tomcat_stop() {
tomcat_status() {
rc_pid=$(tomcat_check_pidfile $pidfile)
- if [ -z "$rc_pid" ]; then
- [ -n "$rc_fast" ] && return 0
- echo "${name} not running? (check $pidfile)."
+ if [ -n "$rc_pid" ]; then
+ echo "${name} is running as pid $rc_pid."
+ else
+ echo "${name} is not running."
return 1
fi
}
tomcat_poll() {
+ rc_pid=$(tomcat_check_pidfile $pidfile)
+
+ _prefix=
while (true) ; do
- rc_pid=$(tomcat_check_pidfile $pidfile)
[ -z "$rc_pid" ] && break
+ echo -n ${_prefix:-"Waiting for PIDS: "}$rc_pid
+ _prefix=", "
sleep 2
done
+ if [ -n "$_prefix" ]; then
+ echo "."
+ fi
}
tomcat_check_pidfile() {
diff --git a/www/tomcat7/pkg-plist b/www/tomcat7/pkg-plist
index a117d32fd02b..a6b46d92b011 100644
--- a/www/tomcat7/pkg-plist
+++ b/www/tomcat7/pkg-plist
@@ -62,7 +62,7 @@
%%T%%/webapps/ROOT/asf-logo-wide.gif
%%T%%/webapps/ROOT/build.xml
%%T%%/webapps/ROOT/favicon.ico
-%%T%%/webapps/ROOT/index.html
+%%T%%/webapps/ROOT/index.jsp
%%T%%/webapps/ROOT/tomcat-power.gif
%%T%%/webapps/ROOT/tomcat.gif
%%T%%/webapps/ROOT/tomcat.svg