aboutsummaryrefslogtreecommitdiff
path: root/www/trac-fivestarvote
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-12-31 18:21:31 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-12-31 18:21:31 +0000
commitdbf022d6297865ef5a9d354b4c50a0036d137bf6 (patch)
tree4d973e1646c770bf1cc23f75f9c5241961d8bb8d /www/trac-fivestarvote
parent9cd2c098103fbf92bbb14365ebb8a2139ddf32d0 (diff)
downloadports-dbf022d6297865ef5a9d354b4c50a0036d137bf6.tar.gz
ports-dbf022d6297865ef5a9d354b4c50a0036d137bf6.zip
The FiveStarVotePlugin is a modified version of the VotePlugin
(www/trac-vote). Instead of having up and down arrows, this plugin uses a 5-star approach to rate resources. WWW: http://trac-hacks.org/wiki/FiveStarVotePlugin
Notes
Notes: svn path=/head/; revision=246944
Diffstat (limited to 'www/trac-fivestarvote')
-rw-r--r--www/trac-fivestarvote/Makefile49
-rw-r--r--www/trac-fivestarvote/distinfo3
-rw-r--r--www/trac-fivestarvote/pkg-descr6
-rw-r--r--www/trac-fivestarvote/pkg-plist1
4 files changed, 59 insertions, 0 deletions
diff --git a/www/trac-fivestarvote/Makefile b/www/trac-fivestarvote/Makefile
new file mode 100644
index 000000000000..069aed793dda
--- /dev/null
+++ b/www/trac-fivestarvote/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: trac-fivestarvote
+# Date created: Dec 31, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+
+MAINTAINER= brooks@freebsd.org
+COMMENT= A 5 star plugin for voting on Trac resources
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_PKGNAME= FiveStarVote
+
+# Maintainter targets below this point
+
+# Retrieve the latest version from SVN and package in a tarball.
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ cd ${WRKDIR} && \
+ svn export http://trac-hacks.org/svn/fivestarvoteplugin/0.11/ \
+ ${DISTNAME}
+ cd ${WRKDIR} && tar cvf ${DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+# Create a pkg-plist after the package is installed.
+EGGDIR= ${PYTHON_SITELIBDIR}/${PYEASYINSTALL_EGG}
+PLIST_EGGDIR= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+build-plist:
+ ${FIND} ${EGGDIR} -type f | \
+ ${SED} -e 's|${EGGDIR}|${PLIST_EGGDIR}|' | \
+ ${SORT} > pkg-plist
+ ${FIND} ${EGGDIR} -type d | \
+ ${SED} -e 's|${EGGDIR}|@dirrm ${PLIST_EGGDIR}|' | \
+ ${SORT} -r >> pkg-plist
+
+.include <bsd.port.mk>
diff --git a/www/trac-fivestarvote/distinfo b/www/trac-fivestarvote/distinfo
new file mode 100644
index 000000000000..67e89373e213
--- /dev/null
+++ b/www/trac-fivestarvote/distinfo
@@ -0,0 +1,3 @@
+MD5 (fivestarvote-0.1.tar.gz) = ed79cbb389d3ebcdc51ce95e4b259faf
+SHA256 (fivestarvote-0.1.tar.gz) = a648d657b7af82e116244a943d79bb6604ed0212a3e6daae9e943076eac064ee
+SIZE (fivestarvote-0.1.tar.gz) = 19456
diff --git a/www/trac-fivestarvote/pkg-descr b/www/trac-fivestarvote/pkg-descr
new file mode 100644
index 000000000000..196fafd061da
--- /dev/null
+++ b/www/trac-fivestarvote/pkg-descr
@@ -0,0 +1,6 @@
+This plugin is a modified version of the VotePlugin (www/trac-vote).
+
+Instead of having up and down arrows, this plugin uses a 5-star approach
+to rate resources.
+
+WWW: http://trac-hacks.org/wiki/FiveStarVotePlugin
diff --git a/www/trac-fivestarvote/pkg-plist b/www/trac-fivestarvote/pkg-plist
new file mode 100644
index 000000000000..ddf68a1c022f
--- /dev/null
+++ b/www/trac-fivestarvote/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%