aboutsummaryrefslogtreecommitdiff
path: root/www/trac-keywords
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-09-11 11:23:24 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-09-11 11:23:24 +0000
commita0716f66e331ead22b3d9f147a2d7eb2cb8db0e3 (patch)
treeda22117bcedb6d2cfcfe0ef7b84b41fbbabba72d /www/trac-keywords
parent1804e65601509b4bb98d06c9dda9eba848d980ad (diff)
downloadports-a0716f66e331ead22b3d9f147a2d7eb2cb8db0e3.tar.gz
ports-a0716f66e331ead22b3d9f147a2d7eb2cb8db0e3.zip
This plugin allows for validating custom fields as dates in tickets.
WWW: http://trac-hacks.org/wiki/DateFieldPlugin PR: ports/150215 Submitted by: Eygene Ryabinkin <rea-fbsd at codelabs.ru>
Notes
Notes: svn path=/head/; revision=260963
Diffstat (limited to 'www/trac-keywords')
-rw-r--r--www/trac-keywords/Makefile42
-rw-r--r--www/trac-keywords/distinfo3
-rw-r--r--www/trac-keywords/files/patch-web_ui.py12
-rw-r--r--www/trac-keywords/pkg-descr3
4 files changed, 60 insertions, 0 deletions
diff --git a/www/trac-keywords/Makefile b/www/trac-keywords/Makefile
new file mode 100644
index 000000000000..cfb0eabb1522
--- /dev/null
+++ b/www/trac-keywords/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: trac-keywords
+# Date created: December 17, 2009
+# Whom: Eygene Ryabinkin <rea-fbsd@codelabs.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= keywords
+PORTVERSION= 0.2
+CATEGORIES= www python
+MASTER_SITES= http://dist.codelabs.ru/fbsd/
+PKGNAMEPREFIX= trac-
+DISTNAME= trackeywordsplugin-r${REL}
+
+MAINTAINER= rea-fbsd@codelabs.ru
+COMMENT= A plugin for using pre-configured keywords
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= trac>=0.11:${PORTSDIR}/www/trac
+
+USE_PYTHON= 2.5+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= TracKeywordsPlugin
+PYDISTUTILS_NOEGGINFO= yes
+WRKSRC= ${WRKDIR}/trackeywordsplugin/0.11
+REL= 7273
+PLIST_FILES= ${PYTHON_SITELIBDIR:S;${LOCALBASE}/;;}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+post-extract:
+# We must fix file permissions -- ZIP file have 0000 for every file.
+# Directory permissions are fine (they aren't stored inside ZIP
+# file), but we set them too -- just in case.
+ @${FIND} ${WRKSRC} -type f | ${XARGS} chmod 644
+ @${FIND} ${WRKSRC} -type d | ${XARGS} chmod 755
+# Fix misplaced Genshi template: https://trac-hacks.org/ticket/6104
+ @${MV} ${WRKDIR}/trackeywordsplugin/0.10/trackeywords/templates/keywords.html ${WRKSRC}/trackeywords/templates/
+# Seems like web_ui.py was misplaced too.
+ @${MV} ${WRKDIR}/trackeywordsplugin/0.10/trackeywords/web_ui.py ${WRKSRC}/trackeywords/
+
+.include <bsd.port.mk>
diff --git a/www/trac-keywords/distinfo b/www/trac-keywords/distinfo
new file mode 100644
index 000000000000..f35a19410fa6
--- /dev/null
+++ b/www/trac-keywords/distinfo
@@ -0,0 +1,3 @@
+MD5 (trackeywordsplugin-r7273.zip) = fc00fc7f8ca16fcf2b99267a06ebfa2f
+SHA256 (trackeywordsplugin-r7273.zip) = 64f4e88a96039cbcc35ae835d87ed2a9a1aa28e97281caa443092c52ad18f572
+SIZE (trackeywordsplugin-r7273.zip) = 9528
diff --git a/www/trac-keywords/files/patch-web_ui.py b/www/trac-keywords/files/patch-web_ui.py
new file mode 100644
index 000000000000..e7e5453552f3
--- /dev/null
+++ b/www/trac-keywords/files/patch-web_ui.py
@@ -0,0 +1,12 @@
+--- trackeywords/web_ui.py.orig 2009-09-09 17:18:34.000000000 +0400
++++ trackeywords/web_ui.py 2010-04-05 11:32:50.000000000 +0400
+@@ -80,7 +80,8 @@
+
+ # changed to Genshi signature
+ def post_process_request(self, req, template, data, content_type):
+- data['keywords'] = self._get_keywords()
++ if data is not None:
++ data['keywords'] = self._get_keywords()
+ return (template, data, content_type)
+
+ ### ITemplateProvider methods
diff --git a/www/trac-keywords/pkg-descr b/www/trac-keywords/pkg-descr
new file mode 100644
index 000000000000..f98c6226dd9d
--- /dev/null
+++ b/www/trac-keywords/pkg-descr
@@ -0,0 +1,3 @@
+This plugin allows for validating custom fields as dates in tickets.
+
+WWW: http://trac-hacks.org/wiki/DateFieldPlugin