aboutsummaryrefslogtreecommitdiff
path: root/www/trac-pagetopdf
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-03 14:29:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-03 14:29:35 +0000
commit1dcd8eadfd45cc933161bf419a05f5cee3fe722b (patch)
tree4dc699c3623719d7e42d9e0925b65a4b8f2eba95 /www/trac-pagetopdf
parent478bb82e082d7f6d9b00fd9710f93891439fb0e7 (diff)
downloadports-1dcd8eadfd45cc933161bf419a05f5cee3fe722b.tar.gz
ports-1dcd8eadfd45cc933161bf419a05f5cee3fe722b.zip
This plugin uses the new content conversion API in Trac's trunk to export Wiki
pages to a PDF. The link appers in the Download in other formats list at the bottom of Wiki pages. This plugin uses htmldoc to perform the conversion. WWW: http://trac-hacks.org/wiki/PageToPdfPlugin PR: ports/107270 Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Notes
Notes: svn path=/head/; revision=181332
Diffstat (limited to 'www/trac-pagetopdf')
-rw-r--r--www/trac-pagetopdf/Makefile31
-rw-r--r--www/trac-pagetopdf/distinfo3
-rw-r--r--www/trac-pagetopdf/pkg-descr7
-rw-r--r--www/trac-pagetopdf/pkg-plist1
4 files changed, 42 insertions, 0 deletions
diff --git a/www/trac-pagetopdf/Makefile b/www/trac-pagetopdf/Makefile
new file mode 100644
index 000000000000..5f83f3c0f934
--- /dev/null
+++ b/www/trac-pagetopdf/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: trac-pagetopdf
+# Date created: December 28 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pagetopdf
+PORTVERSION= 0.2
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/downloads/trac-hacks/
+PKGNAMEPREFIX= trac-
+DISTNAME= pagetopdfplugin
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Export trac wiki pages as PDFs
+
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
+ htmldoc:${PORTSDIR}/textproc/htmldoc
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_ZIP= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/0.10
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+do-build:
+ @${DO_NADA}
+
+.include <bsd.port.mk>
diff --git a/www/trac-pagetopdf/distinfo b/www/trac-pagetopdf/distinfo
new file mode 100644
index 000000000000..25b4df444611
--- /dev/null
+++ b/www/trac-pagetopdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (pagetopdfplugin.zip) = e94e47154d59d5ca015b9e2f0903e15e
+SHA256 (pagetopdfplugin.zip) = be837c9ea9550634a6296f5e57d7201a91816a120984db7e484956ffe650c9bf
+SIZE (pagetopdfplugin.zip) = 1545
diff --git a/www/trac-pagetopdf/pkg-descr b/www/trac-pagetopdf/pkg-descr
new file mode 100644
index 000000000000..24efcddb9b25
--- /dev/null
+++ b/www/trac-pagetopdf/pkg-descr
@@ -0,0 +1,7 @@
+This plugin uses the new content conversion API in Trac's trunk to export Wiki
+pages to a PDF. The link appers in the Download in other formats list at the
+bottom of Wiki pages.
+
+This plugin uses htmldoc to perform the conversion.
+
+WWW: http://trac-hacks.org/wiki/PageToPdfPlugin
diff --git a/www/trac-pagetopdf/pkg-plist b/www/trac-pagetopdf/pkg-plist
new file mode 100644
index 000000000000..ce32a437fa73
--- /dev/null
+++ b/www/trac-pagetopdf/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracPageToPDF-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg