aboutsummaryrefslogtreecommitdiff
path: root/www/trac-pydotorgtheme
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-30 19:40:47 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-30 19:40:47 +0000
commitd933f05f4feb1d4d1d7429752a1af8b686a5869c (patch)
tree52effad23f875e16c27da5b93f2410f24564632a /www/trac-pydotorgtheme
parent3d4530fc3fb1dc95535dac227c385a0cd540a91c (diff)
downloadports-d933f05f4feb1d4d1d7429752a1af8b686a5869c.tar.gz
ports-d933f05f4feb1d4d1d7429752a1af8b686a5869c.zip
- do not directly depend on setuptools, use USE_DISTUTILS instead
- bump PORTREVISION because of dependency change - remove indefinite article in COMMENT - trim Makefile header - limit python version to 2.x only PR: 173106 Submitted by: rm (myself) Approved by: brooks (maintainer, by mail) Feature safe: yes
Notes
Notes: svn path=/head/; revision=306697
Diffstat (limited to 'www/trac-pydotorgtheme')
-rw-r--r--www/trac-pydotorgtheme/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/www/trac-pydotorgtheme/Makefile b/www/trac-pydotorgtheme/Makefile
index b010c4edf7ac..63d8f280e233 100644
--- a/www/trac-pydotorgtheme/Makefile
+++ b/www/trac-pydotorgtheme/Makefile
@@ -1,35 +1,24 @@
-# New ports collection makefile for: trac-pydotorgtheme
-# Date created: January 9, 2009
-# Whom: Brooks Davis <brooks@freebsd.org>
-#
+# Created by: Brooks Davis <brooks@freebsd.org>
# $FreeBSD$
-#
PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;:L}
PORTVERSION= 2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www devel python
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= brooks
PKGNAMEPREFIX= trac-
MAINTAINER= brooks@FreeBSD.org
-COMMENT= This is a theme that emulates the look of python.org
+COMMENT= Theme that emulates the look of python.org
RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac \
trac-themeengine>=2.0:${PORTSDIR}/www/trac-themeengine
-BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
-USE_PYTHON= 2.5+
-NO_BUILD= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= TracPyDotOrgTheme
-WRKSRC= ${WRKDIR}/${PORTNAME}
-PYDISTUTILS_NOEGGINFO= yes
-
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
-
-do-build:
- @${DO_NADA}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
.include <bsd.port.mk>