aboutsummaryrefslogtreecommitdiff
path: root/www/trac-xmlrpc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:40:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-05-27 19:40:11 +0000
commit405b2cea91e03e517d710fef6ec0b4ad9bdf7976 (patch)
treec423d09a011044ed4a7277aabb969ca283aeeaf0 /www/trac-xmlrpc
parent3a895cd247dd4294d1c79a6bfef6ef8a8dab2ce8 (diff)
downloadports-405b2cea91e03e517d710fef6ec0b4ad9bdf7976.tar.gz
ports-405b2cea91e03e517d710fef6ec0b4ad9bdf7976.zip
This plugin allows Trac plugins to export select parts of their interface via
XML-RPC. It also includes some exported functions for manipulating tickets, with plans to include interfaces to other parts of Trac's API. WWW: http://trac-hacks.org/wiki/XmlRpcPlugin Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Notes
Notes: svn path=/head/; revision=192105
Diffstat (limited to 'www/trac-xmlrpc')
-rw-r--r--www/trac-xmlrpc/Makefile27
-rw-r--r--www/trac-xmlrpc/distinfo3
-rw-r--r--www/trac-xmlrpc/pkg-descr7
-rw-r--r--www/trac-xmlrpc/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/www/trac-xmlrpc/Makefile b/www/trac-xmlrpc/Makefile
new file mode 100644
index 000000000000..8236970c29d0
--- /dev/null
+++ b/www/trac-xmlrpc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: trac-xmlrpc
+# Date created: May 18 2007
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlrpc
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://www.gerritbeine.de/download/trac/
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Provides an xml rpc interface to Trac
+
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS+= tracd:${PORTSDIR}/www/trac
+
+WRKSRC= ${WRKDIR}/${PORTNAME}plugin
+NO_BUILD= yes
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PLIST_SUB+= PORTVERSION=${PORTVERSION} PYTHONVERSION=${_PYTHON_VERSION}
+
+.include <bsd.port.mk>
diff --git a/www/trac-xmlrpc/distinfo b/www/trac-xmlrpc/distinfo
new file mode 100644
index 000000000000..8d729c20572b
--- /dev/null
+++ b/www/trac-xmlrpc/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmlrpcplugin-0.1.tar.gz) = f7bc2121cb22efa738757af7436f19b2
+SHA256 (xmlrpcplugin-0.1.tar.gz) = 6eb21c477372a1014972cd38de09955edd5954a4caeb6081ad21f269c8e99611
+SIZE (xmlrpcplugin-0.1.tar.gz) = 8882
diff --git a/www/trac-xmlrpc/pkg-descr b/www/trac-xmlrpc/pkg-descr
new file mode 100644
index 000000000000..cda1d210dcd8
--- /dev/null
+++ b/www/trac-xmlrpc/pkg-descr
@@ -0,0 +1,7 @@
+This plugin allows Trac plugins to export select parts of their interface via
+XML-RPC.
+
+It also includes some exported functions for manipulating tickets, with plans
+to include interfaces to other parts of Trac's API.
+
+WWW: http://trac-hacks.org/wiki/XmlRpcPlugin
diff --git a/www/trac-xmlrpc/pkg-plist b/www/trac-xmlrpc/pkg-plist
new file mode 100644
index 000000000000..70bae0049e44
--- /dev/null
+++ b/www/trac-xmlrpc/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/TracXMLRPC-%%PORTVERSION%%-py%%PYTHONVERSION%%.egg