aboutsummaryrefslogtreecommitdiff
path: root/www/trac
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-07 07:11:22 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-07 07:11:22 +0000
commit9ff4ffd62472a96915c1a30ec56509d4186a09cb (patch)
tree09e074a7f1a06351b0654234ff629ccdf5ba1231 /www/trac
parentb2999e935c12508d79dacf71e768c5c67c8320ee (diff)
downloadports-9ff4ffd62472a96915c1a30ec56509d4186a09cb.tar.gz
ports-9ff4ffd62472a96915c1a30ec56509d4186a09cb.zip
- add knobs for compiling with pgsql backend and add knob for compiling without
subversion for sites who doesn't use it PR: ports/109998 Submitted by: Radim Kolar SF dot NET <hsn_AT_sendmail dot cz>
Notes
Notes: svn path=/head/; revision=186772
Diffstat (limited to 'www/trac')
-rw-r--r--www/trac/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/www/trac/Makefile b/www/trac/Makefile
index ababe5ccc04f..dea94e8ce830 100644
--- a/www/trac/Makefile
+++ b/www/trac/Makefile
@@ -14,13 +14,13 @@ MASTER_SITES= http://ftp.edgewall.com/pub/trac/ \
MAINTAINER= clsung@FreeBSD.org
COMMENT= An enhanced wiki and issue tracking system for software projects
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite20 \
- ${PYTHON_SITELIBDIR}/neo_cgi.so:${PORTSDIR}/www/clearsilver-python \
- ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/subversion-python
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/neo_cgi.so:${PORTSDIR}/www/clearsilver-python
RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= SILVERCITY "Use Silvercity for syntax highlighting" On \
- DOCUTILS "Allow additional text markup" On
+ DOCUTILS "Allow additional text markup" On \
+ PGSQL "Use PostgreSQL instead of SQLite3" Off \
+ SUBVERSION "Support for subversion RCS" On
CONFLICTS= ja-trac-*
USE_PYTHON= yes
@@ -54,4 +54,14 @@ RUN_DEPENDS+= ${PREFIX}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
RUN_DEPENDS+= ${PREFIX}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
.endif
+.if defined(WITH_PGSQL)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
+.else
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite20
+.endif
+
+.if !defined(WITHOUT_SUBVERSION)
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/subversion-python
+.endif
+
.include <bsd.port.post.mk>