aboutsummaryrefslogtreecommitdiff
path: root/www/trac
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-07 16:53:45 +0000
commitb7df0651651ef059fd4db24d7b77113e72ad6c15 (patch)
treee492c56fa7379da1ca224d6c3b1e9a31bdf1f7d9 /www/trac
parentf391ca611e4a642fc3b0e7df30f4a60b63f60b71 (diff)
downloadports-b7df0651651ef059fd4db24d7b77113e72ad6c15.tar.gz
ports-b7df0651651ef059fd4db24d7b77113e72ad6c15.zip
- Convert to OptionsNG
- Trim header Reviewed by: bapt
Notes
Notes: svn path=/head/; revision=313599
Diffstat (limited to 'www/trac')
-rw-r--r--www/trac/Makefile71
1 files changed, 36 insertions, 35 deletions
diff --git a/www/trac/Makefile b/www/trac/Makefile
index 87d1a9c2b13e..1e624d02b258 100644
--- a/www/trac/Makefile
+++ b/www/trac/Makefile
@@ -16,12 +16,13 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Genshi>=0.5:${PORTSDIR}/textproc/py-genshi \
${PYTHON_PKGNAMEPREFIX}Babel>=0.9:${PORTSDIR}/devel/py-babel
-OPTIONS= SILVERCITY "Use Silvercity for syntax highlighting" On \
- DOCUTILS "Allow additional text markup" On \
- PYGMENTS "Use generic syntax highlighter" On \
- TZ "Process Time Zones" On \
- PGSQL "Use PostgreSQL instead of SQLite3" Off \
- SUBVERSION "Support for subversion RCS" On
+OPTIONS_DEFINE= SILVERCITY DOCUTILS PYGMENTS TZ PGSQL SVN
+OPTIONS_DEFAULT= SILVERCITY DOCUTILS PYGMENTS TZ SVN
+SILVERCITY_DESC= Silvercity for syntax highlighting
+DOCUTILS_DESC= Allow additional text markup
+PYGMENTS_DESC= Use generic syntax highlighter
+TZ_DESC= Process Time Zones
+
CONFLICTS= ja-trac-[0-9]*
USE_PYTHON= 2.5+
@@ -32,6 +33,34 @@ PYDISTUTILS_NOEGGINFO= yes
USE_RC_SUBR= tracd
SUB_LIST= PYTHON_CMD=${PYTHON_CMD}
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSILVERCITY)
+RUN_DEPENDS+= ${LOCALBASE}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
+.endif
+
+.if ${PORT_OPTIONS:MDOCUTILS)
+RUN_DEPENDS+= ${LOCALBASE}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
+.endif
+
+.if ${PORT_OPTIONS:MPYGMENTS}
+RUN_DEPENDS+= ${LOCALBASE}/bin/pygmentize:${PORTSDIR}/textproc/py-pygments
+.endif
+
+.if ${PORT_OPTIONS:MTZ}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
+.endif
+
+.if ${PORT_OPTIONS:MPGSQL}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
+.endif
+
+.if ${PORT_OPTIONS:MSVN}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/py-subversion
+.endif
+
# This target is only meant to be used by the port maintainer.
x-generate-plist:
(${PORTSDIR}/Tools/scripts/plist -d -m ${MTREE_FILE} ${PREFIX} \
@@ -62,32 +91,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SILVERCITY)
-RUN_DEPENDS+= ${LOCALBASE}/bin/source2html.py:${PORTSDIR}/textproc/silvercity
-.endif
-
-.if defined(WITH_DOCUTILS)
-RUN_DEPENDS+= ${LOCALBASE}/bin/rst2html:${PORTSDIR}/textproc/py-docutils
-.endif
-
-.if defined(WITH_PYGMENTS)
-RUN_DEPENDS+= ${LOCALBASE}/bin/pygmentize:${PORTSDIR}/textproc/py-pygments
-.endif
-
-.if defined(WITH_TZ)
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz
-.endif
-
-.if defined(WITH_PGSQL)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psycopg2/__init__.py:${PORTSDIR}/databases/py-psycopg2
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
-.endif
-
-.if !defined(WITHOUT_SUBVERSION)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/svn/__init__.py:${PORTSDIR}/devel/py-subversion
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>