aboutsummaryrefslogtreecommitdiff
path: root/www/tt-rss/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:40:02 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-09-23 02:40:02 +0000
commit3f4ad595fb218a768cecf71e18904ab2bdee1d4c (patch)
treeba7ac4bb1c0cddd5965eb411f6d688078e6d3c85 /www/tt-rss/Makefile
parentb30abcc31456a9284980ab9402efba8b9693803d (diff)
downloadports-3f4ad595fb218a768cecf71e18904ab2bdee1d4c.tar.gz
ports-3f4ad595fb218a768cecf71e18904ab2bdee1d4c.zip
Tiny Tiny RSS is an open source web-based news feed (RSS/Atom) aggregator,
designed to allow you to read news from any location, while feeling as close to a real desktop application as possible. It can be seen as a replacement for Google Reader. WWW: http://tt-rss.org/ PR: ports/150246 Submitted by: Thierry Thomas <thierry at pompo.net>
Notes
Notes: svn path=/head/; revision=261671
Diffstat (limited to 'www/tt-rss/Makefile')
-rw-r--r--www/tt-rss/Makefile92
1 files changed, 92 insertions, 0 deletions
diff --git a/www/tt-rss/Makefile b/www/tt-rss/Makefile
new file mode 100644
index 000000000000..d5a8c3b83393
--- /dev/null
+++ b/www/tt-rss/Makefile
@@ -0,0 +1,92 @@
+# New ports collection makefile for: tt-rss
+# Date created: 18 August 2010
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tt-rss
+PORTVERSION= 1.4.2
+CATEGORIES= www
+MASTER_SITES= http://tt-rss.org/download/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Tiny Tiny RSS: web-based news feed (RSS/Atom) aggregator
+
+NO_BUILD= yes
+
+USE_GETTEXT= yes
+USE_PHP= mbstring pcntl session xmlrpc
+WANT_PHP_WEB= yes
+WANT_PHP_CLI= yes
+REINPLACE_ARGS= -i ""
+
+USE_RC_SUBR= ttrssd
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+DB= pgsql
+.else
+USE_PHP+= mysql
+DB= mysql
+.endif
+
+.if !defined(WITHOUT_CURL)
+USE_PHP+= curl
+.endif
+
+LICENSE= GPLv2
+
+SUB_FILES= httpd-tt-rss.conf pkg-message
+SUB_LIST= DB=${DB}
+PLIST_SUB= WWWOWN=${WWWOWN}:${WWWGRP}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PHP2FIX= config.php-dist update_daemon.php update_daemon2.php \
+ update_daemon_loop.php update_feedbrowser.php update_feeds.php
+
+SCRIPTS= update-translations.sh update_daemon.php update_daemon2.php \
+ update_daemon_loop.php update_feedbrowser.php update_feeds.php
+
+pre-everything::
+ @${ECHO_MSG}
+ @${ECHO_MSG} " By default, Tiny Tiny RSS will use MySQL as a back-end;"
+ @${ECHO_MSG} " define WITH_PGSQL if you prefer PostgreSQL."
+ @${ECHO_MSG}
+ @${ECHO_MSG} " CURL is required for SimplePie, but if you prefer Magpie,"
+ @${ECHO_MSG} " you can define WITHOUT_CURL."
+ @${ECHO_MSG}
+
+pre-configure:
+.for script in ${PHP2FIX}
+ ${REINPLACE_CMD} -e 's|/usr/bin/php|${LOCALBASE}/bin/php|' \
+ ${WRKSRC}/${script}
+.endfor
+
+do-configure:
+.if !defined(WITH_PGSQL)
+ ${REINPLACE_CMD} -e '/DB_TYPE/s|pgsql|mysql|;s|mysql$$|pgsql|' \
+ ${WRKSRC}/config.php-dist
+.endif
+ ${REINPLACE_CMD} -e '/SINGLE_USER_MODE/s|true|false|' \
+ -e '/ENABLE_UPDATE_DAEMON/s|false|true|' \
+ ${WRKSRC}/config.php-dist
+
+do-install:
+ ${MKDIR} ${WWWDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${WWWDIR})
+ ${RM} ${WWWDIR}/LICENSE
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ ${CHMOD} ug+x ${SCRIPTS:S|^|${WWWDIR}/|}
+ ${INSTALL_DATA} ${WRKDIR}/httpd-tt-rss.conf ${DATADIR}
+ if [ ! -f ${WWWDIR}/config.php ]; then \
+ ${CP} -p ${WWWDIR}/config.php-dist ${WWWDIR}/config.php; \
+ ${CHMOD} go-r ${WWWDIR}/config.php; \
+ fi
+
+post-install:
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include <bsd.port.mk>