aboutsummaryrefslogtreecommitdiff
path: root/www/twhttpd
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 07:58:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 07:58:23 +0000
commit5dc666089a5386ca95cbca7dfaf44abed918378d (patch)
treeab4fd4a47def57b1fa9edb3541340d22438f8096 /www/twhttpd
parentb97052ed340eff6f8ce8a61f3e6960229a2e6edf (diff)
downloadports-5dc666089a5386ca95cbca7dfaf44abed918378d.tar.gz
ports-5dc666089a5386ca95cbca7dfaf44abed918378d.zip
Final step in the move from mail/twhttpd to www/twhttpd.
Notes
Notes: svn path=/head/; revision=72363
Diffstat (limited to 'www/twhttpd')
-rw-r--r--www/twhttpd/Makefile27
-rw-r--r--www/twhttpd/distinfo1
-rw-r--r--www/twhttpd/files/patch-aa11
-rw-r--r--www/twhttpd/files/patch-ab16
-rw-r--r--www/twhttpd/files/patch-ac11
-rw-r--r--www/twhttpd/files/patch-ad11
-rw-r--r--www/twhttpd/pkg-comment1
-rw-r--r--www/twhttpd/pkg-descr14
-rw-r--r--www/twhttpd/pkg-message5
-rw-r--r--www/twhttpd/pkg-plist3
10 files changed, 100 insertions, 0 deletions
diff --git a/www/twhttpd/Makefile b/www/twhttpd/Makefile
new file mode 100644
index 000000000000..bf83ff974d2b
--- /dev/null
+++ b/www/twhttpd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: twhttpd-1.0
+# Date created: 25 Sep 2002
+# Whom: Pieter Danhieux <opr@bsdaemon.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= twhttpd
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.geocities.com/samngms/twhttpd/download/
+DISTNAME= twhttpd-${PORTVERSION}
+
+MAINTAINER= opr@bsdaemon.be
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOCONF= yes
+
+do-install:
+ @${INSTALL_PROGRAM} -o root -g wheel -m 0755 ${WRKSRC}/twhttpd ${PREFIX}/sbin/twhttpd
+ @${INSTALL} -o root -g wheel -m 0755 ${WRKSRC}/rm_cache ${PREFIX}/sbin/rm_cache
+ @${INSTALL} -o root -g wheel -m 0700 ${WRKSRC}/twhttpd.cfg ${PREFIX}/etc/twhttpd.cfg.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+.include <bsd.port.mk>
diff --git a/www/twhttpd/distinfo b/www/twhttpd/distinfo
new file mode 100644
index 000000000000..3acf24d49358
--- /dev/null
+++ b/www/twhttpd/distinfo
@@ -0,0 +1 @@
+MD5 (twhttpd-1.0.tar.gz) = 09b49b470e689fc1e5917b9503cea71d
diff --git a/www/twhttpd/files/patch-aa b/www/twhttpd/files/patch-aa
new file mode 100644
index 000000000000..919d055e56f1
--- /dev/null
+++ b/www/twhttpd/files/patch-aa
@@ -0,0 +1,11 @@
+--- config.h.orig Sat Aug 31 05:40:23 2002
++++ config.h Wed Sep 25 12:01:58 2002
+@@ -31,7 +31,7 @@
+ #define CURRENT_DIR "./"
+ #define DEFAULT_CACHE_DIR ".cache"
+ #define DEFAULT_COOKIE_DIR ".cookie"
+-#define DEFAULT_CONFIG_FILE "/etc/twhttpd.cfg"
++#define DEFAULT_CONFIG_FILE "/usr/local/etc/twhttpd.cfg"
+
+ #define SOCKET_TIMEOUT 45 /* socket timeout value */
+ #define CONNECT_TIMEOUT 15 /* connect timeout value */
diff --git a/www/twhttpd/files/patch-ab b/www/twhttpd/files/patch-ab
new file mode 100644
index 000000000000..21c2a4f895ab
--- /dev/null
+++ b/www/twhttpd/files/patch-ab
@@ -0,0 +1,16 @@
+--- httplog.c.orig Sat Dec 8 15:15:44 2001
++++ httplog.c Wed Sep 25 12:02:28 2002
+@@ -40,6 +40,7 @@
+ #include <time.h>
+ #include <stdio.h>
+ #include <syslog.h>
++#include <arpa/inet.h>
+ #include <netinet/in.h>
+ #include <sys/time.h>
+ #include <sys/socket.h>
+@@ -151,4 +152,4 @@
+ }
+ }
+ }
+-}
++}
diff --git a/www/twhttpd/files/patch-ac b/www/twhttpd/files/patch-ac
new file mode 100644
index 000000000000..a663815b5f49
--- /dev/null
+++ b/www/twhttpd/files/patch-ac
@@ -0,0 +1,11 @@
+--- twhttpd.c.orig Sat Aug 31 05:16:35 2002
++++ twhttpd.c Wed Sep 25 12:02:49 2002
+@@ -33,7 +33,7 @@
+ #include <signal.h>
+ #include <time.h>
+ #include <unistd.h>
+-#include <wait.h>
++#include <sys/wait.h>
+ #include <netinet/in.h>
+ #include <sys/socket.h>
+ #include <sys/types.h>
diff --git a/www/twhttpd/files/patch-ad b/www/twhttpd/files/patch-ad
new file mode 100644
index 000000000000..3d5ace1c5058
--- /dev/null
+++ b/www/twhttpd/files/patch-ad
@@ -0,0 +1,11 @@
+--- configure.in.orig Wed Sep 25 12:41:35 2002
++++ configure.in Wed Sep 25 12:41:44 2002
+@@ -8,7 +8,7 @@
+ AC_PROG_LEX
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(pwdb, crypt)
++AC_CHECK_LIB(crypt, crypt)
+ AC_CHECK_LIB(socket, bind)
+ AC_CHECK_LIB(nsl, gethostbyname)
+
diff --git a/www/twhttpd/pkg-comment b/www/twhttpd/pkg-comment
new file mode 100644
index 000000000000..635dbe9311dc
--- /dev/null
+++ b/www/twhttpd/pkg-comment
@@ -0,0 +1 @@
+Secure HTTP Proxy
diff --git a/www/twhttpd/pkg-descr b/www/twhttpd/pkg-descr
new file mode 100644
index 000000000000..3cb9f05ea657
--- /dev/null
+++ b/www/twhttpd/pkg-descr
@@ -0,0 +1,14 @@
+twhttpd is a powerful secure HTTP proxy.
+twhttpd protects your internal Web server by acting as an inbound proxy
+(like a reserve Squid proxy). It can also work as a secure outbound proxy
+to protect your browser client. It allows you to inspect almost every
+detail of the HTTP protocol headers, including the URL request line, the
+server version, user-agent, referrer, cookie, query, etc., in a
+easy-to-use script-like configuration file.
+This program is generally considered an "Expert Tool"; you will need
+knowledge of the HTTP protocol to configure the proxy properly.
+
+WWW: http://www.geocities.com/samngms/twhttpd/
+
+- Pieter
+opr@bsdaemon.be
diff --git a/www/twhttpd/pkg-message b/www/twhttpd/pkg-message
new file mode 100644
index 000000000000..92e87913862d
--- /dev/null
+++ b/www/twhttpd/pkg-message
@@ -0,0 +1,5 @@
+***************************************************************************
+twhttpd is installed in /usr/local/sbin/
+Now copy /usr/local/etc/twhttpd.cfg.sample to twhttpd.cfg,
+and edit it.
+***************************************************************************
diff --git a/www/twhttpd/pkg-plist b/www/twhttpd/pkg-plist
new file mode 100644
index 000000000000..e0c8911ac315
--- /dev/null
+++ b/www/twhttpd/pkg-plist
@@ -0,0 +1,3 @@
+sbin/twhttpd
+sbin/rm_cache
+etc/twhttpd.cfg.sample