aboutsummaryrefslogtreecommitdiff
path: root/www/twig
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-07-06 14:25:55 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-07-06 14:25:55 +0000
commit4c120a48d48f3e3f1f1f4ac8fce87074a935610a (patch)
treefd5e80391916125587ca5f4a88d4df7da00ed2a3 /www/twig
parent2dea7c57542a12dad85836f17623c3fa417cc9b2 (diff)
downloadports-4c120a48d48f3e3f1f1f4ac8fce87074a935610a.tar.gz
ports-4c120a48d48f3e3f1f1f4ac8fce87074a935610a.zip
- new option WITHOUT_PHP_DEPENDS
- make use of USE_PHP - unbreak for apache2
Notes
Notes: svn path=/head/; revision=113065
Diffstat (limited to 'www/twig')
-rw-r--r--www/twig/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/www/twig/Makefile b/www/twig/Makefile
index 259d00a21600..569fec18295b 100644
--- a/www/twig/Makefile
+++ b/www/twig/Makefile
@@ -14,18 +14,18 @@ MASTER_SITES= http://www.informationgateway.org/download/
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Web Based Email Client and Scheduler
+.if !defined(WITHOUT_PHP_DEPENDS)
.if !defined(WITH_PHP3)
-RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/${PHP4_PORT}
+USE_PHP= yes
.else
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp3.so:${PORTSDIR}/${PHP3_PORT}
.endif
+.endif
NO_BUILD= YES
PHP_PORT?= www/mod_php4-twig
-PHP4_PORT?= www/mod_php4-twig
PHP3_PORT?= www/mod_php3
TWIG?= www/data-dist/twig
-POSTGRESQL_PORT?= databases/postgresql7
PLIST_SUB+= TWIG=${TWIG}
ROOTFILES= index.php3 test.php3 goto.php3
CONFFILES= .htaccess mailfooter.inc.php3.sample
@@ -34,14 +34,6 @@ USERFILES= announcements.inc.php3 config.inc.php3 dbconfig.inc.php3 \
images.inc.php3 login.footer.inc.php3 login.form.php3 \
login.header.inc.php3 mainmenu.inc.php3 newusergroups.inc.php3
-.if defined(WITH_APACHE2)
-pre-everything::
- @${ECHO_CMD} "#"
- @${ECHO_CMD} "# this ports does not support Apache2"
- @${ECHO_CMD} "#"
- @${FALSE}
-.endif
-
do-install:
-${MKDIR} ${PREFIX}/${TWIG}/config
@(cd ${WRKSRC} && ${CP} ${ROOTFILES} ${PREFIX}/${TWIG}/ )