aboutsummaryrefslogtreecommitdiff
path: root/www/varnish
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2010-05-04 18:15:51 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2010-05-04 18:15:51 +0000
commit84fef87a1fbb56647b7f9c8c8fd89a9496dde5b6 (patch)
tree81297c2bd117d1aa5c2ced03b2e71cd4cfb7c8a9 /www/varnish
parentac3d94975568b2a3301b77da7386b3b749aa0221 (diff)
downloadports-84fef87a1fbb56647b7f9c8c8fd89a9496dde5b6.tar.gz
ports-84fef87a1fbb56647b7f9c8c8fd89a9496dde5b6.zip
Add upstream revision r4758: fix a bug that may cause Varnish to append
junk at the end of a chunk-encoded reply.
Notes
Notes: svn path=/head/; revision=253697
Diffstat (limited to 'www/varnish')
-rw-r--r--www/varnish/Makefile1
-rw-r--r--www/varnish/files/patch-r475813
2 files changed, 14 insertions, 0 deletions
diff --git a/www/varnish/Makefile b/www/varnish/Makefile
index e7e76b2410f4..672a788395c1 100644
--- a/www/varnish/Makefile
+++ b/www/varnish/Makefile
@@ -7,6 +7,7 @@
PORTNAME= varnish
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= SF
diff --git a/www/varnish/files/patch-r4758 b/www/varnish/files/patch-r4758
new file mode 100644
index 000000000000..3603d37e2054
--- /dev/null
+++ b/www/varnish/files/patch-r4758
@@ -0,0 +1,13 @@
+Index: bin/varnishd/cache_response.c
+===================================================================
+--- bin/varnishd/cache_response.c (revision 4757)
++++ bin/varnishd/cache_response.c (revision 4758)
+@@ -325,7 +325,7 @@
+ }
+ if (ptr + len > high)
+ /* Chop tail of segment off */
+- len = 1 + high - low;
++ len = 1 + high - ptr;
+
+ ptr += len;
+