aboutsummaryrefslogtreecommitdiff
path: root/www/vdr-plugin-live
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-06-19 18:42:12 +0000
commit06a1a754bf11f8d8bd5f7a48aaca173bf6cef618 (patch)
treec52fc6c0fdf6d98bbdbfaa0ad6db66308f0a2d76 /www/vdr-plugin-live
parentd95ff34009ff04c9b302834a93a37e7ff36b1f8e (diff)
downloadports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.tar.gz
ports-06a1a754bf11f8d8bd5f7a48aaca173bf6cef618.zip
- Update multimedia/vdr and multimedia/vdr-plugins to 1.7.28 .
- Update xineliboutput XKeySym.Pause key in example remote.conf. ("space" instead of "Space") - Add multimedia/vdr-plugin-extrecmenu 1.2.2 to vdr-plugins metaport. - Update multimedia/vdr-plugin-skinenigmang to 0.1.2s20120606 git snapshot. - Update www/vdr-plugin-live to 0.2.0s20120325 git snapshot. - Bump PORTREVISION for all other plugins and add api fixes where necessary. - Add HISTORY to PORTDOCS for most plugins. (those that have it) - Remove shlib major versions from LIB_DEPENDS to pet portlint.
Notes
Notes: svn path=/head/; revision=299655
Diffstat (limited to 'www/vdr-plugin-live')
-rw-r--r--www/vdr-plugin-live/Makefile6
-rw-r--r--www/vdr-plugin-live/distinfo4
-rw-r--r--www/vdr-plugin-live/files/gen_version_suffix.h7
-rw-r--r--www/vdr-plugin-live/files/patch-Makefile11
-rw-r--r--www/vdr-plugin-live/files/patch-tasks.cpp30
5 files changed, 51 insertions, 7 deletions
diff --git a/www/vdr-plugin-live/Makefile b/www/vdr-plugin-live/Makefile
index 92239bd55c91..2664aa419585 100644
--- a/www/vdr-plugin-live/Makefile
+++ b/www/vdr-plugin-live/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= vdr-plugin-live
-PORTVERSION= 0.2.0s20110303
-PORTREVISION= 8
+PORTVERSION= 0.2.0s20120325
CATEGORIES= www multimedia
MASTER_SITES= http://live.vdr-developer.org/downloads/:release \
LOCAL/nox/:snapshot
@@ -22,7 +21,7 @@ LIB_DEPENDS+= tntnet:${PORTSDIR}/www/tntnet \
USE_BZIP2= yes
PATCH_STRIP= -p1
-PORTDOCS= COPYING README
+PORTDOCS= COPYING README HISTORY
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/vdr-plugin-${PLUGIN}
VDR_PLUGIN_MAKEFILES= ${WRKSRC}/httpd/Makefile ${WRKSRC}/pages/Makefile
@@ -31,6 +30,7 @@ MAKE_ARGS+= INCLUDES="-I$(LOCALBASE)/include -I${WRKSRC}"
.include "${.CURDIR}/../../multimedia/vdr/Makefile.plugins"
post-patch: post-patch-plugin
+ ${CP} ${FILESDIR}/gen_version_suffix.h ${WRKSRC}
post-install: post-install-pluginlocales
(cd ${WRKSRC}/${PLUGIN} && \
diff --git a/www/vdr-plugin-live/distinfo b/www/vdr-plugin-live/distinfo
index f5053a5271dc..10a3de05686c 100644
--- a/www/vdr-plugin-live/distinfo
+++ b/www/vdr-plugin-live/distinfo
@@ -1,2 +1,2 @@
-SHA256 (vdr/vdr-live-0.2.0s20110303.tar.bz2) = d1a50c8c25f1b8a563c14f8c94cddd61a53764484322d177c506954e6f993462
-SIZE (vdr/vdr-live-0.2.0s20110303.tar.bz2) = 1995550
+SHA256 (vdr/vdr-live-0.2.0s20120325.tar.bz2) = 1c6d226a87930832cd836635214e1fecc6527ddbfd67d5d0ec1c974b12da2733
+SIZE (vdr/vdr-live-0.2.0s20120325.tar.bz2) = 2010190
diff --git a/www/vdr-plugin-live/files/gen_version_suffix.h b/www/vdr-plugin-live/files/gen_version_suffix.h
new file mode 100644
index 000000000000..1e0133ad759d
--- /dev/null
+++ b/www/vdr-plugin-live/files/gen_version_suffix.h
@@ -0,0 +1,7 @@
+/* ATTENTION: this file is automatically generated and will be overwritten!
+ * Manual changes will get lost!
+ */
+#ifndef GEN_VERSION_SUFFIX_H
+#define GEN_VERSION_SUFFIX_H
+#define VERSION_SUFFIX "_git_master_94a0a21_20120325164212+0200"
+#endif
diff --git a/www/vdr-plugin-live/files/patch-Makefile b/www/vdr-plugin-live/files/patch-Makefile
index e65d8489b57e..50e6f0d6bc04 100644
--- a/www/vdr-plugin-live/files/patch-Makefile
+++ b/www/vdr-plugin-live/files/patch-Makefile
@@ -1,6 +1,13 @@
--- a/Makefile
+++ b/Makefile
-@@ -151,7 +151,11 @@ $(VERSIONSUFFIX): FORCE
+@@ -155,12 +155,16 @@ $(SUBDIRS):
+ PAGES:
+ @$(MAKE) -C pages PLUGINFEATURES="$(PLUGINFEATURES)" .dependencies
+
+-$(VERSIONSUFFIX): FORCE
+- ./buildutil/version-util $(VERSIONSUFFIX) || ./buildutil/version-util -F $(VERSIONSUFFIX)
++#$(VERSIONSUFFIX): FORCE
++# ./buildutil/version-util $(VERSIONSUFFIX) || ./buildutil/version-util -F $(VERSIONSUFFIX)
libvdr-$(PLUGIN).so: $(VERSIONSUFFIX) $(SUBDIRS) $(PLUGINOBJS)
$(CXX) $(LDFLAGS) -shared -o $@ $(PLUGINOBJS) -Wl,--whole-archive $(WEBLIBS) -Wl,--no-whole-archive $(LIBS)
@@ -12,7 +19,7 @@
ifneq ($(TNTVERS7),yes)
@echo ""
-@@ -189,6 +193,9 @@ clean: $(SUBDIRS)
+@@ -198,6 +202,9 @@ clean: $(SUBDIRS)
@-rm -f $(PLUGINOBJS) $(DEPFILE) *.so *.tgz core* *~
@-rm -f $(VERSIONSUFFIX)
diff --git a/www/vdr-plugin-live/files/patch-tasks.cpp b/www/vdr-plugin-live/files/patch-tasks.cpp
new file mode 100644
index 000000000000..a3f1aff2ff9e
--- /dev/null
+++ b/www/vdr-plugin-live/files/patch-tasks.cpp
@@ -0,0 +1,30 @@
+--- a/tasks.cpp
++++ b/tasks.cpp
+@@ -60,9 +60,15 @@ void PlayRecordingTask::Action()
+
+ const char *current = NowReplaying();
+ if (!current || (0 != strcmp(current, recording->FileName()))) {
++#if APIVERSNUM < 10728
+ cReplayControl::SetRecording( 0, 0 );
+ cControl::Shutdown();
+ cReplayControl::SetRecording( recording->FileName(), recording->Title() );
++#else
++ cReplayControl::SetRecording( 0 );
++ cControl::Shutdown();
++ cReplayControl::SetRecording( recording->FileName() );
++#endif
+ cControl::Launch( new cReplayControl );
+ cControl::Attach();
+ }
+@@ -122,7 +128,11 @@ void StopRecordingTask::Action()
+ return;
+ }
+
++#if APIVERSNUM < 10728
+ cReplayControl::SetRecording( 0, 0 );
++#else
++ cReplayControl::SetRecording( 0 );
++#endif
+ cControl::Shutdown();
+ }
+