aboutsummaryrefslogtreecommitdiff
path: root/www/w3-4
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1997-06-10 09:58:54 +0000
committerSatoshi Asami <asami@FreeBSD.org>1997-06-10 09:58:54 +0000
commit7ca69fdf614e75d1b35fb7f0306df9c82c0854c8 (patch)
tree59d38e7604189c1c098f475cb47065d5e6e942e9 /www/w3-4
parent0239ce812621a78e76729ce56134d492d61ef349 (diff)
downloadports-7ca69fdf614e75d1b35fb7f0306df9c82c0854c8.tar.gz
ports-7ca69fdf614e75d1b35fb7f0306df9c82c0854c8.zip
Update dir file with install-info. Also, change organization so that
files can be shared between this port and japanese/w3. Note this is a "blind" commit; it is too much trouble to test an update with this many added and deleted files. I'll test it later. PR: 3788 Submitted by: <kiri@kiri.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=6842
Diffstat (limited to 'www/w3-4')
-rw-r--r--www/w3-4/Makefile54
-rw-r--r--www/w3-4/distinfo2
-rw-r--r--www/w3-4/files/DEINSTALL.tmpl31
-rw-r--r--www/w3-4/files/INSTALL.tmpl112
-rw-r--r--www/w3-4/files/dot.emacs.tmpl8
-rw-r--r--www/w3-4/files/patch-aa25
-rw-r--r--www/w3-4/files/user-install.tmpl11
-rw-r--r--www/w3-4/pkg-plist3
8 files changed, 228 insertions, 18 deletions
diff --git a/www/w3-4/Makefile b/www/w3-4/Makefile
index 4f32e49d6b87..0d5c81b0e8ec 100644
--- a/www/w3-4/Makefile
+++ b/www/w3-4/Makefile
@@ -7,32 +7,68 @@
#
DISTNAME= w3-2.2.26
-CATEGORIES= www
-MASTER_SITES= ftp://ftp.cs.indiana.edu/pub/elisp/w3/ \
- ftp://ftp.iij.ad.jp/pub/network/WWW/w3/
+CATEGORIES?= www
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/network/WWW/w3/ \
+ ftp://ftp.cs.indiana.edu/pub/elisp/w3/
MAINTAINER= kiri@kiri.toba-cmt.ac.jp
-BUILD_DEPENDS= emacs:${PORTSDIR}/editors/emacs
-RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs
+BUILD_DEPENDS?= emacs:${PORTSDIR}/editors/emacs
+RUN_DEPENDS?= emacs:${PORTSDIR}/editors/emacs
WRKSRC= ${WRKDIR}/w3
+MAKE_ENV+= EMACSCMD=${EMACSCMD} ELISPDIR=${ELISPDIR} \
+ MKDIR="${MKDIR}" CP=${CP} \
+ INFODIR=${INFODIR} \
+ INSTALL_DATA="${INSTALL_DATA}"
-DOCDIR= ${PREFIX}/share/doc/w3
+VERSION= 2.2.26
+EMACSCMD?= emacs
+PORTSDOCDIR= ${PREFIX}/share/doc/w3
SAMPLEDIR= ${PREFIX}/share/examples/w3
+ELISPDIR?= ${PREFIX}/share/emacs/site-lisp
+INFODIR= ${PREFIX}/info
+ADDIR= ${X11BASE}/lib/X11/app-defaults
+DIRSECTION= The Emacs editor and associated tools
+INFOFILE= w3.info
+
+post-build:
+.for f in DEINSTALL INSTALL dot.emacs user-install
+ @${SED} -e "s,%VERSION%,${VERSION},g" \
+ -e "s,%PREFIX%,${PREFIX},g" \
+ -e "s,%INFODIR%,${INFODIR},g" \
+ -e "s,%ELISPDIR%,${ELISPDIR},g" \
+ -e "s,%INFOFILE%,${INFOFILE},g" \
+ -e "s,%ADDIR%,${ADDIR},g" \
+ -e "s,%TOUCH%,${TOUCH},g" \
+ -e "s,%MKDIR%,${MKDIR},g" \
+ -e "s,%SAMPLEDIR%,${SAMPLEDIR},g" \
+ -e "s,%DIRSECTION%,${DIRSECTION},g" \
+ < ${FILESDIR}/${f}.tmpl > ${FILESDIR}/${f}
+.endfor
+ @${CP} ${FILESDIR}/DEINSTALL ${FILESDIR}/INSTALL ${PKGDIR}
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCDIR}
+ @${MKDIR} ${PORTSDOCDIR}
@${MKDIR} ${SAMPLEDIR}
.for f in dot.emacs dot.mosaic-hotlist-default
@${INSTALL_DATA} ${FILESDIR}/${f} ${SAMPLEDIR}
.endfor
@${INSTALL_SCRIPT} ${FILESDIR}/user-install ${SAMPLEDIR}
.for f in W3.ad clean-cache Makefile w3.txi
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PORTSDOCDIR}
.endfor
.endif
- @${SETENV} PKG_PREFIX=${PREFIX} /bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+ @${SETENV} MKDIR="${MKDIR}" TOUCH=${TOUCH} \
+ INFODIR=${INFODIR} INFOFILE=${INFOFILE} \
+ ELISPDIR=${ELISPDIR} ADDIR=${ADDIR} \
+ DIRSECTION="${DIRSECTION}" \
+ /bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+
+pre-clean:
+ @${RM} -f ${FILESDIR}/DEINSTALL ${FILESDIR}/INSTALL \
+ ${FILESDIR}/dot.emacs ${FILESDIR}/user-install \
+ ${PKGDIR}/DEINSTALL ${PKGDIR}/INSTALL
.include <bsd.port.mk>
diff --git a/www/w3-4/distinfo b/www/w3-4/distinfo
index 461238b90fcf..90db576bc408 100644
--- a/www/w3-4/distinfo
+++ b/www/w3-4/distinfo
@@ -1 +1 @@
-MD5 (w3-2.2.26.tar.gz) = e12d158809b8084bd0dc3491610b0a43
+MD5 (w3-2.2.26.tar.gz) = b53c81896353eec79911455d67d24339
diff --git a/www/w3-4/files/DEINSTALL.tmpl b/www/w3-4/files/DEINSTALL.tmpl
new file mode 100644
index 000000000000..48f1b91fd511
--- /dev/null
+++ b/www/w3-4/files/DEINSTALL.tmpl
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+infodir=${INFODIR:-%INFODIR%}
+infofile=${INFOFILE:-%INFOFILE%}
+elispdir=${ELISPDIR:-%ELISPDIR%}
+addir=${ADDIR:-%ADDIR%}
+
+if [ "X$2" = X"DEINSTALL" ]; then
+ echo "Deleting \"w3\" entry from ${infodir}/dir"
+ install-info --delete ${infodir}/${infofile} ${infodir}/dir
+ OptionStart=";;; Emacs-w3 configuration options"
+ OptionEnd=";;; End of Emacs-w3 configuration options"
+ if [ "`grep \"^${OptionStart}\" ${elispdir}/site-start.el`" ]; then
+ echo "Deleting \"w3\" entry from ${elispdir}/site-start.el"
+ sed -e "/^${OptionStart}/,/^${OptionEnd}/d"\
+ ${elispdir}/site-start.el \
+ > ${elispdir}/site-start.el.bak
+ mv ${elispdir}/site-start.el.bak ${elispdir}/site-start.el
+ fi
+ OptionStart="!!! Emacs-w3 configuration options"
+ OptionEnd="!!! End of Emacs-w3 configuration options"
+ if [ "`grep \"^${OptionStart}\" ${addir}/Emacs`" ]; then
+ echo "Deleting \"w3\" entry from ${addir}/Emacs"
+ sed -e 's/^![ ]*\(Emacs\*w3-.*\)$/&/' \
+ -e "/^${OptionStart}/,/^${OptionEnd}/d" \
+ ${addir}/Emacs > ${addir}/Emacs.bak
+ mv ${addir}/Emacs.bak ${addir}/Emacs
+ fi
+else
+ exit 0
+fi
diff --git a/www/w3-4/files/INSTALL.tmpl b/www/w3-4/files/INSTALL.tmpl
new file mode 100644
index 000000000000..29a0802fec7c
--- /dev/null
+++ b/www/w3-4/files/INSTALL.tmpl
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+TOUCH=${TOUCH:-%TOUCH%}
+MKDIR=${MKDIR:-"%MKDIR%"}
+
+infodir=${INFODIR:-%INFODIR%}
+infofile=${INFOFILE:-%INFOFILE%}
+elispdir=${ELISPDIR:-%ELISPDIR%}
+addir=${ADDIR:-%ADDIR%}
+
+dirsection=${DIRSECTION:-%DIRSECTION%}
+
+OptionStart="Emacs-w3 configuration options"
+OptionEnd="End of Emacs-w3 configuration options"
+
+if [ "X$2" = X"POST-INSTALL" ]; then
+ if [ ! -f ${elispdir}/site-start.el ]; then
+ ${TOUCH} ${elispdir}/site-start.el
+ fi
+ ${MKDIR} ${addir}
+ if [ ! -f ${addir}/Emacs ]; then
+ ${TOUCH} ${addir}/Emacs
+ fi
+ if [ ! "`grep \"START-INFO-DIR-ENTRY\" ${infodir}/${infofile}`" ]; then
+ echo "INFO-DIR-SECTION ${dirsection}" \
+ >> ${infodir}/${infofile}
+ echo "START-INFO-DIR-ENTRY" >> ${infodir}/${infofile}
+ echo "* w3: (`basename ${infofile} .info`). WWW browser." \
+ >> ${infodir}/${infofile}
+ echo "END-INFO-DIR-ENTRY" >> ${infodir}/${infofile}
+ fi
+ echo "Adding \"w3\" entry to ${infodir}/dir"
+ install-info ${infodir}/${infofile} ${infodir}/dir
+ sed -e "/^;;; ${OptionStart}/,/^;;; ${OptionEnd}/d" \
+ ${elispdir}/site-start.el > ${elispdir}/site-start.el.bak
+ mv ${elispdir}/site-start.el.bak ${elispdir}/site-start.el
+ echo "Adding \"w3\" entry to ${elispdir}/site-start.el"
+ echo ";;; ${OptionStart}" \
+ >> ${elispdir}/site-start.el
+ echo "(setq load-path " >> ${elispdir}/site-start.el
+ echo " (cons (expand-file-name " >> ${elispdir}/site-start.el
+ echo " \"${elispdir}/w3\") load-path))" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-preview-this-buffer \"w3\" \"WWW Previewer\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-follow-url-at-point" \
+ >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Find document at pt\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3 \"w3\" \"WWW Browser\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-open-local" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Open local file for WWW browsing\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-fetch" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Open remote file for WWW browsing\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-use-hotlist" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Use shortcuts to view WWW docs\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-show-hotlist" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Use shortcuts to view WWW docs\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-follow-link" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Follow a hypertext link.\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'w3-batch-fetch" >> ${elispdir}/site-start.el
+ echo " \"w3\" \"Batch retrieval of URLs\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'url-get-url-at-point" >> ${elispdir}/site-start.el
+ echo " \"url\" \"Find the url under the cursor\" nil)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'url-file-attributes" \
+ >> ${elispdir}/site-start.el
+ echo " \"url\" \"File attributes of a URL\" nil)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'url-popup-info" >> ${elispdir}/site-start.el
+ echo " \"url\" \"Get info on a URL\" t)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'url-retrieve" >> ${elispdir}/site-start.el
+ echo " \"url\" \"Retrieve a URL\" nil)" >> ${elispdir}/site-start.el
+ echo "(autoload 'url-buffer-visiting" \
+ >> ${elispdir}/site-start.el
+ echo " \"url\" \"Find buffer visiting a URL.\" nil)" \
+ >> ${elispdir}/site-start.el
+ echo "(autoload 'gopher-dispatch-object" \
+ >> ${elispdir}/site-start.el
+ echo " \"gopher\" \"Fetch gopher dir\" t)" \
+ >> ${elispdir}/site-start.el
+ echo ";;; ${OptionEnd}" \
+ >> ${elispdir}/site-start.el
+ if [ ! -f ${addir}/Emacs ]; then
+ touch ${addir}/Emacs
+ fi
+ sed -e 's/^![ ]*\(Emacs\*w3-.*\)$/&/' \
+ -e "/^!!! ${OptionStart}/,/^!!! ${OptionEnd}/d" \
+ ${addir}/Emacs > ${addir}/Emacs.bak
+ mv ${addir}/Emacs.bak ${addir}/Emacs
+ echo "Adding \"w3\" entry to ${addir}/Emacs"
+ sed -e 's/^[ ]*Emacs\*w3-.*$/! &/' ${addir}/Emacs \
+ > ${addir}/Emacs.bak
+ echo "!!! ${OptionStart}" >> ${addir}/Emacs.bak
+ echo "Emacs*w3-node-style.attributeForeground: purple" \
+ >> ${addir}/Emacs.bak
+ echo "Emacs*w3-visited-node-style.attributeForeground: blue" \
+ >> ${addir}/Emacs.bak
+ echo "!!! End of ${OptionStart}" >> ${addir}/Emacs.bak
+ mv ${addir}/Emacs.bak ${addir}/Emacs
+ exit 0
+else
+ exit 0
+fi
diff --git a/www/w3-4/files/dot.emacs.tmpl b/www/w3-4/files/dot.emacs.tmpl
new file mode 100644
index 000000000000..cba240257400
--- /dev/null
+++ b/www/w3-4/files/dot.emacs.tmpl
@@ -0,0 +1,8 @@
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;; Emacs-w3 ;;;;
+;; Emacs-w3(Ver.%VERSION%) ;;
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+(setq url-keep-history t)
+(setq url-be-asynchronous t)
+(setq w3-default-homepage
+ "file://localhost/usr/share/doc/handbook/handbook.html")
+;; Emacs-w3 end
diff --git a/www/w3-4/files/patch-aa b/www/w3-4/files/patch-aa
index 0429fd811d79..a1b9742daad1 100644
--- a/www/w3-4/files/patch-aa
+++ b/www/w3-4/files/patch-aa
@@ -1,22 +1,31 @@
---- Makefile.org Sun Oct 29 01:21:56 1995
-+++ Makefile Sun Dec 1 14:01:52 1996
-@@ -8,12 +8,13 @@
+--- Makefile.orig Sun Oct 29 01:21:56 1995
++++ Makefile Sat May 31 19:15:25 1997
+@@ -1,19 +1,19 @@
+ # what emacs is called on your system
+-EMACS = emacs
++EMACS = ${EMACSCMD}
+
+ # How to make a directory
+ # need a -p if you want to make the parents!
+-MKDIR = mkdir
++MKDIR ?= mkdir
+
# Various other stuff used
RM = rm -f
- CP = cp
-+INSTALL_DATA = /usr/bin/install -c -o bin -g bin -m 444
+-CP = cp
++CP ?= cp
# where the Info file should go
-INFODIR = ../info
-+INFODIR = ${PREFIX}/info
++INFODIR ?= ../info
# where the w3 lisp files should go
-LISPDIR = $$HOME/lisp
-+LISPDIR = ${PREFIX}/share/emacs/site-lisp/w3
++LISPDIR = ${ELISPDIR}/w3
# Change this to be where your .emacs file is stored
DOTEMACS = $$HOME/.emacs
-@@ -57,16 +58,16 @@
+@@ -57,16 +57,16 @@
w3: docomp.el $(OBJECTS)
@echo Build of w3 complete...
diff --git a/www/w3-4/files/user-install.tmpl b/www/w3-4/files/user-install.tmpl
new file mode 100644
index 000000000000..118f0b23da11
--- /dev/null
+++ b/www/w3-4/files/user-install.tmpl
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+SAMPLEDIR=%SAMPLEDIR%
+
+if [ ! -f ${HOME}/.mosaic-hotlist-default ]; then
+ cp ${SAMPLEDIR}/dot.mosaic-hotlist-default ${HOME}/.mosaic-hotlist-default
+fi
+
+mv ${HOME}/.emacs ${HOME}/.emacs.org.$$
+sed -e '/^;;* Emacs-w3 ;*$/,/^;; *Emacs-w3 end$/d' < ${HOME}/.emacs.org.$$ > ${HOME}/.emacs
+cat ${SAMPLEDIR}/dot.emacs >> ${HOME}/.emacs
diff --git a/www/w3-4/pkg-plist b/www/w3-4/pkg-plist
index 260007213564..fc5171711519 100644
--- a/www/w3-4/pkg-plist
+++ b/www/w3-4/pkg-plist
@@ -68,3 +68,6 @@ share/emacs/site-lisp/w3/xbm-button.el
share/emacs/site-lisp/w3/xbm-button.elc
share/emacs/site-lisp/w3/xpm-button.el
share/emacs/site-lisp/w3/xpm-button.elc
+@dirrm share/emacs/site-lisp/w3
+@dirrm share/examples/w3
+@dirrm share/doc/w3