aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-04 11:09:49 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-04 11:09:49 +0000
commit4a95a318ed7282396cf8da4c44912d4d0c7f1b24 (patch)
tree28ae799e2f1df46be5d2e7780b008531e7dcf596 /www/webkit-gtk2
parent298502fbcda839d07dc2ba0411ff20ad8eac2bf6 (diff)
downloadports-4a95a318ed7282396cf8da4c44912d4d0c7f1b24.tar.gz
ports-4a95a318ed7282396cf8da4c44912d4d0c7f1b24.zip
Fix CVE-2014-1748.
PR: 205683 Security: 1091d2d1-cb2e-11e5-b14b-bcaec565249c
Notes
Notes: svn path=/head/; revision=408024
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile1
-rw-r--r--www/webkit-gtk2/files/patch-CVE-2014-174810
2 files changed, 11 insertions, 0 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 41c7ee32b1b6..8aed0db93305 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= webkit
PORTVERSION= 2.4.9
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://webkitgtk.org/releases/
PKGNAMESUFFIX= -gtk2
diff --git a/www/webkit-gtk2/files/patch-CVE-2014-1748 b/www/webkit-gtk2/files/patch-CVE-2014-1748
new file mode 100644
index 000000000000..b5cfda9f678c
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-CVE-2014-1748
@@ -0,0 +1,10 @@
+--- ./Source/WebCore/platform/ScrollView.cpp.orig 2016-01-05 21:53:38.202759000 +0100
++++ ./Source/WebCore/platform/ScrollView.cpp 2016-01-05 21:55:50.429266000 +0100
+@@ -1177,6 +1177,7 @@ void ScrollView::paint(GraphicsContext*
+ scrollViewDirtyRect.intersect(visibleAreaWithScrollbars);
+ context->translate(x(), y());
+ scrollViewDirtyRect.moveBy(-location());
++ context->clip(IntRect(IntPoint(), visibleAreaWithScrollbars.size()));
+
+ paintScrollbars(context, scrollViewDirtyRect);
+ }