aboutsummaryrefslogtreecommitdiff
path: root/www/webkit-gtk2
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-03-24 15:51:45 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-03-24 15:51:45 +0000
commit3e3724d9b04e2108ba96bef4a3d12fb72e3b2213 (patch)
tree932f74bc8cf5eee561e731c521742368f3ce2d9c /www/webkit-gtk2
parent92e918a4065128a5f8f2525e40d4b711310cd504 (diff)
downloadports-3e3724d9b04e2108ba96bef4a3d12fb72e3b2213.tar.gz
ports-3e3724d9b04e2108ba96bef4a3d12fb72e3b2213.zip
- Fix build on sparc64
Notes
Notes: svn path=/head/; revision=251445
Diffstat (limited to 'www/webkit-gtk2')
-rw-r--r--www/webkit-gtk2/Makefile4
-rw-r--r--www/webkit-gtk2/files/patch-JavaScriptCore-runtime_JSValue.h24
2 files changed, 26 insertions, 2 deletions
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 13ec8118bdcf..b04adbd37deb 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -50,8 +50,8 @@ OPTIONS= VIDEO "Enable video support" on \
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64 or sparc64
+.if ${ARCH} == "ia64"
+BROKEN= Does not compile on ia64
.endif
.if exists (${LOCALBASE}/lib/libicutu.so.43)
diff --git a/www/webkit-gtk2/files/patch-JavaScriptCore-runtime_JSValue.h b/www/webkit-gtk2/files/patch-JavaScriptCore-runtime_JSValue.h
new file mode 100644
index 000000000000..b2fc49091d85
--- /dev/null
+++ b/www/webkit-gtk2/files/patch-JavaScriptCore-runtime_JSValue.h
@@ -0,0 +1,24 @@
+--- JavaScriptCore/runtime/JSValue.h.orig 2010-03-24 09:42:34.000000000 +0100
++++ JavaScriptCore/runtime/JSValue.h 2010-03-24 09:44:47.000000000 +0100
+@@ -464,13 +464,21 @@
+ inline JSValue::JSValue(JSCell* ptr)
+ {
+ u.asBits.tag = CellTag;
++#if defined(__sparc64__)
++ u.asBits.payload = reinterpret_cast<int64_t>(ptr);
++#else
+ u.asBits.payload = reinterpret_cast<int32_t>(ptr);
++#endif
+ }
+
+ inline JSValue::JSValue(const JSCell* ptr)
+ {
+ u.asBits.tag = CellTag;
++#if defined(__sparc64__)
++ u.asBits.payload = reinterpret_cast<int64_t>(const_cast<JSCell*>(ptr));
++#else
+ u.asBits.payload = reinterpret_cast<int32_t>(const_cast<JSCell*>(ptr));
++#endif
+ }
+
+ inline JSValue::operator bool() const