aboutsummaryrefslogtreecommitdiff
path: root/www/webservices
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-03-20 08:54:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-03-20 08:54:35 +0000
commit872e2a923f64f02103378415616238e4a0118cdd (patch)
tree586408b705c56d709394fabf0a20bd8fdaaf8b51 /www/webservices
parentb91fb6f18152806cf4931fabcf8f4fdf0672f2e9 (diff)
downloadports-872e2a923f64f02103378415616238e4a0118cdd.tar.gz
ports-872e2a923f64f02103378415616238e4a0118cdd.zip
A collection of classes for implementing web services in Objective-C
A collection of classes for making and/or parsing XMLRPC and SOAP requests. This is intended to provide a framework for implementing web services, so this release also contains initial support for parsing/editing web service definitions (WSDL). LICENSE: LGPL2 or later WWW: http://www.gnustep.org/resources/downloads.php
Notes
Notes: svn path=/head/; revision=230466
Diffstat (limited to 'www/webservices')
-rw-r--r--www/webservices/Makefile27
-rw-r--r--www/webservices/distinfo3
-rw-r--r--www/webservices/pkg-descr10
-rw-r--r--www/webservices/pkg-plist48
4 files changed, 88 insertions, 0 deletions
diff --git a/www/webservices/Makefile b/www/webservices/Makefile
new file mode 100644
index 000000000000..53db2b84c342
--- /dev/null
+++ b/www/webservices/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: webservices
+# Date created: 25 Jan 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= webservices
+PORTVERSION= 0.2.0
+CATEGORIES= www gnustep
+MASTER_SITES= ${MASTER_SITE_GNUSTEP}
+MASTER_SITE_SUBDIR= libs
+DISTNAME= WebServices-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Classes for building web services
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_LOCAL_LIBRARIES}
+
+DEFAULT_LIBVERSION= 0.1
+
+.include <bsd.port.mk>
diff --git a/www/webservices/distinfo b/www/webservices/distinfo
new file mode 100644
index 000000000000..66270c16cae1
--- /dev/null
+++ b/www/webservices/distinfo
@@ -0,0 +1,3 @@
+MD5 (WebServices-0.2.0.tar.gz) = 1ece87cf7bc7eafd2dbbe7610b3affb5
+SHA256 (WebServices-0.2.0.tar.gz) = 0162118b82dbf04f9054f6c0168e6db6fa44f13f3e78aebdd1628ccd1d104d0f
+SIZE (WebServices-0.2.0.tar.gz) = 68542
diff --git a/www/webservices/pkg-descr b/www/webservices/pkg-descr
new file mode 100644
index 000000000000..6beb81bbec65
--- /dev/null
+++ b/www/webservices/pkg-descr
@@ -0,0 +1,10 @@
+A collection of classes for implementing web services in Objective-C
+
+A collection of classes for making and/or parsing XMLRPC and SOAP requests.
+This is intended to provide a framework for implementing web services,
+so this release also contains initial support for parsing/editing
+web service definitions (WSDL).
+
+LICENSE: LGPL2 or later
+
+WWW: http://www.gnustep.org/resources/downloads.php
diff --git a/www/webservices/pkg-plist b/www/webservices/pkg-plist
new file mode 100644
index 000000000000..574c080290e3
--- /dev/null
+++ b/www/webservices/pkg-plist
@@ -0,0 +1,48 @@
+Local/Library/Documentation/WebServices/ClassesTOC.gsdoc
+Local/Library/Documentation/WebServices/ClassesTOC.html
+Local/Library/Documentation/WebServices/ConstantsTOC.gsdoc
+Local/Library/Documentation/WebServices/ConstantsTOC.html
+Local/Library/Documentation/WebServices/GWSBinding.gsdoc
+Local/Library/Documentation/WebServices/GWSBinding.html
+Local/Library/Documentation/WebServices/GWSCoder.gsdoc
+Local/Library/Documentation/WebServices/GWSCoder.html
+Local/Library/Documentation/WebServices/GWSDocument.gsdoc
+Local/Library/Documentation/WebServices/GWSDocument.html
+Local/Library/Documentation/WebServices/GWSElement.gsdoc
+Local/Library/Documentation/WebServices/GWSElement.html
+Local/Library/Documentation/WebServices/GWSExtensibility.gsdoc
+Local/Library/Documentation/WebServices/GWSExtensibility.html
+Local/Library/Documentation/WebServices/GWSMessage.gsdoc
+Local/Library/Documentation/WebServices/GWSMessage.html
+Local/Library/Documentation/WebServices/GWSPort.gsdoc
+Local/Library/Documentation/WebServices/GWSPort.html
+Local/Library/Documentation/WebServices/GWSPortType.gsdoc
+Local/Library/Documentation/WebServices/GWSPortType.html
+Local/Library/Documentation/WebServices/GWSService.gsdoc
+Local/Library/Documentation/WebServices/GWSService.html
+Local/Library/Documentation/WebServices/GWSType.gsdoc
+Local/Library/Documentation/WebServices/GWSType.html
+Local/Library/Documentation/WebServices/MainIndex.html
+Local/Library/Documentation/WebServices/TypesAndConstants.gsdoc
+Local/Library/Documentation/WebServices/TypesAndConstants.html
+Local/Library/Documentation/WebServices/WebServices.html
+Local/Library/Documentation/WebServices/WebServices.igsdoc
+Local/Library/Documentation/WebServices/dependencies
+Local/Library/Documentation/WebServices/index.html
+Local/Library/Headers/WebServices/GWSBinding.h
+Local/Library/Headers/WebServices/GWSCoder.h
+Local/Library/Headers/WebServices/GWSConstants.h
+Local/Library/Headers/WebServices/GWSDocument.h
+Local/Library/Headers/WebServices/GWSElement.h
+Local/Library/Headers/WebServices/GWSExtensibility.h
+Local/Library/Headers/WebServices/GWSMessage.h
+Local/Library/Headers/WebServices/GWSPort.h
+Local/Library/Headers/WebServices/GWSPortType.h
+Local/Library/Headers/WebServices/GWSService.h
+Local/Library/Headers/WebServices/GWSType.h
+Local/Library/Headers/WebServices/WebServices.h
+Local/Library/Libraries/libWebServices.so
+Local/Library/Libraries/libWebServices.so.%%LIBVERSION%%
+Local/Library/Libraries/libWebServices.so.%%LIBVERSION%%.0
+@dirrm Local/Library/Headers/WebServices
+@dirrm Local/Library/Documentation/WebServices