aboutsummaryrefslogtreecommitdiff
path: root/www/wml
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-08-08 22:13:17 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-08-08 22:13:17 +0000
commitef98ae73657bfec6b744c9fa665a8b6119712657 (patch)
tree363614f00dc548cbd99bc75640ca5d2d995a3240 /www/wml
parent1882e9f8bbd47f94fed35bc75c6c1ae4d84d527a (diff)
downloadports-ef98ae73657bfec6b744c9fa665a8b6119712657.tar.gz
ports-ef98ae73657bfec6b744c9fa665a8b6119712657.zip
Don't spawn a process to run perl, but install perl arch-dependent files
in a standard directory. PR: ports/70091 Submitted by: myself Approved by: maintainer.
Notes
Notes: svn path=/head/; revision=115690
Diffstat (limited to 'www/wml')
-rw-r--r--www/wml/Makefile12
-rw-r--r--www/wml/files/patch-configure13
2 files changed, 15 insertions, 10 deletions
diff --git a/www/wml/Makefile b/www/wml/Makefile
index 9852325a43a9..8ff3e6aef232 100644
--- a/www/wml/Makefile
+++ b/www/wml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wml
PORTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES= www lang
MASTER_SITES= http://thewml.org/distrib/ \
ftp://thewml.org/distrib/
@@ -19,11 +20,12 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-perl=${PERL5}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
+ PERL_ARCH="${PERL_ARCH}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL_VER= 15
LIBTOOLFILES= wml_backend/p2_mp4h/configure
-PLIST_SUB+= ARCH=${LOCAL_PERL_ARCH}
+PLIST_SUB+= ARCH=${PERL_ARCH}
CAT1= wml_aux_txt2html.1 wml_aux_tidy.1 wml_p4_gm4.1
@@ -58,12 +60,6 @@ MAN7= wml_intro.7 wml_macros.7 wml_tutorial.7 wml_faq.7 wml_tags.7
.include <bsd.port.pre.mk>
-.if exists(${PERL5})
-LOCAL_PERL_ARCH!= ${PERL5} -MConfig -e 'print "$$Config{archname}"'
-.else
-LOCAL_PERL_ARCH= ${ARCH}-freebsd
-.endif
-
.if ${ARCH} == "amd64"
BROKEN= "Build fails on amd64 (needs to build shared libraries with -fPIC)"
.endif
diff --git a/www/wml/files/patch-configure b/www/wml/files/patch-configure
index a23ebc058d63..3611d692a270 100644
--- a/www/wml/files/patch-configure
+++ b/www/wml/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Sat May 8 01:58:52 2004
-+++ configure Sat May 8 01:58:59 2004
+--- configure.orig Fri Oct 18 23:44:21 2002
++++ configure Thu Aug 5 23:40:57 2004
@@ -1170,7 +1170,7 @@
esac
case " $ac_configure_args " in
@@ -9,3 +9,12 @@
esac
fi
done
+@@ -2740,7 +2740,7 @@
+
+ dummy:
+ @echo INSTALLPRIVLIB=`echo $(INSTALLPRIVLIB) | $(abs2prefix)`
+- @echo INSTALLARCHLIB=`echo $(INSTALLARCHLIB) | $(abs2prefix)`
++ @echo INSTALLARCHLIB=`echo $(INSTALLPRIVLIB) | $(abs2prefix)`/$(PERL_ARCH)
+ };
+ }
+ EOT