aboutsummaryrefslogtreecommitdiff
path: root/www/wsdlpull/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-03-18 04:19:55 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-03-18 04:19:55 +0000
commitf948827a03dfdb08dce09ac6af360911df8f8a4b (patch)
treed1356f3ec44416704db7f302874d0ed94d02005a /www/wsdlpull/Makefile
parent3e5a9e919c17a25c72daff426b5c18c8a6343186 (diff)
downloadports-f948827a03dfdb08dce09ac6af360911df8f8a4b.tar.gz
ports-f948827a03dfdb08dce09ac6af360911df8f8a4b.zip
add wsdlpull 1.6.1
C++ WSDL Parser
Notes
Notes: svn path=/head/; revision=131544
Diffstat (limited to 'www/wsdlpull/Makefile')
-rw-r--r--www/wsdlpull/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/www/wsdlpull/Makefile b/www/wsdlpull/Makefile
new file mode 100644
index 000000000000..eb5e60def6e5
--- /dev/null
+++ b/www/wsdlpull/Makefile
@@ -0,0 +1,41 @@
+# ex:ts=8
+# Ports collection makefile for: wsdlpull
+# Date created: Mar 18, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= wsdlpull
+PORTVERSION= 1.6.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= C++ WSDL Parser
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:R}
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/wsdl
+INSTALLS_SHLIB= yes
+
+DOCSDIR= ${PREFIX}/share/doc/wsdl
+PORTDOCS= *
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
+ -e "s,[$$][(]prefix[)]/docs,${DOCSDIR},"
+
+post-install:
+ @${FIND} ${PREFIX}/include/wsdl ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/wsdl -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>