aboutsummaryrefslogtreecommitdiff
path: root/www/wwwcount
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1996-09-06 14:18:28 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1996-09-06 14:18:28 +0000
commit944b0e3048913bd77e0c46c872d853bc0c3749e0 (patch)
tree4bd529221def3865a051aa4ee56a6cf2f48dd83a /www/wwwcount
parent4ba8d4d619dea69171540e36131aca3ac9f53fe7 (diff)
downloadports-944b0e3048913bd77e0c46c872d853bc0c3749e0.tar.gz
ports-944b0e3048913bd77e0c46c872d853bc0c3749e0.zip
Location changed
Better fit to FreeBSD directory structure NO_PACKAGE removed, hostname is in config files, not compiled in
Notes
Notes: svn path=/head/; revision=3746
Diffstat (limited to 'www/wwwcount')
-rw-r--r--www/wwwcount/Makefile11
-rw-r--r--www/wwwcount/files/patch-aa135
-rw-r--r--www/wwwcount/files/patch-ae69
-rw-r--r--www/wwwcount/pkg-plist33
4 files changed, 217 insertions, 31 deletions
diff --git a/www/wwwcount/Makefile b/www/wwwcount/Makefile
index 00b9f007acc2..e8b7f26954e2 100644
--- a/www/wwwcount/Makefile
+++ b/www/wwwcount/Makefile
@@ -3,21 +3,20 @@
# Date created: 16 May 1996
# Whom: ache
#
-# $Id: Makefile,v 1.3 1996/05/27 03:42:47 asami Exp $
+# $Id: Makefile,v 1.4 1996/05/27 03:44:31 asami Exp $
#
-# WWW site: http://www.semcor.com/~muquit/Count.html
+# WWW site: http://www.fccc.edu/users/muquit/Count.html
# For digit images look at:
-# http://cervantes.learningco.com/kevin/digits/index.html
+# http://www.digitmania.holowww.com/
DISTNAME= wwwcount2.3
PKGNAME= wwwcount-2.3
CATEGORIES+= www
-MASTER_SITES= ftp://warm.semcor.com/pub/muquit/wwwcount2.3/
+MASTER_SITES= http://www.fccc.edu/users/muquit/src/wwwcount2.3/
MAINTAINER= ache@FreeBSD.ORG
-NO_PACKAGE= yes # hostname compiled in
GNU_CONFIGURE= yes
IS_INTERACTIVE= yes
@@ -33,6 +32,6 @@ do-install:
cd ${WRKSRC}/utils; \
${INSTALL} -s -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} mkstrip ${PREFIX}/bin; \
${INSTALL} -c -m ${MANMODE} -o ${MANOWN} -g ${MANGRP} mkstrip.1 ${PREFIX}/man/man1; \
- ${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} mkstrip.sh ${PREFIX}/etc/Counter/digits
+ ${INSTALL} -c -m ${BINMODE} -o ${BINOWN} -g ${BINGRP} mkstrip.sh ${PREFIX}/lib/Counter/digits
.include <bsd.port.mk>
diff --git a/www/wwwcount/files/patch-aa b/www/wwwcount/files/patch-aa
index 65c95bb16fba..ad1f88ddfcf0 100644
--- a/www/wwwcount/files/patch-aa
+++ b/www/wwwcount/files/patch-aa
@@ -1,5 +1,5 @@
*** Count-config.orig Fri May 3 06:20:27 1996
---- Count-config Thu May 16 22:18:17 1996
+--- Count-config Fri Sep 6 18:05:28 1996
***************
*** 20,26 ****
trap 'echo '';echo "Interrupt Detected..exiting";rm -f "./Config.tmpl" 2>/dev/null;rm -f "./.alfcf" ;rm -f "./strict" 2>/dev/null;echo '';exit 1' 1 2 3 15
@@ -18,7 +18,7 @@
if [ ! -f "./VERSION" ]
then
***************
-*** 36,42 ****
+*** 36,48 ****
Version=`cat ./VERSION`
Basedir="wwwcount$Version"
ConfigH="config.h"
@@ -26,14 +26,27 @@
ConfigDir="conf"
ConfFile="count.cfg"
DigitDir="digits"
---- 36,42 ----
+ DataDir="data"
+! LogDir="Log"
+! LogFile="Count$Version.log"
+ RgbFile="./wcount/rgb.txt"
+ #allow_f_cr=0
+ #strict_mode=0
+--- 36,49 ----
Version=`cat ./VERSION`
Basedir="wwwcount$Version"
ConfigH="config.h"
! BaseDir="${PREFIX}/etc/Counter"
+! LibDir="${PREFIX}/lib/Counter"
ConfigDir="conf"
ConfFile="count.cfg"
DigitDir="digits"
+ DataDir="data"
+! LogDir="/var/log"
+! LogFile="Counter.log"
+ RgbFile="./wcount/rgb.txt"
+ #allow_f_cr=0
+ #strict_mode=0
***************
*** 114,120 ****
@@ -43,7 +56,7 @@
fi
until [ $answer = "y" -o $answer = "Y" -o $answer = "n" -o $answer = "N" ]
do
---- 114,120 ----
+--- 115,121 ----
if [ .$answer = . ]
then
@@ -52,6 +65,48 @@
until [ $answer = "y" -o $answer = "Y" -o $answer = "n" -o $answer = "N" ]
do
***************
+*** 245,251 ****
+ You need to enter the directory of the Log file.
+
+ EOB
+! echo $n "*Log directory [$BaseDir/$LogDir]:$c "
+ read newpath
+ if [ .$newpath != . ]
+ then
+--- 246,252 ----
+ You need to enter the directory of the Log file.
+
+ EOB
+! echo $n "*Log directory [$LogDir]:$c "
+ read newpath
+ if [ .$newpath != . ]
+ then
+***************
+*** 289,299 ****
+ echo "++++++++++++++++++++++++++++++"
+ echo "CgiBinDir=$CgiBinDir"
+ echo "BaseDir= $BaseDir"
+! echo "DigitDir= $BaseDir/$DigitDir"
+ echo "ConfDir = $BaseDir/$ConfigDir"
+ echo "ConfFile= $ConfFile"
+ echo "DataDir= $BaseDir/$DataDir"
+! echo "LogDir= $BaseDir/$LogDir"
+ echo "LogFile= $LogFile"
+ echo "++++++++++++++++++++++++++++++"
+
+--- 290,300 ----
+ echo "++++++++++++++++++++++++++++++"
+ echo "CgiBinDir=$CgiBinDir"
+ echo "BaseDir= $BaseDir"
+! echo "DigitDir= $LibDir/$DigitDir"
+ echo "ConfDir = $BaseDir/$ConfigDir"
+ echo "ConfFile= $ConfFile"
+ echo "DataDir= $BaseDir/$DataDir"
+! echo "LogDir= $LogDir"
+ echo "LogFile= $LogFile"
+ echo "++++++++++++++++++++++++++++++"
+
+***************
*** 302,308 ****
if [ .$answer = . ]
@@ -60,7 +115,7 @@
fi
until [ $answer = "y" -o $answer = "Y" -o $answer = "n" -o $answer = "N" ]
do
---- 302,308 ----
+--- 303,309 ----
if [ .$answer = . ]
then
@@ -68,3 +123,73 @@
fi
until [ $answer = "y" -o $answer = "Y" -o $answer = "n" -o $answer = "N" ]
do
+***************
+*** 338,345 ****
+ echo "#define ConfigDir \"$BaseDir/$ConfigDir\"" >> $ConfigH
+ echo "#define ConfigFile \"$ConfFile\"" >> $ConfigH
+ echo "#define DataDir \"$BaseDir/$DataDir\"" >> $ConfigH
+! echo "#define DigitDir \"$BaseDir/$DigitDir\"" >> $ConfigH
+! echo "#define LogDir \"$BaseDir/$LogDir\"" >> $ConfigH
+ echo "#define LogFile \"$LogFile\"" >> $ConfigH
+
+ cat<<EOX>>$ConfigH
+--- 339,346 ----
+ echo "#define ConfigDir \"$BaseDir/$ConfigDir\"" >> $ConfigH
+ echo "#define ConfigFile \"$ConfFile\"" >> $ConfigH
+ echo "#define DataDir \"$BaseDir/$DataDir\"" >> $ConfigH
+! echo "#define DigitDir \"$LibDir/$DigitDir\"" >> $ConfigH
+! echo "#define LogDir \"$LogDir\"" >> $ConfigH
+ echo "#define LogFile \"$LogFile\"" >> $ConfigH
+
+ cat<<EOX>>$ConfigH
+***************
+*** 381,387 ****
+ * so RGB names can be looked up, but yet not allow users to make constant
+ * use of this very ineffiecient lookup.
+ *****************************************************************************/
+! #define RgbMappingDict "$BaseDir/rgb.txt"
+ EOX
+
+ #if [ $allow_f_cr -eq 1 ]
+--- 382,388 ----
+ * so RGB names can be looked up, but yet not allow users to make constant
+ * use of this very ineffiecient lookup.
+ *****************************************************************************/
+! #define RgbMappingDict "$LibDir/rgb.txt"
+ EOX
+
+ #if [ $allow_f_cr -eq 1 ]
+***************
+*** 413,427 ****
+ ##
+ echo "creating variables template file $Tmpl for the install program.."
+ echo "BASE_DIR=\"$BaseDir\"" > $Tmpl
+ echo "CGIBIN_DIR=\"$CgiBinDir\"" >> $Tmpl
+ echo "CONFIG_FILE=\"$ConfFile\"" >> $Tmpl
+ echo "CONFIG_DIR=\"$BaseDir/$ConfigDir\"" >> $Tmpl
+! echo "DIGIT_DIR=\"$BaseDir/$DigitDir\"" >> $Tmpl
+ echo "DATA_DIR=\"$BaseDir/$DataDir\"" >> $Tmpl
+! echo "LOG_DIR=\"$BaseDir/$LogDir\"" >> $Tmpl
+ echo "LOG_FILE=\"$LogFile\"" >> $Tmpl
+ echo "RGB_FILE=\"$RgbFile\"" >> $Tmpl
+! echo "RGB_DIR=\"$BaseDir\"" >> $Tmpl
+ ##
+ # create template for install program --ends
+ ##
+--- 414,429 ----
+ ##
+ echo "creating variables template file $Tmpl for the install program.."
+ echo "BASE_DIR=\"$BaseDir\"" > $Tmpl
++ echo "LIB_DIR=\"$LibDir\"" >> $Tmpl
+ echo "CGIBIN_DIR=\"$CgiBinDir\"" >> $Tmpl
+ echo "CONFIG_FILE=\"$ConfFile\"" >> $Tmpl
+ echo "CONFIG_DIR=\"$BaseDir/$ConfigDir\"" >> $Tmpl
+! echo "DIGIT_DIR=\"$LibDir/$DigitDir\"" >> $Tmpl
+ echo "DATA_DIR=\"$BaseDir/$DataDir\"" >> $Tmpl
+! echo "LOG_DIR=\"$LogDir\"" >> $Tmpl
+ echo "LOG_FILE=\"$LogFile\"" >> $Tmpl
+ echo "RGB_FILE=\"$RgbFile\"" >> $Tmpl
+! echo "RGB_DIR=\"$LibDir\"" >> $Tmpl
+ ##
+ # create template for install program --ends
+ ##
diff --git a/www/wwwcount/files/patch-ae b/www/wwwcount/files/patch-ae
index eecea1e87d43..18c44adb6955 100644
--- a/www/wwwcount/files/patch-ae
+++ b/www/wwwcount/files/patch-ae
@@ -1,5 +1,5 @@
*** Count-install.orig Fri May 3 06:20:31 1996
---- Count-install Thu May 16 22:34:39 1996
+--- Count-install Fri Sep 6 18:05:28 1996
***************
*** 193,199 ****
@@ -85,7 +85,7 @@
until [ $answer != "x" ]
do
***************
-*** 298,304 ****
+*** 298,318 ****
# enter groud id -ends
##
echo "installing Count.cgi->$CGIBIN_DIR"
@@ -93,7 +93,21 @@
echo "installing $CONFIG_FILE->$CONFIG_DIR"
$INSTALL_PROG -c -o $UserId -g $GroupId -m 664 $CONFIG_FILE $CONFIG_DIR/$CONFIG_FILE
echo "installing sample datafile $SAMPLE_DAT->$DATA_DIR"
---- 298,304 ----
+ $INSTALL_PROG -c -o $UserId -g $GroupId -m 664 $SAMPLE_DAT $DATA_DIR/sample.dat
+ chmod 775 $DATA_DIR
+
+! echo "installing rgb.txt->$BASE_DIR"
+! $INSTALL_PROG -c -o $UserId -g $GroupId -m 644 $Rgbfile $BASE_DIR/rgb.txt
+
+! echo "creating Log directory $LOG_DIR"
+! ./mkdirhier $LOG_DIR
+! chown $UserId $LOG_DIR
+! chgrp $GroupId $LOG_DIR
+! chmod 775 $LOG_DIR
+
+ echo "installing image strip for digit style A->$DIGIT_DIR/A"
+ $INSTALL_PROG -c -o $UserId -g $GroupId -m 644 $DigitA/strip.gif\
+--- 298,317 ----
# enter groud id -ends
##
echo "installing Count.cgi->$CGIBIN_DIR"
@@ -101,8 +115,32 @@
echo "installing $CONFIG_FILE->$CONFIG_DIR"
$INSTALL_PROG -c -o $UserId -g $GroupId -m 664 $CONFIG_FILE $CONFIG_DIR/$CONFIG_FILE
echo "installing sample datafile $SAMPLE_DAT->$DATA_DIR"
+ $INSTALL_PROG -c -o $UserId -g $GroupId -m 664 $SAMPLE_DAT $DATA_DIR/sample.dat
+ chmod 775 $DATA_DIR
+
+! echo "installing rgb.txt->$RGB_DIR"
+! $INSTALL_PROG -c -o $UserId -g $GroupId -m 644 $Rgbfile $RGB_DIR/rgb.txt
+
+! echo "installing $LOG_FILE->$LOG_DIR"
+! touch $LOG_DIR/$LOG_FILE
+! chmod 644 $LOG_DIR/$LOG_FILE
+! chown $UserId.$GroupId $LOG_DIR/$LOG_FILE
+
+ echo "installing image strip for digit style A->$DIGIT_DIR/A"
+ $INSTALL_PROG -c -o $UserId -g $GroupId -m 644 $DigitA/strip.gif\
+***************
+*** 344,349 ****
+--- 343,350 ----
+ #chown -R $UserId.$GroupId $BASE_DIR
+ find $BASE_DIR -exec chown $UserId {} \;
+ find $BASE_DIR -exec chgrp $GroupId {} \;
++ find $LIB_DIR -exec chown $UserId {} \;
++ find $LIB_DIR -exec chgrp $GroupId {} \;
+ # echo "UserId=$UserId"
+ # echo "GroupId=$GroupId"
+ ;;
***************
-*** 358,364 ****
+*** 358,374 ****
EOM
echo "installing Count.cgi->$CGIBIN_DIR"
@@ -110,7 +148,17 @@
echo "installing $CONFIG_FILE->$CONFIG_DIR"
$INSTALL_PROG -c $CONFIG_FILE $CONFIG_DIR/$CONFIG_FILE
echo "installing sample datafile $SAMPLE_DAT->$DATA_DIR"
---- 358,364 ----
+ $INSTALL_PROG -c $SAMPLE_DAT $DATA_DIR/sample.dat
+
+! echo "installing rgb.txt->$BASE_DIR"
+! $INSTALL_PROG -c $Rgbfile $BASE_DIR/rgb.txt
+
+! echo "creating Log directory $LOG_DIR"
+! ./mkdirhier $LOG_DIR
+
+ echo "installing image strip for digit style A->$DIGIT_DIR/A"
+ $INSTALL_PROG -c $DigitA/strip.gif $DIGIT_DIR/A/strip.gif
+--- 359,376 ----
EOM
echo "installing Count.cgi->$CGIBIN_DIR"
@@ -118,3 +166,14 @@
echo "installing $CONFIG_FILE->$CONFIG_DIR"
$INSTALL_PROG -c $CONFIG_FILE $CONFIG_DIR/$CONFIG_FILE
echo "installing sample datafile $SAMPLE_DAT->$DATA_DIR"
+ $INSTALL_PROG -c $SAMPLE_DAT $DATA_DIR/sample.dat
+
+! echo "installing rgb.txt->$RGB_DIR"
+! $INSTALL_PROG -c $Rgbfile $RGB_DIR/rgb.txt
+
+! echo "installing $LOG_FILE->$LOG_DIR"
+! touch $LOG_DIR/$LOG_FILE
+! chmod 644 $LOG_DIR/$LOG_FILE
+
+ echo "installing image strip for digit style A->$DIGIT_DIR/A"
+ $INSTALL_PROG -c $DigitA/strip.gif $DIGIT_DIR/A/strip.gif
diff --git a/www/wwwcount/pkg-plist b/www/wwwcount/pkg-plist
index cc3787b13bcc..ed0e803e8c0b 100644
--- a/www/wwwcount/pkg-plist
+++ b/www/wwwcount/pkg-plist
@@ -6,22 +6,25 @@ etc/Counter/conf
etc/Counter/conf/count.cfg
etc/Counter/data
etc/Counter/data/sample.dat
-etc/Counter/Log
-etc/Counter/rgb.txt
-etc/Counter/digits
-etc/Counter/digits/A
-etc/Counter/digits/A/strip.gif
-etc/Counter/digits/B
-etc/Counter/digits/B/strip.gif
-etc/Counter/digits/C
-etc/Counter/digits/C/strip.gif
-etc/Counter/digits/D
-etc/Counter/digits/D/strip.gif
-etc/Counter/digits/D/lenna.gif
-etc/Counter/digits/E
-etc/Counter/digits/E/strip.gif
+lib/Counter/rgb.txt
+lib/Counter/digits
+lib/Counter/digits/A
+lib/Counter/digits/A/strip.gif
+lib/Counter/digits/B
+lib/Counter/digits/B/strip.gif
+lib/Counter/digits/C
+lib/Counter/digits/C/strip.gif
+lib/Counter/digits/D
+lib/Counter/digits/D/strip.gif
+lib/Counter/digits/D/lenna.gif
+lib/Counter/digits/E
+lib/Counter/digits/E/strip.gif
@owner bin
@group bin
-etc/Counter/digits/mkstrip.sh
+lib/Counter/digits/mkstrip.sh
bin/mkstrip
man/man1/mkstrip.1
+@exec touch /var/log/Counter.log
+@exec chown nobody.nobody /var/log/Counter.log
+@exec chmod 644 /var/log/Counter.log
+@unexec rm /var/log/Counter.log