aboutsummaryrefslogtreecommitdiff
path: root/www/wwwstat
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /www/wwwstat
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'www/wwwstat')
-rw-r--r--www/wwwstat/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/wwwstat/Makefile b/www/wwwstat/Makefile
index a99b5442b45d..4d95afad2786 100644
--- a/www/wwwstat/Makefile
+++ b/www/wwwstat/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wwwstat
PORTVERSION= 2.01
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= ftp://ftp.ics.uci.edu/pub/websoft/wwwstat/ \
ftp://ftp.gwdg.de/pub/misc/www-stat/websoft/wwwstat/
@@ -20,16 +20,16 @@ USE_APACHE_RUN= 22+
USES= perl5
MAKE_ENV+= PERL=${PERL}
SUB_FILES= pkg-message
-SUB_LIST= SITE_PERL=${SITE_PERL}
+SUB_LIST= SITE_PERL=${PREFIX}/${SITE_PERL}
BIN_FILES= monthly oldlog2new splitlog wwwerrs wwwstat
SPERL_FILES= domains.pl splitlog.rc wwwstat.rc
MAN1_FILES= wwwstat.1 splitlog.1
do-install:
- @${INSTALL_SCRIPT} ${BIN_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
- @${MKDIR} ${STAGEDIR}${SITE_PERL}
- @${INSTALL_DATA} ${SPERL_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${SITE_PERL}
- @${INSTALL_MAN} ${MAN1_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${BIN_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${INSTALL_DATA} ${SPERL_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
+ ${INSTALL_MAN} ${MAN1_FILES:S|^|${WRKSRC}/|} ${STAGEDIR}${PREFIX}/man/man1
.include <bsd.port.mk>