aboutsummaryrefslogtreecommitdiff
path: root/www/xpath2rss
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-22 18:39:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-22 18:39:44 +0000
commit30c3cdab5b3d033c0827d62f885fbe6d36d97400 (patch)
tree6a23f6585707cf51f3fe4932f5fbf67453f4968d /www/xpath2rss
parent88f2f815d37b8a986e7bf3662617a27547c09a1c (diff)
downloadports-30c3cdab5b3d033c0827d62f885fbe6d36d97400.tar.gz
ports-30c3cdab5b3d033c0827d62f885fbe6d36d97400.zip
add xpath2rss 0.7
HTML to RSS converter
Notes
Notes: svn path=/head/; revision=61748
Diffstat (limited to 'www/xpath2rss')
-rw-r--r--www/xpath2rss/Makefile30
-rw-r--r--www/xpath2rss/distinfo1
-rw-r--r--www/xpath2rss/pkg-comment1
-rw-r--r--www/xpath2rss/pkg-descr4
-rw-r--r--www/xpath2rss/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/www/xpath2rss/Makefile b/www/xpath2rss/Makefile
new file mode 100644
index 000000000000..d1c4fd3c2564
--- /dev/null
+++ b/www/xpath2rss/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: xpath2rss
+# Date created: Jun 23, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpath2rss
+PORTVERSION= 0.7
+CATEGORIES= www python
+MASTER_SITES= http://www.mnot.net/xpath2rss/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= ${PYXML}
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ (cd ${WRKSRC} ; ${INSTALL_SCRIPT} *.py ${PYTHON_SITELIBDIR})
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/xpath2rss/distinfo b/www/xpath2rss/distinfo
new file mode 100644
index 000000000000..5c22c87abf66
--- /dev/null
+++ b/www/xpath2rss/distinfo
@@ -0,0 +1 @@
+MD5 (xpath2rss-0.7.tgz) = fd52a08b776086a951827f89ad519023
diff --git a/www/xpath2rss/pkg-comment b/www/xpath2rss/pkg-comment
new file mode 100644
index 000000000000..9251ecb66142
--- /dev/null
+++ b/www/xpath2rss/pkg-comment
@@ -0,0 +1 @@
+HTML to RSS converter
diff --git a/www/xpath2rss/pkg-descr b/www/xpath2rss/pkg-descr
new file mode 100644
index 000000000000..9d9f95db1482
--- /dev/null
+++ b/www/xpath2rss/pkg-descr
@@ -0,0 +1,4 @@
+xpath2rss is Yet Another HTML->RSS scraper. This one's different in that
+instead of using regular expressions, as most do, it uses XPath.
+
+WWW: http://www.mnot.net/xpath2rss/
diff --git a/www/xpath2rss/pkg-plist b/www/xpath2rss/pkg-plist
new file mode 100644
index 000000000000..c6013ad9a9f5
--- /dev/null
+++ b/www/xpath2rss/pkg-plist
@@ -0,0 +1,5 @@
+bin/xpath2rss
+%%PYTHON_SITELIBDIR%%/HtmlDom.py
+%%PYTHON_SITELIBDIR%%/RSS.py
+%%PORTDOCS%%share/doc/xpath2rss/README
+%%PORTDOCS%%@dirrm share/doc/xpath2rss