aboutsummaryrefslogtreecommitdiff
path: root/www/xpi-adblock
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-11-15 07:43:23 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-11-15 07:43:23 +0000
commit9c30d81a5c9923d81ce07f12b57ee5615815b441 (patch)
tree52ea38b2f6937d9560ba612b0b1619b3d12de465 /www/xpi-adblock
parent5befbf427517c0ff80b38ce84876d45210e30c50 (diff)
downloadports-9c30d81a5c9923d81ce07f12b57ee5615815b441.tar.gz
ports-9c30d81a5c9923d81ce07f12b57ee5615815b441.zip
- Add a couple of targets to ease chrome.manifest generation
Notes
Notes: svn path=/head/; revision=177300
Diffstat (limited to 'www/xpi-adblock')
-rw-r--r--www/xpi-adblock/Makefile.xpi7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/xpi-adblock/Makefile.xpi b/www/xpi-adblock/Makefile.xpi
index 47c59347feeb..60b32995ee1c 100644
--- a/www/xpi-adblock/Makefile.xpi
+++ b/www/xpi-adblock/Makefile.xpi
@@ -200,3 +200,10 @@ xpi-plist: extract
then ${ECHO_CMD} %%XPI_XPIDIR%%/chrome.manifest >> ${PLIST} ; fi
@${FIND} -ds ${WRKSRC} -type d -not -name ${DISTNAME} | \
${SED} -e "s,^${WRKSRC},@dirrm %%XPI_XPIDIR%%," >> ${PLIST}
+
+xpi-pre-chrome:
+ @${CHMOD} g+w ${_TD_FULL}
+ @${RM} -f ${_TD_FULL}/chrome.manifest
+
+xpi-post-chrome:
+ @${CP} -f ${_TD_FULL}/chrome.manifest ${FILESDIR}/