aboutsummaryrefslogtreecommitdiff
path: root/www/xshttpd
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2007-03-22 16:27:08 +0000
committerJohan van Selst <johans@FreeBSD.org>2007-03-22 16:27:08 +0000
commit1e903d2f3b57f36ac4a2bb5dbe0a1d9aeffb77e5 (patch)
treed41ef6a7029320d09377b31babf52bf3411b475d /www/xshttpd
parent192cb8db921e5fb29d5240a156c33cd597f20687 (diff)
downloadports-1e903d2f3b57f36ac4a2bb5dbe0a1d9aeffb77e5.tar.gz
ports-1e903d2f3b57f36ac4a2bb5dbe0a1d9aeffb77e5.zip
Update to new stable release 34g01
Notes
Notes: svn path=/head/; revision=188034
Diffstat (limited to 'www/xshttpd')
-rw-r--r--www/xshttpd/Makefile35
-rw-r--r--www/xshttpd/distinfo6
-rw-r--r--www/xshttpd/pkg-plist4
3 files changed, 36 insertions, 9 deletions
diff --git a/www/xshttpd/Makefile b/www/xshttpd/Makefile
index 28d5a2a16c8c..9311852d0619 100644
--- a/www/xshttpd/Makefile
+++ b/www/xshttpd/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= xshttpd
-DISTVERSION= 3.3g01
-PORTREVISION= 1
-CATEGORIES= www
+DISTVERSION= 3.4g01
+CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.stack.nl/pub/xs-httpd/release/ \
ftp://mud.stack.nl/pub/xs-httpd/release/
DISTNAME= ${PORTNAME}-${DISTVERSION:S/.//}
@@ -22,7 +21,8 @@ CONFLICTS+= apache-[0-9]* xshttpd-devel-[0-9]*
MAN1= clearxs.1 gfxcount.1 httpd.1 httpdc.1 imagemap.1 \
readxs.1 xsindex.1 xspasswd.1
-MAN5= httpd.conf.5 xsauth.5 xsscripts.5
+MAN5= httpd.conf.5 xsauth.5 xsconf.5 xsscripts.5 xsredir.5
+USE_BZIP2= yes
USE_RC_SUBR= xshttpd.sh
GNU_CONFIGURE= yes
@@ -31,12 +31,16 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
OPTIONS= SSL "Enable https support" On \
LDAP "Enable ldap support" Off \
PCRE "Enable pcre rewriting support" Off \
+ CURL "Enable curl (proxy) support" Off \
+ M4_CONFIG "Enable m4 configuration preprocessor" Off \
PERSISTENT_PERL "Enable persistent perl interpreter" Off
+PORTDOCS= README BUGS COPYING ChangeLog
+
# By default XS-HTTPD stores its data in ${PREFIX}/lib/httpd
WWWDIR?= ${PREFIX}/www
PLIST_SUB= WWWDIR=${WWWDIR:S,^${PREFIX}/,,}
-CONFIGURE_ARGS+=--with-rootdir=${WWWDIR}
+CONFIGURE_ARGS+=--with-rootdir=${WWWDIR} --mandir=${MANPREFIX}/man
.include <bsd.port.pre.mk>
@@ -55,6 +59,12 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
CONFIGURE_ARGS+=--without-ldap
.endif
+.if defined(WITH_M4_CONFIG)
+CONFIGURE_ARGS+=--with-preprocessor
+.else
+CONFIGURE_ARGS+=--without-preprocessor
+.endif
+
.if defined(WITH_PERSISTENT_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+=--with-perl
@@ -69,6 +79,13 @@ CONFIGURE_ARGS+=--with-pcre=yes
CONFIGURE_ARGS+=--with-pcre=no
.endif
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--with-curl=yes
+.else
+CONFIGURE_ARGS+=--with-curl=no
+.endif
+
post-patch:
.for i in man/httpd.1 man/httpd.conf.5 config/httpd.conf.sample \
contrib/SSL-Makefile contrib/logrotate.sh
@@ -84,4 +101,12 @@ post-patch:
@${REINPLACE_CMD} -e 's|mime.types ||g' \
${WRKSRC}/config/Makefile.in
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
.include <bsd.port.post.mk>
diff --git a/www/xshttpd/distinfo b/www/xshttpd/distinfo
index c8b831bc44c1..84ca2768ce14 100644
--- a/www/xshttpd/distinfo
+++ b/www/xshttpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (xshttpd-33g01.tar.gz) = b22bcb06e73c4c7df4e6f3da3fc22de9
-SHA256 (xshttpd-33g01.tar.gz) = 4519b3b927f87cd62534593296a7c4aa77895b5369e646c8a5a0be8587928cb3
-SIZE (xshttpd-33g01.tar.gz) = 208738
+MD5 (xshttpd-34g01.tar.bz2) = e18d3985a46118807976d7ac48c5cf06
+SHA256 (xshttpd-34g01.tar.bz2) = 3331a81c0568375c43444325469bfa9e049f4914f3e8f11adb3989fa6c24f90c
+SIZE (xshttpd-34g01.tar.bz2) = 200916
diff --git a/www/xshttpd/pkg-plist b/www/xshttpd/pkg-plist
index 01aeece77eef..a53e0c9d173b 100644
--- a/www/xshttpd/pkg-plist
+++ b/www/xshttpd/pkg-plist
@@ -9,10 +9,12 @@ bin/xspasswd
%%WWWDIR%%/cgi-bin/imagemap
%%WWWDIR%%/cgi-bin/xschpass
%%WWWDIR%%/contrib/SSL-Makefile
+%%WWWDIR%%/contrib/agentstats.pl
+%%WWWDIR%%/contrib/caroot.pem
%%WWWDIR%%/contrib/logrotate.sh
%%WWWDIR%%/contrib/persistent.pl
+%%WWWDIR%%/contrib/powered-by-xs.gif
%%WWWDIR%%/contrib/wwwstats.pl
-%%WWWDIR%%/contrib/agentstats.pl
%%WWWDIR%%/compress.methods.sample
%%WWWDIR%%/gfxcount/digital0.ppm
%%WWWDIR%%/gfxcount/digital1.ppm