aboutsummaryrefslogtreecommitdiff
path: root/www/xulrunner
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /www/xulrunner
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Chase the GNOME X11BASE to LOCALBASE move, and fix the build with the
new freetype2 where needed. Submitted by: mezz, ahze, pav, and many others Approved by: portmgr (implicit, kris)
Notes
Notes: svn path=/head/; revision=175261
Diffstat (limited to 'www/xulrunner')
-rw-r--r--www/xulrunner/Makefile11
-rw-r--r--www/xulrunner/files/patch-xulrunner_app_mozilla.in18
2 files changed, 24 insertions, 5 deletions
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index cfdd31b60342..f809c09324d6 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -3,11 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/xulrunner/Makefile,v 1.6 2006/02/26 16:58:29 ahze Exp $
+# $MCom: ports/www/xulrunner/Makefile,v 1.13 2006/10/12 12:22:03 ahze Exp $
PORTNAME= xulrunner
PORTVERSION= 1.8.0.4
-PORTREVISION?= 1
+PORTREVISION?= 4
CATEGORIES?= www devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= xulrunner/releases/${PORTVERSION}/source/
@@ -16,7 +16,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Mozilla runtime package that can be used to bootstrap XUL+XPCOM apps
-USE_X_PREFIX= yes
WANT_GNOME= yes
ALL_TARGET= default
HAS_CONFIGURE= yes
@@ -25,12 +24,14 @@ USE_GMAKE= yes
USE_GCC= 3.4+
PORT_MOZCONFIG= ${WRKSRC}/xulrunner/config/mozconfig
-MOZ_OPTIONS?= --disable-javaxpcom
+MOZ_OPTIONS?= --disable-javaxpcom --enable-canvas \
+ --enable-system-cairo
MOZ_EXTENSIONS= default,cookie,permissions
OPTIONS= # Empty, used for generic gecko OPTIONS
+USE_GECKO_OPTIONS= java debug logging optimized_cflags
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../www/mozilla/Makefile.common"
+.include "${PORTSDIR}/www/mozilla/Makefile.common"
.if ${OSVERSION} < 500000
BROKEN= does not build
diff --git a/www/xulrunner/files/patch-xulrunner_app_mozilla.in b/www/xulrunner/files/patch-xulrunner_app_mozilla.in
new file mode 100644
index 000000000000..1839a79d7d0a
--- /dev/null
+++ b/www/xulrunner/files/patch-xulrunner_app_mozilla.in
@@ -0,0 +1,18 @@
+--- xulrunner/app/mozilla.in.orig Wed Oct 11 18:25:16 2006
++++ xulrunner/app/mozilla.in Wed Oct 11 18:25:48 2006
+@@ -193,12 +193,12 @@
+ done #others arg
+
+ #???: needs check if othersopt begin with -* ?
+-if [ `expr "${_optLast}" : '.*:/.*'` -eq 0 -a \( -f "${_optLast}" -o -d "${_optLast}" \) ]; then
++if [ `expr X"${_optLast}" : 'X.*:/.*'` -eq 0 -a \( -f "${_optLast}" -o -d "${_optLast}" \) ]; then
+ # Last argument seems to be a local file/directory
+ # Check, if it is absolutely specified (ie. /home/foo/file vs. ./file)
+ # If it is just "relatively" (./file) specified, make it absolutely
+- [ `expr "${_optLast}" : '/.*'` -eq 0 ] && _optLast="file://`pwd`/${_optLast}"
+-elif [ `expr "${_optLast}" : '.*:/.*'` -gt 0 -o -n "${_optOthers}" ]; then #???? like before...
++ [ `expr -e X"${_optLast}" : '/.*'` -eq 0 ] && _optLast="file://`pwd`/${_optLast}"
++elif [ `expr -e X"${_optLast}" : '.*:/.*'` -gt 0 -o -n X"${_optOthers}" ]; then #???? like before...
+ _NEW_WINDOW=1
+ fi
+