aboutsummaryrefslogtreecommitdiff
path: root/www/youtube_dl
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-26 13:04:05 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-26 13:04:05 +0000
commit973acdae3ec5070b840b2e323148e19a9316260d (patch)
tree756e9ad6407a64880dc5e8d0f4281fb416d934ee /www/youtube_dl
parentdb90abcf81260ee7c51c27da3a75c519e9882058 (diff)
downloadports-973acdae3ec5070b840b2e323148e19a9316260d.tar.gz
ports-973acdae3ec5070b840b2e323148e19a9316260d.zip
- Update to 2008.03.22
PR: ports/122111 Submitted by: Pankov Pavel <pankov_p at mail.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=209865
Diffstat (limited to 'www/youtube_dl')
-rw-r--r--www/youtube_dl/Makefile2
-rw-r--r--www/youtube_dl/distinfo6
-rw-r--r--www/youtube_dl/files/conv2avi.patch81
3 files changed, 41 insertions, 48 deletions
diff --git a/www/youtube_dl/Makefile b/www/youtube_dl/Makefile
index 6ee7c006ab7e..8f8397c7d72a 100644
--- a/www/youtube_dl/Makefile
+++ b/www/youtube_dl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= youtube_dl
-PORTVERSION= 2008.03.08
+PORTVERSION= 2008.03.22
CATEGORIES= www
MASTER_SITES= http://www.arrakis.es/~rggi3/youtube-dl/
DISTNAME= youtube-dl-${PORTVERSION}
diff --git a/www/youtube_dl/distinfo b/www/youtube_dl/distinfo
index a88a33a7edff..64a899789251 100644
--- a/www/youtube_dl/distinfo
+++ b/www/youtube_dl/distinfo
@@ -1,3 +1,3 @@
-MD5 (youtube-dl-2008.03.08) = 026eee27b6186b3729f842e2cc10cd0e
-SHA256 (youtube-dl-2008.03.08) = 30b491cece2bae9525e95f26dcb7d238eb0487fa689696faf166b590fd50b707
-SIZE (youtube-dl-2008.03.08) = 15306
+MD5 (youtube-dl-2008.03.22) = a86bfb24c5f9b7aff0c4ec2975c1a03c
+SHA256 (youtube-dl-2008.03.22) = c65577f00acc19dc7d71e1e41664a665961f8075b2b7f16a433f97eedfbd0f26
+SIZE (youtube-dl-2008.03.22) = 15750
diff --git a/www/youtube_dl/files/conv2avi.patch b/www/youtube_dl/files/conv2avi.patch
index 4e19c7243325..54599e0e8919 100644
--- a/www/youtube_dl/files/conv2avi.patch
+++ b/www/youtube_dl/files/conv2avi.patch
@@ -1,44 +1,37 @@
-Index: www/youtube_dl/files/conv2avi.patch
-===================================================================
-RCS file: www/youtube_dl/files/conv2avi.patch
-diff -N www/youtube_dl/files/conv2avi.patch
---- /dev/null 1 Jan 1970 00:00:00 -0000
-+++ www/youtube_dl/files/conv2avi.patch 31 Jan 2008 19:32:45 -0000
-@@ -0,0 +1,37 @@
-+--- youtube-dl.orig Wed Jan 30 14:18:50 2008
-++++ youtube-dl Thu Jan 31 21:36:49 2008
-+@@ -208,6 +208,7 @@
-+ cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
-+ cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
-+ cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
-++cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='output file in avi format')
-+ cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
-+ cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
-+ (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
-+@@ -382,6 +383,26 @@
-+
-+ except KeyboardInterrupt:
-+ sys.exit('\n')
-++
-++# Convert to avi if needed
-++if cmdl_opts.use_avi:
-++ if cmdl_opts.outfile is None:
-++ avi_filename = '%s.avi' % video_filename[:-4]
-++ else:
-++ avi_filename = '%s.avi' % video_filename
-++
-++ try:
-++ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
-++ cond_print('Video file converted to %s\n' % avi_filename)
-++ except OSError:
-++ sys.exit('Error: unable to convert file.\n')
-++ except KeyboardInterrupt:
-++ sys.exit('\n')
-++
-++ try:
-++ os.unlink(video_filename)
-++ except OSError:
-++ sys.exit('Error: unable to remove downloaded file.\n')
-+
-+ # Finish
-+ sys.exit()
+--- youtube-dl.orig Wed Jan 30 14:18:50 2008
++++ youtube-dl Thu Jan 31 21:36:49 2008
+@@ -208,6 +208,7 @@
+ cmdl_parser.add_option('-t', '--title', action='store_true', dest='use_title', help='use title in file name')
+ cmdl_parser.add_option('-l', '--literal', action='store_true', dest='use_literal', help='use literal title in file name')
+ cmdl_parser.add_option('-n', '--netrc', action='store_true', dest='use_netrc', help='use .netrc authentication data')
++cmdl_parser.add_option('-a', '--avi', action='store_true', dest='use_avi', help='convert file to MPEG4 format')
+ cmdl_parser.add_option('-g', '--get-url', action='store_true', dest='get_url', help='print final video URL only')
+ cmdl_parser.add_option('-2', '--title-too', action='store_true', dest='get_title', help='used with -g, print title too')
+ (cmdl_opts, cmdl_args) = cmdl_parser.parse_args()
+@@ -382,6 +383,26 @@
+
+ except KeyboardInterrupt:
+ sys.exit('\n')
++
++# Convert to avi if needed
++if cmdl_opts.use_avi and not cmdl_opts.best_quality:
++ if cmdl_opts.outfile is None:
++ avi_filename = '%s.avi' % video_filename[:-4]
++ else:
++ avi_filename = '%s.avi' % video_filename
++
++ try:
++ os.system('%%CONV2AVI_CMD%% "%s" "%s" > %s 2> %s' % (video_filename, avi_filename, os.path.devnull, os.path.devnull))
++ cond_print('Video file converted to %s\n' % avi_filename)
++ except OSError:
++ sys.exit('Error: unable to convert file.\n')
++ except KeyboardInterrupt:
++ sys.exit('\n')
++
++ try:
++ os.unlink(video_filename)
++ except OSError:
++ sys.exit('Error: unable to remove downloaded file.\n')
+
+ # Finish
+ sys.exit()