aboutsummaryrefslogtreecommitdiff
path: root/www/zend-framework/Makefile
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-01-28 21:24:25 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-01-28 21:24:25 +0000
commit16b5c1772b29d237dc7e959da4a4ae90aa534989 (patch)
treec7e5b74ef35bebc2f17b7672bc6495c487452613 /www/zend-framework/Makefile
parent7886e2eaa06d695c8aad82d778fa0b50e44863ed (diff)
downloadports-16b5c1772b29d237dc7e959da4a4ae90aa534989.tar.gz
ports-16b5c1772b29d237dc7e959da4a4ae90aa534989.zip
- Update to 1.7.3
- Add knob to install incubator classes
Notes
Notes: svn path=/head/; revision=227068
Diffstat (limited to 'www/zend-framework/Makefile')
-rw-r--r--www/zend-framework/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index f3cd09ed6046..539c14368fe6 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ZendFramework
-PORTVERSION= 1.7.0
-PORTREVISION= 1
+PORTVERSION= 1.7.3
CATEGORIES= www
MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/ GENTOO/distfiles
@@ -24,6 +23,7 @@ SUB_FILES= pkg-message
OPTIONS= \
EDOJO "Install embedded Dojo" On \
PDOJO "Install Dojo from ports" Off \
+ INCUBATOR "Install incubator classes" Off \
MYSQL "Install MySQL PDO support" Off \
MYSQLI "Install MySQLi support" Off \
DBLIB "Install DBLIB PDO support" Off \
@@ -58,6 +58,14 @@ DOJO= "@comment "
.endif
PLIST_SUB+= DOJO=${DOJO}
+.if defined(WITH_INCUBATOR)
+INCUBATOR= ""
+INSTALL_DIRS+= incubator
+.else
+INCUBATOR= "@comment "
+.endif
+PLIST_SUB+= INCUBATOR=${INCUBATOR}
+
.if defined(WITH_PDOJO)
RUN_DEPENDS+= dojo>=0:${PORTSDIR}/www/dojo
.endif