aboutsummaryrefslogtreecommitdiff
path: root/www/zend-framework
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-03-11 19:12:02 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-03-11 19:12:02 +0000
commit4afd3f7f60de895230dca87c32867acc50dde1c7 (patch)
tree897bb0c9ed3ed152a41be96680de38de3351d732 /www/zend-framework
parentf7c728bb1ece4bb48100dca7912e60677303e72f (diff)
downloadports-4afd3f7f60de895230dca87c32867acc50dde1c7.tar.gz
ports-4afd3f7f60de895230dca87c32867acc50dde1c7.zip
- Update to 1.0.4
- Various cleanups/coding style improvements in Makefile - Added owner/perms configuration for pkg_add PR: ports/121241 Submitted by: Greg Larkin <glarkin@sourcehosting.net> (maintainer)
Notes
Notes: svn path=/head/; revision=208830
Diffstat (limited to 'www/zend-framework')
-rw-r--r--www/zend-framework/Makefile22
-rw-r--r--www/zend-framework/distinfo6
-rw-r--r--www/zend-framework/files/pkg-message.in3
-rw-r--r--www/zend-framework/pkg-plist54
4 files changed, 44 insertions, 41 deletions
diff --git a/www/zend-framework/Makefile b/www/zend-framework/Makefile
index be321a9ccb2b..930abf84b96f 100644
--- a/www/zend-framework/Makefile
+++ b/www/zend-framework/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ZendFramework
-PORTVERSION= 1.0.3
+PORTVERSION= 1.0.4
CATEGORIES= www
MASTER_SITES= http://framework.zend.com/releases/${DISTNAME}/ GENTOO/distfiles
@@ -16,8 +16,6 @@ COMMENT= A framework for developing PHP web applications
NO_BUILD= yes
USE_PHP= pcre spl
WANT_PHP_WEB= yes
-IGNORE_WITH_PHP=4
-
USE_GETTEXT= yes
SUB_FILES= pkg-message
@@ -33,6 +31,8 @@ OPTIONS= MYSQL "Install MySQL PDO support" Off \
.include <bsd.port.pre.mk>
+IGNORE_WITH_PHP=4
+
# Add all of the required and/or optional PHP extension dependencies,
# if chosen by the user.
#
@@ -40,15 +40,16 @@ OPTIONS= MYSQL "Install MySQL PDO support" Off \
# a table of what PHP extensions are required for what ZF classes.
.if defined(WITH_REQPHP)
-USE_PHP+= ctype curl dom gd iconv mbstring memcache \
- session simplexml soap xml zlib
+USE_PHP+= ctype curl dom gd hash iconv mbstring \
+ memcache pdo session simplexml soap xml zlib
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/apc.so:${PORTSDIR}/www/pecl-APC
.endif
.if defined(WITH_OPTPHP)
USE_PHP+= bcmath bitset json posix
.endif
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_mysql.so:${PORTSDIR}/databases/php5-pdo_mysql
+USE_PHP+= pdo_mysql
.endif
.if defined(WITH_DBLIB)
@@ -72,11 +73,16 @@ USE_PHP+= pdo_sqlite
.endif
do-install:
- @${MKDIR} ${DATADIR}
- ${CP} -R ${WRKSRC}/ ${DATADIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${DATADIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${DATADIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
+ ${DATADIR:S|^${PREFIX}/|%D/|}' >> ${TMPPLIST}
${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${ECHO_CMD} '@exec ${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} 644' >> ${TMPPLIST}
${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
+ @${ECHO_CMD} '@exec ${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} 755' >> ${TMPPLIST}
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/www/zend-framework/distinfo b/www/zend-framework/distinfo
index 96e434895a53..37818f6cfd78 100644
--- a/www/zend-framework/distinfo
+++ b/www/zend-framework/distinfo
@@ -1,3 +1,3 @@
-MD5 (ZendFramework-1.0.3.tar.gz) = f44da5090c9a461b20372e64574b30ff
-SHA256 (ZendFramework-1.0.3.tar.gz) = b685c9314b3568b31d1c0957ea045f732b8a268807e0bb1aec185da18cbac8a9
-SIZE (ZendFramework-1.0.3.tar.gz) = 3918956
+MD5 (ZendFramework-1.0.4.tar.gz) = aeb2f0a898c024f616cea7e4488a09b8
+SHA256 (ZendFramework-1.0.4.tar.gz) = 6ffc9833d4a17ad7cfd210024dbdef9f6a7b1563f6c8dbeaf5787c8e178c4220
+SIZE (ZendFramework-1.0.4.tar.gz) = 3752635
diff --git a/www/zend-framework/files/pkg-message.in b/www/zend-framework/files/pkg-message.in
index 8ad98f11f955..245ed5418ccc 100644
--- a/www/zend-framework/files/pkg-message.in
+++ b/www/zend-framework/files/pkg-message.in
@@ -1,7 +1,7 @@
***************************************************************
Now you need to adjust PHP's include_path to contain
- `%%DATADIR%%'
+ `%%DATADIR%%/library'
For example, insert:
include_path = ".:%%DATADIR%%/library"
@@ -11,4 +11,3 @@ into `%%LOCALBASE%%/etc/php.ini'.
For more information about the Zend Framework, please visit:
http://framework.zend.com/
***************************************************************
-
diff --git a/www/zend-framework/pkg-plist b/www/zend-framework/pkg-plist
index 06de584a7f52..e5ea7b6aab15 100644
--- a/www/zend-framework/pkg-plist
+++ b/www/zend-framework/pkg-plist
@@ -140,6 +140,8 @@
%%DATADIR%%/library/Zend/Db/Adapter/Oracle/Exception.php
%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Abstract.php
%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Ibm.php
+%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Ibm/Db2.php
+%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Ibm/Ids.php
%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Mssql.php
%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Mysql.php
%%DATADIR%%/library/Zend/Db/Adapter/Pdo/Oci.php
@@ -244,6 +246,7 @@
%%DATADIR%%/library/Zend/Gdata/App/HttpException.php
%%DATADIR%%/library/Zend/Gdata/App/IOException.php
%%DATADIR%%/library/Zend/Gdata/App/InvalidArgumentException.php
+%%DATADIR%%/library/Zend/Gdata/App/LoggingHttpClientAdapterSocket.php
%%DATADIR%%/library/Zend/Gdata/App/MediaEntry.php
%%DATADIR%%/library/Zend/Gdata/App/MediaFileSource.php
%%DATADIR%%/library/Zend/Gdata/App/MediaSource.php
@@ -431,6 +434,7 @@
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Gender.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Hobbies.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Hometown.php
+%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Link.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Location.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/MediaContent.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/MediaGroup.php
@@ -445,6 +449,7 @@
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/School.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Statistics.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Status.php
+%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Token.php
%%DATADIR%%/library/Zend/Gdata/YouTube/Extension/Username.php
%%DATADIR%%/library/Zend/Gdata/YouTube/MediaEntry.php
%%DATADIR%%/library/Zend/Gdata/YouTube/PlaylistListEntry.php
@@ -1385,11 +1390,13 @@
%%DATADIR%%/tests/Zend/Config/XmlTest.php
%%DATADIR%%/tests/Zend/Config/_files/allsections.ini
%%DATADIR%%/tests/Zend/Config/_files/allsections.xml
+%%DATADIR%%/tests/Zend/Config/_files/array.xml
%%DATADIR%%/tests/Zend/Config/_files/circular.ini
%%DATADIR%%/tests/Zend/Config/_files/circular.xml
%%DATADIR%%/tests/Zend/Config/_files/config.ini
%%DATADIR%%/tests/Zend/Config/_files/config.xml
%%DATADIR%%/tests/Zend/Config/_files/multipleinheritance.ini
+%%DATADIR%%/tests/Zend/Config/_files/nosections.ini
%%DATADIR%%/tests/Zend/Config/_files/onetoplevelstring.xml
%%DATADIR%%/tests/Zend/Config/_files/separator.ini
%%DATADIR%%/tests/Zend/Config/_files/toplevelstring.xml
@@ -1429,17 +1436,10 @@
%%DATADIR%%/tests/Zend/Controller/_files/ObController.php
%%DATADIR%%/tests/Zend/Controller/_files/ViewController.php
%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/controllers/IndexController.php
-%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts/index/test.phtml
-%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts/test.phtml
-%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts/test/foo.php
%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/controllers/Admin/IndexController.php
%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/controllers/IndexController.php
+%%DATADIR%%/tests/Zend/Controller/_files/routes-root.ini
%%DATADIR%%/tests/Zend/Controller/_files/routes.ini
-%%DATADIR%%/tests/Zend/Controller/views/scripts/custom/renderScript.php
-%%DATADIR%%/tests/Zend/Controller/views/scripts/foo-bar/baz-bat.phtml
-%%DATADIR%%/tests/Zend/Controller/views/scripts/site.phtml
-%%DATADIR%%/tests/Zend/Controller/views/scripts/view/index.phtml
-%%DATADIR%%/tests/Zend/Controller/views/scripts/view/name.phtml
%%DATADIR%%/tests/Zend/CurrencyTest.php
%%DATADIR%%/tests/Zend/Date/AllTests.php
%%DATADIR%%/tests/Zend/Date/DateObjectTest.php
@@ -1645,6 +1645,7 @@
%%DATADIR%%/tests/Zend/Gdata/AppTest.php
%%DATADIR%%/tests/Zend/Gdata/AttendeeStatusTest.php
%%DATADIR%%/tests/Zend/Gdata/AttendeeTypeTest.php
+%%DATADIR%%/tests/Zend/Gdata/AuthSubTest.php
%%DATADIR%%/tests/Zend/Gdata/Calendar/AccessLevelTest.php
%%DATADIR%%/tests/Zend/Gdata/Calendar/ColorTest.php
%%DATADIR%%/tests/Zend/Gdata/Calendar/EventEntryTest.php
@@ -2066,10 +2067,13 @@
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/AlbumDataTest.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/AllTests.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/ArtistTest.php
+%%DATADIR%%/tests/Zend/Service/Audioscrobbler/AudioscrobblerTest.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/GroupTest.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/ProfileTest.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/TagDataTest.php
%%DATADIR%%/tests/Zend/Service/Audioscrobbler/TrackDataTest.php
+%%DATADIR%%/tests/Zend/Service/Audioscrobbler/_files/errorNoUserExists
+%%DATADIR%%/tests/Zend/Service/Audioscrobbler/_files/errorResponseStatusError
%%DATADIR%%/tests/Zend/Service/Delicious/AllTests.php
%%DATADIR%%/tests/Zend/Service/Delicious/PostTest.php
%%DATADIR%%/tests/Zend/Service/Delicious/PrivateDataTest.php
@@ -2120,6 +2124,7 @@
%%DATADIR%%/tests/Zend/Translate/XmlTmTest.php
%%DATADIR%%/tests/Zend/Translate/_files/XmlTm_test_de.xml
%%DATADIR%%/tests/Zend/Translate/_files/XmlTm_test_en.xml
+%%DATADIR%%/tests/Zend/Translate/_files/array.php
%%DATADIR%%/tests/Zend/Translate/_files/failed.tmx
%%DATADIR%%/tests/Zend/Translate/_files/failed.xliff
%%DATADIR%%/tests/Zend/Translate/_files/test_fileerror.mo
@@ -2198,18 +2203,6 @@
%%DATADIR%%/tests/Zend/_files/_testDir1/ClassNonexistent.php
%%DATADIR%%/tests/Zend/_files/_testDir1/Interface1.php
%%DATADIR%%/tests/Zend/_files/_testDir2/Class2.php
-@exec mkdir -p %D/%%DATADIR%%/library/Zend/View/Filter
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/filters
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/helpers
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/default/controllers
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/helpers
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/scripts
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/filters
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/helpers
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Db/Table/_files
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Memory/_files
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/Storage/_tempFiles
-@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/_files/_index
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir2
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir1/Class1
@dirrm %%DATADIR%%/tests/Zend/_files/_testDir1
@@ -2234,6 +2227,7 @@
@dirrm %%DATADIR%%/tests/Zend/Service/Flickr/_files
@dirrm %%DATADIR%%/tests/Zend/Service/Flickr
@dirrm %%DATADIR%%/tests/Zend/Service/Delicious
+@dirrm %%DATADIR%%/tests/Zend/Service/Audioscrobbler/_files
@dirrm %%DATADIR%%/tests/Zend/Service/Audioscrobbler
@dirrm %%DATADIR%%/tests/Zend/Service/Amazon
@dirrm %%DATADIR%%/tests/Zend/Service
@@ -2327,14 +2321,9 @@
@dirrm %%DATADIR%%/tests/Zend/Db/Adapter
@dirrm %%DATADIR%%/tests/Zend/Db
@dirrm %%DATADIR%%/tests/Zend/Date
-@dirrm %%DATADIR%%/tests/Zend/Controller/views/scripts/view
-@dirrm %%DATADIR%%/tests/Zend/Controller/views/scripts/foo-bar
-@dirrm %%DATADIR%%/tests/Zend/Controller/views/scripts/custom
-@dirrm %%DATADIR%%/tests/Zend/Controller/views/scripts
@dirrm %%DATADIR%%/tests/Zend/Controller/views/helpers
@dirrm %%DATADIR%%/tests/Zend/Controller/views/filters
@dirrm %%DATADIR%%/tests/Zend/Controller/views
-@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/scripts
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/helpers
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/foo/controllers/Admin
@@ -2342,9 +2331,6 @@
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/foo
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/default/controllers
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/default
-@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts/test
-@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts/index
-@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/scripts
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/helpers
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/filters
@dirrm %%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views
@@ -2516,6 +2502,7 @@
@dirrm %%DATADIR%%/library/Zend/Db/Statement
@dirrm %%DATADIR%%/library/Zend/Db/Select
@dirrm %%DATADIR%%/library/Zend/Db/Profiler
+@dirrm %%DATADIR%%/library/Zend/Db/Adapter/Pdo/Ibm
@dirrm %%DATADIR%%/library/Zend/Db/Adapter/Pdo
@dirrm %%DATADIR%%/library/Zend/Db/Adapter/Oracle
@dirrm %%DATADIR%%/library/Zend/Db/Adapter/Mysqli
@@ -2572,3 +2559,14 @@
@dirrm %%DATADIR%%/demos/Zend
@dirrm %%DATADIR%%/demos
@dirrm %%DATADIR%%
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/_files/_index
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Search/Lucene/Storage/_tempFiles
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Memory/_files
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Db/Table/_files
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/views/filters
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/foo/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/default/controllers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/helpers
+@exec mkdir -p %D/%%DATADIR%%/tests/Zend/Controller/_files/modules/bar/views/filters
+@exec mkdir -p %D/%%DATADIR%%/library/Zend/View/Filter