aboutsummaryrefslogtreecommitdiff
path: root/www/zope-cmfactionicons
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-20 00:04:58 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-20 00:04:58 +0000
commit3a54566324553aa3e9365816c7e33d2666886652 (patch)
treebbf8bea7a1f57887c485ee63e425983ea22b4d5b /www/zope-cmfactionicons
parent09ca79c9c232a6f0d8750b1cf2b3d9d370aecd02 (diff)
downloadports-3a54566324553aa3e9365816c7e33d2666886652.tar.gz
ports-3a54566324553aa3e9365816c7e33d2666886652.zip
Add zope-cmfactionicons.
This product is a add-on for the Zope Content Management Framework (CMF). It should be useful with Plone, CPS, and other CMF-derived extensions, as well. The product provides: * A new tool, portal_actionicons, which serves as a registry mapping object actions (using category and action ID) to a descriptive title, a priority, and an icon ID. The tool post-processes a set of actions (i.e., those generated by the portal_actions tool), decorating them with additional information, and sorting them according to priority. * ZPT macros which build either horizontal or vertical icon bars for a set of actions. PR: ports/62942 Submitted by: Khairil Yusof <kaeru@inigo-tech.com>
Notes
Notes: svn path=/head/; revision=101429
Diffstat (limited to 'www/zope-cmfactionicons')
-rw-r--r--www/zope-cmfactionicons/Makefile54
-rw-r--r--www/zope-cmfactionicons/distinfo1
-rw-r--r--www/zope-cmfactionicons/pkg-descr19
-rw-r--r--www/zope-cmfactionicons/pkg-message6
4 files changed, 80 insertions, 0 deletions
diff --git a/www/zope-cmfactionicons/Makefile b/www/zope-cmfactionicons/Makefile
new file mode 100644
index 000000000000..052b1b668c43
--- /dev/null
+++ b/www/zope-cmfactionicons/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: zope-cmfactionicons
+# Date created: 21 January 2004
+# Whom: Khairil Yusof
+#
+# $FreeBSD$
+#
+
+PORTNAME= cmfactionicons
+PORTVERSION= 0.9
+CATEGORIES= www zope
+MASTER_SITES= http://zope.org/Members/tseaver/CMFActionIcons/CMFActionIcons-0.9/
+PKGNAMEPREFIX= zope-
+DISTNAME= CMFActionIcons-${PORTVERSION}
+
+MAINTAINER= kaeru@inigo-tech.com
+COMMENT= CMFActionIcons product for Zope/CMF
+
+RUN_DEPENDS= ${LOCALBASE}/${SZOPEBASEDIR}/lib/python/Products/CMFDefault/__init__.py:${PORTSDIR}/www/zope-cmf
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME= CMFActionIcons
+
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}-${PORTVERSION}/${ZOPEPRODUCTNAME}
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/
+
+pre-install:
+ @${CP} ${WRKDIR}/CMFActionIcons-${PORTVERSION}/README.txt ${WRKDIR}/${ZOPEPRODUCTNAME}-${PORTVERSION}/${ZOPEPRODUCTNAME}/README.txt
+ @${RM} -f ${PLIST}
+ @${TOUCH} ${PLIST}
+ @cd ${WRKDIR}/${ZOPEPRODUCTNAME}-${PORTVERSION} ;\
+ for f in `${FIND} ${ZOPEPRODUCTNAME} -type f`; do \
+ ${ECHO_CMD} %%ZOPEPRODUCTDIR%%/$${f} >> ${PLIST}; \
+ done; \
+ for d in `${FIND} -d ${ZOPEPRODUCTNAME} -type d`; do \
+ ${ECHO_CMD} @dirrm %%ZOPEPRODUCTDIR%%/$${d} >> ${PLIST}; \
+ done; \
+
+do-install:
+ @${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+ @${CHMOD} -R og+rX ${WRKSRC}/
+ @${CP} -R ${WRKSRC} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/zope-cmfactionicons/distinfo b/www/zope-cmfactionicons/distinfo
new file mode 100644
index 000000000000..3eb240d9a34d
--- /dev/null
+++ b/www/zope-cmfactionicons/distinfo
@@ -0,0 +1 @@
+MD5 (zope/CMFActionIcons-0.9.tar.gz) = 4c33a6daefd75e5ee63a3afb693628f8
diff --git a/www/zope-cmfactionicons/pkg-descr b/www/zope-cmfactionicons/pkg-descr
new file mode 100644
index 000000000000..3604d4d37ea8
--- /dev/null
+++ b/www/zope-cmfactionicons/pkg-descr
@@ -0,0 +1,19 @@
+CMFActionIcons
+
+This product is a add-on for the Zope Content Management Framework (CMF). It
+should be useful with Plone, CPS, and other CMF-derived extensions, as well.
+The product provides:
+
+* A new tool, portal_actionicons, which serves as a registry mapping object
+ actions (using category and action ID) to a descriptive title, a priority,
+ and an icon ID. The tool post-processes a set of actions (i.e., those
+ generated by the portal_actions tool), decorating them with additional
+ information, and sorting them according to priority.
+
+* ZPT macros which build either horizontal or vertical icon bars for a set
+ of actions.
+
+WWW: http://zope.org/Members/tseaver/CMFActionIcons
+
+- Khairil Yusof
+kaeru@inigo-tech.com
diff --git a/www/zope-cmfactionicons/pkg-message b/www/zope-cmfactionicons/pkg-message
new file mode 100644
index 000000000000..a8533b7b264a
--- /dev/null
+++ b/www/zope-cmfactionicons/pkg-message
@@ -0,0 +1,6 @@
+To complete the installation of CMFActionIcons:
+
+- Restart Zope. This may be done from the Zope Control Panel.
+
+Please read README.txt in the CMFActionIcons Product directory for more
+information to complete installation.