aboutsummaryrefslogtreecommitdiff
path: root/www/zope-formulator/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 04:37:34 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 04:37:34 +0000
commit615c67a1fdb28ab960c73fcd167e1366a6af1f68 (patch)
tree1b7839824c778a359a72e37a58cc58a102f4aeb3 /www/zope-formulator/Makefile
parentdacccd604ae8678743d8a781b84f5e94ee0b4476 (diff)
downloadports-615c67a1fdb28ab960c73fcd167e1366a6af1f68.tar.gz
ports-615c67a1fdb28ab960c73fcd167e1366a6af1f68.zip
New port: www/formulator, Formulator for Zope
Formulator is an extensible framework that eases the creation and validation of web forms. PR: ports/54079 Submitted by: Tim Middleton <x@vex.net>
Notes
Notes: svn path=/head/; revision=96822
Diffstat (limited to 'www/zope-formulator/Makefile')
-rw-r--r--www/zope-formulator/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/www/zope-formulator/Makefile b/www/zope-formulator/Makefile
new file mode 100644
index 000000000000..3cde7b151be0
--- /dev/null
+++ b/www/zope-formulator/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Formulator
+# Date created: 3 Jul 2003
+# Whom: Tim Middleton
+#
+# $FreeBSD$
+#
+
+PORTNAME= formulator
+PORTVERSION= 1.4.2
+CATEGORIES= www zope
+MASTER_SITES= http://www.zope.org/Members/faassen/Formulator/${PORTVERSION}/
+PKGNAMEPREFIX= zope-
+DISTNAME= Formulator-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= x@Vex.Net
+COMMENT= Formulator - HTML form generatation and validation system
+
+USE_PYTHON= yes
+USE_ZOPE= yes
+DIST_SUBDIR= zope
+
+ZOPEPRODUCTNAME= Formulator
+
+PLIST_SUB= ZOPEBASEDIR=${SZOPEBASEDIR}
+WRKSRC= ${WRKDIR}/${ZOPEPRODUCTNAME}
+CPIO= cpio --quiet -pdum -R
+
+do-build:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ @ ${CHMOD} -R og+rX ${WRKSRC}/
+ @ ${MKDIR} ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+ @ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} ${BINOWN}:${BINGRP} \
+ ${ZOPEBASEDIR}/${ZOPEPRODUCTDIR}/${ZOPEPRODUCTNAME}
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>