aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
committerKoop Mast <kwm@FreeBSD.org>2011-08-23 18:39:19 +0000
commitfe61bf1eb4f2758636a3c065686a833eb412df25 (patch)
tree1474457ea487adcafec2ab29e99ab61897a3e479 /www
parent5732783897145621b6af3ab08fba8d9af40f338b (diff)
downloadports-fe61bf1eb4f2758636a3c065686a833eb412df25.tar.gz
ports-fe61bf1eb4f2758636a3c065686a833eb412df25.zip
Chase libnotify, libproxy and webkit-gtk2 shlib changes, and fix build where needed.
Notes
Notes: svn path=/head/; revision=280300
Diffstat (limited to 'www')
-rw-r--r--www/epiphany-extensions/Makefile4
-rw-r--r--www/epiphany/Makefile11
-rw-r--r--www/epiphany/files/patch-embed_downloader-view.c20
-rw-r--r--www/firefox-esr/Makefile3
-rw-r--r--www/firefox/Makefile3
-rw-r--r--www/firefox36/Makefile3
-rw-r--r--www/gnome-user-share/Makefile5
-rw-r--r--www/gnome-user-share/files/patch-src_obexpush.c15
-rw-r--r--www/gnome-web-photo/Makefile3
-rw-r--r--www/kazehakase/Makefile4
-rw-r--r--www/libxul/Makefile3
-rw-r--r--www/midori/Makefile5
-rw-r--r--www/neon29/Makefile4
-rw-r--r--www/py-jswebkit/Makefile3
-rw-r--r--www/py-webkitgtk/Makefile3
-rw-r--r--www/seamonkey/Makefile4
-rw-r--r--www/surf/Makefile3
-rw-r--r--www/uzbl/Makefile3
-rw-r--r--www/webkit-sharp/Makefile1
-rw-r--r--www/xxxterm/Makefile3
20 files changed, 76 insertions, 27 deletions
diff --git a/www/epiphany-extensions/Makefile b/www/epiphany-extensions/Makefile
index 770393fa2e1d..76960b127143 100644
--- a/www/epiphany-extensions/Makefile
+++ b/www/epiphany-extensions/Makefile
@@ -8,7 +8,7 @@
PORTNAME= epiphany-extensions
PORTVERSION= 2.30.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,7 +18,7 @@ COMMENT= A set of add-ons for the Epiphany web browser
BUILD_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre \
- webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+ webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= epiphany:${PORTSDIR}/www/epiphany
USE_GETTEXT= yes
diff --git a/www/epiphany/Makefile b/www/epiphany/Makefile
index d1cc19002abe..82eff476205c 100644
--- a/www/epiphany/Makefile
+++ b/www/epiphany/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/epiphany/Makefile,v 1.240 2010/10/10 19:16:00 marcus Exp $
+# $MCom: ports/www/epiphany/Makefile,v 1.246 2011/04/30 20:43:27 mezz Exp $
#
PORTNAME= epiphany
PORTVERSION= 2.30.6
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= www gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -19,20 +19,21 @@ COMMENT?= An extremely lightweight and simple web browser for GNOME 2
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2 \
+ webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2 \
soup-gnome-2.4.1:${PORTSDIR}/devel/libsoup-gnome \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
${LOCALBASE}/share/icons/HighContrastLargePrint/index.theme:${PORTSDIR}/x11-themes/gnome-themes
+CONFLICTS= epiphany-3.[0-9]*
+
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
USE_GETTEXT= yes
USE_BZIP2= yes
USE_PYTHON= yes
-GNOME_DESKTOP_VERSION=2
USE_GNOME= gnomeprefix gnomehack intlhack gnomedesktop desktopfileutils
WANT_GNOME= yes
GNU_CONFIGURE= yes
diff --git a/www/epiphany/files/patch-embed_downloader-view.c b/www/epiphany/files/patch-embed_downloader-view.c
new file mode 100644
index 000000000000..d15de3c6a3cc
--- /dev/null
+++ b/www/epiphany/files/patch-embed_downloader-view.c
@@ -0,0 +1,20 @@
+--- embed/downloader-view.c.orig 2011-03-07 10:49:18.000000000 +0100
++++ embed/downloader-view.c 2011-03-07 10:56:01.000000000 +0100
+@@ -337,7 +337,7 @@ show_notification (DownloaderView *dv, c
+ g_object_ref (dv);
+
+ notification = notify_notification_new (title, msg,
+- GTK_STOCK_INFO, NULL);
++ GTK_STOCK_INFO);
+
+ g_signal_connect_after (notification, "closed",
+ G_CALLBACK (notification_closed_cb), dv);
+@@ -346,8 +346,6 @@ show_notification (DownloaderView *dv, c
+ notify_notification_set_timeout (notification, NOTIFY_EXPIRES_DEFAULT);
+ notify_notification_set_urgency (notification, NOTIFY_URGENCY_LOW);
+
+- notify_notification_attach_to_status_icon (notification, status_icon);
+-
+ /* There are some visual glitches when the notification is shown and
+ * the GtkStatusIcon is still not visible. To avoid that, we delay the
+ * popup a bit. */
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 5c107b94cbab..8aa1ff587dad 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 6.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -67,7 +68,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
.if defined(WITH_PGO)
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 5c107b94cbab..8aa1ff587dad 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 6.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -67,7 +68,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
.if defined(WITH_PGO)
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 3b4d382e43d6..36e4ab554f7a 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -7,6 +7,7 @@
PORTNAME= firefox
DISTVERSION= 3.6.20
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA}
@@ -82,7 +83,7 @@ MOZ_OPTIONS+= --disable-gnomeui
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
post-extract:
diff --git a/www/gnome-user-share/Makefile b/www/gnome-user-share/Makefile
index 657d8fa9b1b4..ebd00c733283 100644
--- a/www/gnome-user-share/Makefile
+++ b/www/gnome-user-share/Makefile
@@ -3,11 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/www/gnome-user-share/Makefile,v 1.23 2010/09/28 08:52:36 kwm Exp $
+# $MCom: ports/www/gnome-user-share/Makefile,v 1.26 2011/04/30 20:43:27 mezz Exp $
#
PORTNAME= gnome-user-share
PORTVERSION= 2.30.1
+PORTREVISION= 1
CATEGORIES= www deskutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -17,7 +18,7 @@ COMMENT= Personal file-sharing service for the GNOME Desktop
LIB_DEPENDS= avahi-client:${PORTSDIR}/net/avahi-app \
canberra.0:${PORTSDIR}/audio/libcanberra \
- notify.1:${PORTSDIR}/devel/libnotify \
+ notify.4:${PORTSDIR}/devel/libnotify \
unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_dnssd.so:${PORTSDIR}/www/mod_dnssd \
console-kit-daemon:${PORTSDIR}/sysutils/consolekit
diff --git a/www/gnome-user-share/files/patch-src_obexpush.c b/www/gnome-user-share/files/patch-src_obexpush.c
new file mode 100644
index 000000000000..7b71c8d8ecca
--- /dev/null
+++ b/www/gnome-user-share/files/patch-src_obexpush.c
@@ -0,0 +1,15 @@
+--- src/obexpush.c.orig 2011-03-07 20:11:04.000000000 +0100
++++ src/obexpush.c 2011-03-07 20:11:34.000000000 +0100
+@@ -139,10 +139,9 @@
+ /* Translators: %s is the name of the filename received */
+ notification_text = g_strdup_printf(_("You received \"%s\" via Bluetooth"), display);
+ g_free (display);
+- notification = notify_notification_new_with_status_icon (_("You received a file"),
++ notification = notify_notification_new (_("You received a file"),
+ notification_text,
+- "dialog-information",
+- GTK_STATUS_ICON (statusicon));
++ "dialog-information");
+
+ notify_notification_set_timeout (notification, NOTIFY_EXPIRES_DEFAULT);
+
diff --git a/www/gnome-web-photo/Makefile b/www/gnome-web-photo/Makefile
index c3044a3da8e6..139385b10d1b 100644
--- a/www/gnome-web-photo/Makefile
+++ b/www/gnome-web-photo/Makefile
@@ -9,13 +9,14 @@
PORTNAME= gnome-web-photo
PORTVERSION= 0.10.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= GNOME
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool to generate full-size image files and thumbnails
-LIB_DEPENDS= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
diff --git a/www/kazehakase/Makefile b/www/kazehakase/Makefile
index c41f8c9aae2e..fdb71907146a 100644
--- a/www/kazehakase/Makefile
+++ b/www/kazehakase/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kazehakase
PORTVERSION= 0.5.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
MASTER_SITE_SUBDIR= ${PORTNAME}/43802
@@ -47,7 +47,7 @@ BROKEN= does not build on 6.x
.endif
.if defined(WITH_WEBKIT)
-LIB_DEPENDS+= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
PLIST_SUB+= WEBKIT=""
.else
PLIST_SUB+= WEBKIT="@comment "
diff --git a/www/libxul/Makefile b/www/libxul/Makefile
index 19851191afc5..85a4946e47dc 100644
--- a/www/libxul/Makefile
+++ b/www/libxul/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxul
DISTVERSION= 1.9.2.17
+PORTREVISION= 1
CATEGORIES?= www devel
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= xulrunner/releases/${DISTVERSION}/source
@@ -71,7 +72,7 @@ CFLAGS+= -mminimal-toc
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
post-patch:
diff --git a/www/midori/Makefile b/www/midori/Makefile
index 96d7f3d828b4..9b4af07626e6 100644
--- a/www/midori/Makefile
+++ b/www/midori/Makefile
@@ -8,6 +8,7 @@
PORTNAME= midori
PORTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
@@ -16,9 +17,9 @@ DIST_SUBDIR= xfce4
MAINTAINER= kwm@FreeBSD.org
COMMENT= Lightweight web browser using WebKit browser engine
-LIB_DEPENDS= webkit-1.0.13:${PORTSDIR}/www/webkit-gtk2 \
+LIB_DEPENDS= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2 \
sqlite3.8:${PORTSDIR}/databases/sqlite3 \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
BUILD_DEPENDS= rsvg-convert:${PORTSDIR}/graphics/librsvg2 \
valac:${PORTSDIR}/lang/vala
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index 1d59097b9987..2a6cd1d09a45 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -7,7 +7,7 @@
PORTNAME= neon29
PORTVERSION= 0.29.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/neon/
DISTNAME= neon-${PORTVERSION}
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+=--without-gssapi
.if defined(WITH_PROXY)
CONFIGURE_ARGS+=--with-libproxy
-LIB_DEPENDS+= proxy.0:${PORTSDIR}/net/libproxy
+LIB_DEPENDS+= proxy.1:${PORTSDIR}/net/libproxy
.else
CONFIGURE_ARGS+=--without-libproxy
.endif
diff --git a/www/py-jswebkit/Makefile b/www/py-jswebkit/Makefile
index 81049260d13c..396942ddb860 100644
--- a/www/py-jswebkit/Makefile
+++ b/www/py-jswebkit/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jswebkit
PORTVERSION= 0.0.3
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +17,7 @@ MAINTAINER= jupengfei@gmail.com
COMMENT= WebKit/JavaScriptCore Python bindings
BUILD_DEPENDS= cython:${PORTSDIR}/lang/cython
-LIB_DEPENDS= webkit:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= ${BUILD_DEPENDS}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/jswebkit.so
diff --git a/www/py-webkitgtk/Makefile b/www/py-webkitgtk/Makefile
index c67c91a0ce18..3c7c9a4eb5f4 100644
--- a/www/py-webkitgtk/Makefile
+++ b/www/py-webkitgtk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webkitgtk
PORTVERSION= 1.1.8
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= GOOGLE_CODE
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,7 +19,7 @@ COMMENT= Python bindings for the WebKit GTK+ port
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= webkit:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
PROJECTHOST= pywebkitgtk
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index edfc6ac407cc..4eac90ab5f86 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME= seamonkey
DISTVERSION= 2.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= www ipv6
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= seamonkey/releases/${DISTVERSION}/source
@@ -106,7 +106,7 @@ MOZ_OPTIONS+= --disable-composer
MOZ_OPTIONS+= --disable-dbus --disable-libnotify
.else
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- notify.1:${PORTSDIR}/devel/libnotify
+ notify.4:${PORTSDIR}/devel/libnotify
.endif
.if ${ARCH} == amd64 || ${ARCH} == i386
diff --git a/www/surf/Makefile b/www/surf/Makefile
index 6f93a167e3dd..93152d31b17d 100644
--- a/www/surf/Makefile
+++ b/www/surf/Makefile
@@ -7,13 +7,14 @@
PORTNAME= surf
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://dl.suckless.org/${PORTNAME}/
MAINTAINER= davide.italiano@gmail.com
COMMENT= A simple Web browser based on WebKit/Gtk+
-LIB_DEPENDS= webkit-1.0:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= dmenu:${PORTSDIR}/x11/dmenu
USE_GNOME= gtk20 pkgconfig
diff --git a/www/uzbl/Makefile b/www/uzbl/Makefile
index 248740d625bf..0c26c4590a50 100644
--- a/www/uzbl/Makefile
+++ b/www/uzbl/Makefile
@@ -7,13 +7,14 @@
PORTNAME= uzbl
DISTVERSION= 0.0.0.${GITDATE}
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.linta.de/distfiles/
MAINTAINER= aehlig@linta.de
COMMENT= Web interface tools which adhere to the unix philosophy
-LIB_DEPENDS= webkit:${PORTSDIR}/www/webkit-gtk2
+LIB_DEPENDS= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
RUN_DEPENDS= socat:${PORTSDIR}/net/socat \
${PYTHON_PKGNAMEPREFIX}gtk>=2:${PORTSDIR}/x11-toolkits/py-gtk2
diff --git a/www/webkit-sharp/Makefile b/www/webkit-sharp/Makefile
index 19302386e2eb..c1593bc178f8 100644
--- a/www/webkit-sharp/Makefile
+++ b/www/webkit-sharp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= webkit-sharp
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
diff --git a/www/xxxterm/Makefile b/www/xxxterm/Makefile
index 55c3e6368771..d70a13520719 100644
--- a/www/xxxterm/Makefile
+++ b/www/xxxterm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xxxterm
PORTVERSION= 1.425
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://opensource.conformal.com/snapshots/xxxterm/
EXTRACT_SUFX= .tgz
@@ -16,7 +17,7 @@ COMMENT= Minimalists vi-like web browser based on webkit and GTK+
LIB_DEPENDS= gnutls.47:${PORTSDIR}/security/gnutls \
soup-2.4:${PORTSDIR}/devel/libsoup \
- webkit-1.0:${PORTSDIR}/www/webkit-gtk2
+ webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
USE_GNOME= gtk20 pkgconfig
USE_PERL5_BUILD=YES