aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 08:41:44 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-03-19 08:41:44 +0000
commitb86ebdc5283409b50f8b57de6510671a07abafa1 (patch)
tree3601e9a9b15dabad22a1d80b0d246be7e6bc5afd /www
parent229a9bd1f87116f12c9601cf6dddcf8b851ade8f (diff)
downloadports-b86ebdc5283409b50f8b57de6510671a07abafa1.tar.gz
ports-b86ebdc5283409b50f8b57de6510671a07abafa1.zip
Fix displaying of bold/italic truetype fonts. Bump PORTREVISION.
PR: 36049 Submitted by: Joe Kelsey <joe@zircon.seattle.wa.us> Obtained from: Mozilla cvs
Notes
Notes: svn path=/head/; revision=56327
Diffstat (limited to 'www')
-rw-r--r--www/mozilla-devel/Makefile2
-rw-r--r--www/mozilla-devel/files/patch-gfx::src::x11shared::nsFreeType.cpp28
-rw-r--r--www/mozilla-vendor/Makefile2
-rw-r--r--www/mozilla-vendor/files/patch-gfx::src::x11shared::nsFreeType.cpp28
-rw-r--r--www/mozilla/Makefile2
-rw-r--r--www/mozilla/files/patch-gfx::src::x11shared::nsFreeType.cpp28
-rw-r--r--www/seamonkey/Makefile2
-rw-r--r--www/seamonkey/files/patch-gfx::src::x11shared::nsFreeType.cpp28
-rw-r--r--www/seamonkey2/Makefile2
-rw-r--r--www/seamonkey2/files/patch-gfx::src::x11shared::nsFreeType.cpp28
10 files changed, 145 insertions, 5 deletions
diff --git a/www/mozilla-devel/Makefile b/www/mozilla-devel/Makefile
index ecbdd978d48c..0d5c55d9acd0 100644
--- a/www/mozilla-devel/Makefile
+++ b/www/mozilla-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla-devel/files/patch-gfx::src::x11shared::nsFreeType.cpp b/www/mozilla-devel/files/patch-gfx::src::x11shared::nsFreeType.cpp
new file mode 100644
index 000000000000..6a3b2827c5f3
--- /dev/null
+++ b/www/mozilla-devel/files/patch-gfx::src::x11shared::nsFreeType.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- gfx/src/x11shared/nsFreeType.cpp.orig Fri Mar 1 00:37:13 2002
++++ gfx/src/x11shared/nsFreeType.cpp Mon Mar 18 21:11:36 2002
+@@ -1340,12 +1340,20 @@
+ nsFreeTypeFace *
+ nsFreeTypeGetFaceID(nsFontCatalogEntry *aFce)
+ {
+- // in this hash each ttc face has a unique key
+- nsCStringKey key(nsFT2FontCatalog::GetFamilyName(aFce));
++ // We need to have separate keys for the different faces in a ttc file.
++ // We append a slash and the face index to the file name to give us a
++ // unique key for each ttc face.
++ nsCAutoString key_str(nsFT2FontCatalog::GetFileName(aFce));
++ char buf[20];
++ sprintf(buf, "/%d", nsFT2FontCatalog::GetFaceIndex(aFce));
++ key_str.Append(buf);
++ nsCStringKey key(key_str);
+ nsFreeTypeFace *face = (nsFreeTypeFace *)gFreeTypeFaces->Get(&key);
+ if (!face) {
+ face = new nsFreeTypeFace(aFce);
+ NS_ASSERTION(face, "memory error while creating nsFreeTypeFace");
++ if (!face)
++ return nsnull;
+ gFreeTypeFaces->Put(&key, face);
+ }
+ return face;
diff --git a/www/mozilla-vendor/Makefile b/www/mozilla-vendor/Makefile
index ecbdd978d48c..0d5c55d9acd0 100644
--- a/www/mozilla-vendor/Makefile
+++ b/www/mozilla-vendor/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla-vendor/files/patch-gfx::src::x11shared::nsFreeType.cpp b/www/mozilla-vendor/files/patch-gfx::src::x11shared::nsFreeType.cpp
new file mode 100644
index 000000000000..6a3b2827c5f3
--- /dev/null
+++ b/www/mozilla-vendor/files/patch-gfx::src::x11shared::nsFreeType.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- gfx/src/x11shared/nsFreeType.cpp.orig Fri Mar 1 00:37:13 2002
++++ gfx/src/x11shared/nsFreeType.cpp Mon Mar 18 21:11:36 2002
+@@ -1340,12 +1340,20 @@
+ nsFreeTypeFace *
+ nsFreeTypeGetFaceID(nsFontCatalogEntry *aFce)
+ {
+- // in this hash each ttc face has a unique key
+- nsCStringKey key(nsFT2FontCatalog::GetFamilyName(aFce));
++ // We need to have separate keys for the different faces in a ttc file.
++ // We append a slash and the face index to the file name to give us a
++ // unique key for each ttc face.
++ nsCAutoString key_str(nsFT2FontCatalog::GetFileName(aFce));
++ char buf[20];
++ sprintf(buf, "/%d", nsFT2FontCatalog::GetFaceIndex(aFce));
++ key_str.Append(buf);
++ nsCStringKey key(key_str);
+ nsFreeTypeFace *face = (nsFreeTypeFace *)gFreeTypeFaces->Get(&key);
+ if (!face) {
+ face = new nsFreeTypeFace(aFce);
+ NS_ASSERTION(face, "memory error while creating nsFreeTypeFace");
++ if (!face)
++ return nsnull;
+ gFreeTypeFaces->Put(&key, face);
+ }
+ return face;
diff --git a/www/mozilla/Makefile b/www/mozilla/Makefile
index ecbdd978d48c..0d5c55d9acd0 100644
--- a/www/mozilla/Makefile
+++ b/www/mozilla/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/mozilla/files/patch-gfx::src::x11shared::nsFreeType.cpp b/www/mozilla/files/patch-gfx::src::x11shared::nsFreeType.cpp
new file mode 100644
index 000000000000..6a3b2827c5f3
--- /dev/null
+++ b/www/mozilla/files/patch-gfx::src::x11shared::nsFreeType.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- gfx/src/x11shared/nsFreeType.cpp.orig Fri Mar 1 00:37:13 2002
++++ gfx/src/x11shared/nsFreeType.cpp Mon Mar 18 21:11:36 2002
+@@ -1340,12 +1340,20 @@
+ nsFreeTypeFace *
+ nsFreeTypeGetFaceID(nsFontCatalogEntry *aFce)
+ {
+- // in this hash each ttc face has a unique key
+- nsCStringKey key(nsFT2FontCatalog::GetFamilyName(aFce));
++ // We need to have separate keys for the different faces in a ttc file.
++ // We append a slash and the face index to the file name to give us a
++ // unique key for each ttc face.
++ nsCAutoString key_str(nsFT2FontCatalog::GetFileName(aFce));
++ char buf[20];
++ sprintf(buf, "/%d", nsFT2FontCatalog::GetFaceIndex(aFce));
++ key_str.Append(buf);
++ nsCStringKey key(key_str);
+ nsFreeTypeFace *face = (nsFreeTypeFace *)gFreeTypeFaces->Get(&key);
+ if (!face) {
+ face = new nsFreeTypeFace(aFce);
+ NS_ASSERTION(face, "memory error while creating nsFreeTypeFace");
++ if (!face)
++ return nsnull;
+ gFreeTypeFaces->Put(&key, face);
+ }
+ return face;
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index ecbdd978d48c..0d5c55d9acd0 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/seamonkey/files/patch-gfx::src::x11shared::nsFreeType.cpp b/www/seamonkey/files/patch-gfx::src::x11shared::nsFreeType.cpp
new file mode 100644
index 000000000000..6a3b2827c5f3
--- /dev/null
+++ b/www/seamonkey/files/patch-gfx::src::x11shared::nsFreeType.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- gfx/src/x11shared/nsFreeType.cpp.orig Fri Mar 1 00:37:13 2002
++++ gfx/src/x11shared/nsFreeType.cpp Mon Mar 18 21:11:36 2002
+@@ -1340,12 +1340,20 @@
+ nsFreeTypeFace *
+ nsFreeTypeGetFaceID(nsFontCatalogEntry *aFce)
+ {
+- // in this hash each ttc face has a unique key
+- nsCStringKey key(nsFT2FontCatalog::GetFamilyName(aFce));
++ // We need to have separate keys for the different faces in a ttc file.
++ // We append a slash and the face index to the file name to give us a
++ // unique key for each ttc face.
++ nsCAutoString key_str(nsFT2FontCatalog::GetFileName(aFce));
++ char buf[20];
++ sprintf(buf, "/%d", nsFT2FontCatalog::GetFaceIndex(aFce));
++ key_str.Append(buf);
++ nsCStringKey key(key_str);
+ nsFreeTypeFace *face = (nsFreeTypeFace *)gFreeTypeFaces->Get(&key);
+ if (!face) {
+ face = new nsFreeTypeFace(aFce);
+ NS_ASSERTION(face, "memory error while creating nsFreeTypeFace");
++ if (!face)
++ return nsnull;
+ gFreeTypeFaces->Put(&key, face);
+ }
+ return face;
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index ecbdd978d48c..0d5c55d9acd0 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mozilla
PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_MOZILLA} \
diff --git a/www/seamonkey2/files/patch-gfx::src::x11shared::nsFreeType.cpp b/www/seamonkey2/files/patch-gfx::src::x11shared::nsFreeType.cpp
new file mode 100644
index 000000000000..6a3b2827c5f3
--- /dev/null
+++ b/www/seamonkey2/files/patch-gfx::src::x11shared::nsFreeType.cpp
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- gfx/src/x11shared/nsFreeType.cpp.orig Fri Mar 1 00:37:13 2002
++++ gfx/src/x11shared/nsFreeType.cpp Mon Mar 18 21:11:36 2002
+@@ -1340,12 +1340,20 @@
+ nsFreeTypeFace *
+ nsFreeTypeGetFaceID(nsFontCatalogEntry *aFce)
+ {
+- // in this hash each ttc face has a unique key
+- nsCStringKey key(nsFT2FontCatalog::GetFamilyName(aFce));
++ // We need to have separate keys for the different faces in a ttc file.
++ // We append a slash and the face index to the file name to give us a
++ // unique key for each ttc face.
++ nsCAutoString key_str(nsFT2FontCatalog::GetFileName(aFce));
++ char buf[20];
++ sprintf(buf, "/%d", nsFT2FontCatalog::GetFaceIndex(aFce));
++ key_str.Append(buf);
++ nsCStringKey key(key_str);
+ nsFreeTypeFace *face = (nsFreeTypeFace *)gFreeTypeFaces->Get(&key);
+ if (!face) {
+ face = new nsFreeTypeFace(aFce);
+ NS_ASSERTION(face, "memory error while creating nsFreeTypeFace");
++ if (!face)
++ return nsnull;
+ gFreeTypeFaces->Put(&key, face);
+ }
+ return face;