aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-08-28 21:12:38 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-08-28 21:12:38 +0000
commit2d819ab44be71f5310fcb6e276057905522abf7f (patch)
tree6828dda20d90b4f874fc5754d30a7f719ae7a74e /www
parent7d038ecb7ee67071191cc60a75bb07208dd0de70 (diff)
downloadports-2d819ab44be71f5310fcb6e276057905522abf7f.tar.gz
ports-2d819ab44be71f5310fcb6e276057905522abf7f.zip
www/py-rhodecode: fix rc.d script
- Minor fixes to the rc.d script - Add pytz and repoze.lru as run dependencies Submitted by: Chad Milios <cropcirclesystems yahoo.com> (via email)
Notes
Notes: svn path=/head/; revision=325553
Diffstat (limited to 'www')
-rw-r--r--www/py-rhodecode/Makefile2
-rw-r--r--www/py-rhodecode/files/rhodecode.in6
2 files changed, 6 insertions, 2 deletions
diff --git a/www/py-rhodecode/Makefile b/www/py-rhodecode/Makefile
index 72d415824726..1510253983b0 100644
--- a/www/py-rhodecode/Makefile
+++ b/www/py-rhodecode/Makefile
@@ -32,6 +32,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pylons>=1.0:${PORTSDIR}/www/py-pylons \
${PYTHON_PKGNAMEPREFIX}bcrypt>=0.2:${PORTSDIR}/security/py-bcrypt \
${PYTHON_PKGNAMEPREFIX}simplejson>=2.5.2:${PORTSDIR}/devel/py-simplejson \
${PYTHON_PKGNAMEPREFIX}PasteScript>=1.6.3:${PORTSDIR}/www/py-pastescript \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}repoze.lru>=0:${PORTSDIR}/devel/py-repoze.lru \
mercurial>=2.6:${PORTSDIR}/devel/mercurial
USE_PYTHON= -2.7
diff --git a/www/py-rhodecode/files/rhodecode.in b/www/py-rhodecode/files/rhodecode.in
index 21fbc98c17df..7ea469d7dabe 100644
--- a/www/py-rhodecode/files/rhodecode.in
+++ b/www/py-rhodecode/files/rhodecode.in
@@ -21,10 +21,12 @@
name="rhodecode"
rcvar=rhodecode_enable
+load_rc_config ${name}
+
: ${rhodecode_enable="NO"}
-: ${rhodecode_config="%%PREFIX%%/rhodecode/production.ini"}
-: ${rhodecode_user="www"}
+: ${rhodecode_config="%%PREFIX%%/etc/rhodecode/production.ini"}
: ${rhodecode_user="www"}
+: ${rhodecode_group="www"}
pidfile="/var/run/${name}.pid"
command=%%PREFIX%%/bin/paster