aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-07 06:28:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-07 06:28:30 +0000
commit1d6209abf0abc8b8aa330a70361a5802b7b492ae (patch)
tree62e69080fb33b3f5229b482d63cdf158fc24781a /www
parentdb060dd7562de37c2372f23045a849d510c7ba36 (diff)
downloadports-1d6209abf0abc8b8aa330a70361a5802b7b492ae.tar.gz
ports-1d6209abf0abc8b8aa330a70361a5802b7b492ae.zip
* Add mozilla-1.4a support
* Convert to new GNOME infrastructure
Notes
Notes: svn path=/head/; revision=78499
Diffstat (limited to 'www')
-rw-r--r--www/galeon/Makefile10
-rw-r--r--www/galeon2/Makefile45
2 files changed, 25 insertions, 30 deletions
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index c9246ab5557a..d08867e84ace 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -33,7 +33,7 @@ MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.0"
.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-embedded-devel"
MOZILLA= ${WITH_MOZILLA}
HEADERS_SUFX= -devel
-MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.3b"
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
.else
.if ${WITH_MOZILLA}=="mozilla-embedded"
MOZILLA= mozilla-embedded
@@ -47,7 +47,6 @@ HEADERS_SUFX=
.endif
USE_X_PREFIX= yes
-USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack bonobo libglade gnomevfs
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -57,7 +56,6 @@ CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUF
${MOZ_CONFIGURE_ARGS}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_REENTRANT ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
@@ -82,15 +80,15 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
-post-extract:
- @${ECHO_MSG}
+pre-everything::
+ @${ECHO_MSG} ""
@${ECHO_MSG} " By default the port uses www/mozilla for html rendering, but you can change"
@${ECHO_MSG} " this by defining WITH_MOZILLA to one of the following values:"
@${ECHO_MSG}
@${ECHO_MSG} " mozilla-devel "
@${ECHO_MSG} " mozilla-embedded[-devel|-vendor] "
@${ECHO_MSG} " mozilla-vendor "
- @${ECHO_MSG}
+ @${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/www/galeon2/Makefile b/www/galeon2/Makefile
index 78b0d0dfa4f3..41448d5a0ef2 100644
--- a/www/galeon2/Makefile
+++ b/www/galeon2/Makefile
@@ -17,7 +17,6 @@ COMMENT= A GNOME 2 Web browser based on gecko (the Mozilla rendering engine)
BUILD_DEPENDS= ${X11BASE}/include/mozilla${HEADERS_SUFX}/gtkembedmoz/gtkmozembed.h:${PORTSDIR}/www/mozilla-headers${HEADERS_SUFX} \
${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
-LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
RUN_DEPENDS= ${X11BASE}/lib/${MOZILLA}/components/libwidget_gtk2.so:${PORTSDIR}/www/${MOZILLA}
MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.3"
@@ -25,23 +24,22 @@ MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="1.3"
MOZILLA= mozilla-gtk2
HEADERS_SUFX=
-#.if !defined(WITH_MOZILLA)
-#MOZILLA= mozilla-gtk2
-#HEADERS_SUFX=
-#.else
-#.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
-#MOZILLA= ${WITH_MOZILLA}
-#HEADERS_SUFX= -devel
-#MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
-#.else
-#MOZILLA= mozilla
-#HEADERS_SUFX=
-#.endif
-#.endif
+.if !defined(WITH_MOZILLA)
+MOZILLA= mozilla-gtk2
+HEADERS_SUFX=
+.else
+.if ${WITH_MOZILLA}=="mozilla-devel-gtk2"
+MOZILLA= ${WITH_MOZILLA}
+HEADERS_SUFX= -devel
+MOZ_CONFIGURE_ARGS= --with-mozilla-snapshot="trunk"
+.else
+MOZILLA= mozilla
+HEADERS_SUFX=
+.endif
+.endif
USE_X_PREFIX= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomeprefix gnomehack
+USE_GNOME= gnomeprefix gnomehack libgnomeui
USE_LIBTOOL= yes
USE_GMAKE= yes
USE_REINPLACE= yes
@@ -51,7 +49,6 @@ CONFIGURE_ARGS= --with-mozilla-includes="${X11BASE}/include/mozilla${HEADERS_SUF
${MOZ_CONFIGURE_ARGS}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -D_REENTRANT ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= galeon.1
@@ -69,13 +66,13 @@ NO_WERROR= yes
CONFIGURE_ARGS+= --disable-werror
.endif
-#post-extract:
-# @${ECHO_MSG}
-# @${ECHO_MSG} " By default the port uses www/mozilla-gtk2 for html rendering, but you can"
-# @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
-# @${ECHO_MSG}
-# @${ECHO_MSG} " mozilla-devel-gtk2 "
-# @${ECHO_MSG}
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " By default the port uses www/mozilla-gtk2 for html rendering, but you can"
+ @${ECHO_MSG} " change this by defining WITH_MOZILLA to one of the following values:"
+ @${ECHO_MSG}
+ @${ECHO_MSG} " mozilla-devel-gtk2 "
+ @${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \