aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-12-15 16:45:38 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-12-15 16:45:38 +0000
commitd16f87ef4af5844477cce369a2e631e46d1952df (patch)
tree31bc3910fd2c9527abb6ff7eb290ac0db736b98f /www
parentf59167d48a1a8d19295d5146f37d86ed678c2742 (diff)
downloadports-d16f87ef4af5844477cce369a2e631e46d1952df.tar.gz
ports-d16f87ef4af5844477cce369a2e631e46d1952df.zip
- add stage support
- minor cleanups
Notes
Notes: svn path=/head/; revision=336555
Diffstat (limited to 'www')
-rw-r--r--www/mod_fastcgi/Makefile17
-rw-r--r--www/mod_line_edit/Makefile8
-rw-r--r--www/mod_log_config-st/Makefile16
-rw-r--r--www/mod_log_mysql/Makefile5
-rw-r--r--www/mod_proctitle/Makefile6
-rw-r--r--www/mod_proxy_html/Makefile17
-rw-r--r--www/mod_proxy_html/pkg-descr5
-rw-r--r--www/mod_tidy/Makefile11
-rw-r--r--www/mod_webkit/Makefile2
-rw-r--r--www/mod_xmlns/Makefile19
-rw-r--r--www/mod_xmlns/pkg-plist3
11 files changed, 45 insertions, 64 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 28cb30b2e8f8..c52fdb03923e 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -10,25 +10,16 @@ DISTNAME= mod_fastcgi-SNAP-0910052141
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
-COMMENT= A fast-cgi module for Apache
-
+COMMENT= Apache 2.2 fast-cgi module
USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= *.c
-PORTDOCS= LICENSE.TERMS mod_fastcgi.html
-
-NO_STAGE= yes
-do-install:
- @${APXS} -i -a -n ${SHORTMODNAME} ${WRKSRC}/${MODULENAME}.${AP_BUILDEXT}
+PORTDOCS= mod_fastcgi.html
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${f} ${DOCSDIR}
-.endfor
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/docs/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_line_edit/Makefile b/www/mod_line_edit/Makefile
index 73cec95da79c..add32ebbd40c 100644
--- a/www/mod_line_edit/Makefile
+++ b/www/mod_line_edit/Makefile
@@ -13,19 +13,17 @@ EXTRACT_SUFX=
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for simple text rewriting
-
-WRKSRC= ${WRKDIR}
+LICENSE= GPLv2
USE_APACHE= 22+
AP_FAST_BUILD= yes
AP_GENPLIST= yes
-NO_STAGE= yes
pre-extract:
- @${MKDIR} ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
do-extract:
- @${CP} ${DISTDIR}/${PORTNAME}.c ${WRKDIR}/
+ @${CP} ${DISTDIR}/${PORTNAME}.c ${WRKSRC}
.include <bsd.port.mk>
diff --git a/www/mod_log_config-st/Makefile b/www/mod_log_config-st/Makefile
index 60760fc02a32..6a620fdafff8 100644
--- a/www/mod_log_config-st/Makefile
+++ b/www/mod_log_config-st/Makefile
@@ -6,22 +6,24 @@ PORTVERSION= 1.0
PORTREVISION= 2
CATEGORIES= www
# Original location: http://bitbrook.de/software/mod_log_mysql/mod_log_config.c
-MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/
+# Please handle update requests with care!
+# sheepkiller was hacked and not cleaned over a long periode.
+# (First notice 2011-03 not cleaned until 2011-07)
+# Provide distfile now from LOCAL
+#MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/
+MASTER_SITES= LOCAL/ohauer
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
-COMMENT= A modified version of mod_log_config for apache2
+COMMENT= Modified version of mod_log_config for apache2
+EXPIRATION_DATE= 2014-02-08
+DEPRECATED= Upstream site gone since 2011-03
USE_APACHE= 22
-
AP_FAST_BUILD= yes
SRC_FILE= mod_log_config.c
SHORTMODNAME= log_config
MODULENAME= mod_log_config-st
-NO_STAGE= yes
-post-install:
- @${CAT} ${PKGMESSAGE}
-
.include <bsd.port.mk>
diff --git a/www/mod_log_mysql/Makefile b/www/mod_log_mysql/Makefile
index 887ff5ac7c53..2ac1cf38ac34 100644
--- a/www/mod_log_mysql/Makefile
+++ b/www/mod_log_mysql/Makefile
@@ -17,8 +17,10 @@ DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows Apache 2 to log to a MySQL database
-RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_log_config-st.so:${PORTSDIR}/www/mod_log_config-st
+EXPIRATION_DATE= 2014-02-08
+DEPRECATED= Upstream site gone since 2011-03
+RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_log_config-st.so:${PORTSDIR}/www/mod_log_config-st
USE_APACHE= 22
AP_FAST_BUILD= yes
@@ -28,5 +30,4 @@ USE_MYSQL= yes
AP_INC+= ${LOCALBASE}/include/mysql
AP_LIB+= ${LOCALBASE}/lib/mysql -lmysqlclient
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
index 520904ca8c4e..31e6f8cde755 100644
--- a/www/mod_proctitle/Makefile
+++ b/www/mod_proctitle/Makefile
@@ -3,7 +3,6 @@
PORTNAME= mod_proctitle
PORTVERSION= 0.4.1
-PORTREVISION= 0
CATEGORIES= www
MASTER_SITES= ftp://ftp.springdaemons.com/soft/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -11,6 +10,7 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Set httpd process titles to reflect currently processed request
+LICENSE= BSD
USE_APACHE= 22+
GNU_CONFIGURE= yes
@@ -21,9 +21,9 @@ CFLAGS+= -I${LOCALBASE}/include \
PLIST_FILES= ${APACHEMODDIR}/${PORTNAME}.so
-NO_STAGE= yes
do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/.libs/mod_proctitle.so \
- ${PREFIX}/${APACHEMODDIR}/
+ ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
.include <bsd.port.mk>
diff --git a/www/mod_proxy_html/Makefile b/www/mod_proxy_html/Makefile
index abf91e16ec9e..09530e062dc7 100644
--- a/www/mod_proxy_html/Makefile
+++ b/www/mod_proxy_html/Makefile
@@ -12,11 +12,12 @@ DIST_SUBDIR= mod_proxy_html
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for rewriting HTML links in proxied content
-RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_xml2enc.so:${PORTSDIR}/www/mod_xml2enc
+LICENSE= GPLv2
+RUN_DEPENDS= ${LOCALBASE}/${APACHEMODDIR}/mod_xml2enc.so:${PORTSDIR}/www/mod_xml2enc
SUB_FILES= pkg-message
-USE_APACHE= 22+
+USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SHORTMODNAME= proxy_html
@@ -27,16 +28,10 @@ AP_INC+= ${LOCALBASE}/include/libxml2 -I${WRKSRC}
AP_LIB+= ${LOCALBASE}/lib
AP_EXTRAS+= -lxml2
-PLIST_FILES= %%DOCSDIR%%/COPYING %%DOCSDIR%%/README \
- %%DOCSDIR%%/proxy_html.conf
-PLIST_DIRS= %%DOCSDIR%%
+PORTDOCS= README proxy_html.conf
-NO_STAGE= yes
post-install:
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/COPYING ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/proxy_html.conf ${DOCSDIR}
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_proxy_html/pkg-descr b/www/mod_proxy_html/pkg-descr
index 9a58cb1d16d5..3360166f7a74 100644
--- a/www/mod_proxy_html/pkg-descr
+++ b/www/mod_proxy_html/pkg-descr
@@ -3,4 +3,9 @@ situation, to ensure that links work for users outside the proxy. It
serves the same purpose as Apache's ProxyPassReverse directive does for
HTTP headers, and is an essential component of a reverse proxy.
+Note (for apache24 users):
+mod_proxy_html has now been relicensed and incorporated into the core
+Apache HTTPD distribution at apache.org from HTTPD 2.4. That version is
+now likely to be more up-to-date than this one.
+
WWW: http://apache.webthing.com/mod_proxy_html/
diff --git a/www/mod_tidy/Makefile b/www/mod_tidy/Makefile
index ca14449c031f..ca8675f9ed7a 100644
--- a/www/mod_tidy/Makefile
+++ b/www/mod_tidy/Makefile
@@ -11,8 +11,10 @@ DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= Validates the HTML output of your apache2 webserver
-LIB_DEPENDS= tidy:${PORTSDIR}/www/tidy-lib
+LICENSE= AL2 MIT
+LICENSE_COMB= multi
+LIB_DEPENDS= libtidy.so:${PORTSDIR}/www/tidy-lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_APACHE= 22+
@@ -20,12 +22,5 @@ AP_FAST_BUILD= yes
AP_GENPLIST= yes
AP_INC+= ${LOCALBASE}/include/tidy
AP_LIB+= ${LOCALBASE}/lib -ltidy
-PLIST_FILES= ${DOCSDIR:S/${PREFIX}\///}/LICENSE
-PLIST_DIRS= ${DOCSDIR:S/${PREFIX}\///}
-
-NO_STAGE= yes
-post-install:
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/../LICENSE ${DOCSDIR}
.include <bsd.port.mk>
diff --git a/www/mod_webkit/Makefile b/www/mod_webkit/Makefile
index eb806acc5bcf..748ea966ae65 100644
--- a/www/mod_webkit/Makefile
+++ b/www/mod_webkit/Makefile
@@ -10,6 +10,7 @@ DISTNAME= Webware-${PORTVERSION}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for WebWare WebKit AppServer
+LICENSE= PSFL
USE_APACHE= 22+
AP_FAST_BUILD= yes
@@ -18,7 +19,6 @@ AP_EXTRAS= marshal.c
WRKSRC= ${WRKDIR}/Webware-${PORTVERSION}/WebKit/Adapters/${PORTNAME}2
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|/usr/sbin/apxs|${APXS}|' ${WRKSRC}/Makefile
diff --git a/www/mod_xmlns/Makefile b/www/mod_xmlns/Makefile
index 1d23a06dd098..797288efbe4a 100644
--- a/www/mod_xmlns/Makefile
+++ b/www/mod_xmlns/Makefile
@@ -12,24 +12,21 @@ DISTFILES= xmlns.h mod_xmlns.c
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for XML namespaces
+LICENSE= GPLv2
USE_GNOME= libxml2
USE_APACHE= 22+
-XML2_INC= ${LOCALBASE}/include/libxml2
-XML2_LIB= ${LOCALBASE}/lib
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+AP_INC+= ${LOCALBASE}/include/libxml2
+AP_LIB+= ${LOCALBASE}/lib -lxml2
+SRC_FILE= mod_xmlns.c
-NO_STAGE= yes
pre-extract:
- @${MKDIR} ${WRKDIR}
+ @${MKDIR} ${WRKSRC}
do-extract:
- @${CP} ${DISTDIR}/xmlns.h ${DISTDIR}/mod_xmlns.c ${WRKDIR}
-
-do-build:
- @(cd ${WRKDIR} && ${APXS} -c -I ${XML2_INC} -L ${XML2_LIB} -lxml2 mod_xmlns.c)
-
-do-install:
- @(cd ${WRKDIR} && ${APXS} -A -i mod_xmlns.la)
+ @${CP} ${DISTDIR}/xmlns.h ${DISTDIR}/mod_xmlns.c ${WRKSRC}
.include <bsd.port.mk>
diff --git a/www/mod_xmlns/pkg-plist b/www/mod_xmlns/pkg-plist
deleted file mode 100644
index fb691e0a0509..000000000000
--- a/www/mod_xmlns/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%APACHEMODDIR%%/%%AP_MODULE%%
-@exec %D/sbin/apxs -e -a -n %%AP_NAME%% %D/%F
-@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F