aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2006-05-23 19:12:24 +0000
committerHiroki Sato <hrs@FreeBSD.org>2006-05-23 19:12:24 +0000
commit5c086e1aa05e2b5c4f10453341e763b232b1318f (patch)
tree745ca3325b9cef5805e3865337cbd14e690b36bd /www
parent6bb6fffb7ad0554c76946622a4124c22e8f472dd (diff)
downloadports-5c086e1aa05e2b5c4f10453341e763b232b1318f.tar.gz
ports-5c086e1aa05e2b5c4f10453341e763b232b1318f.zip
Revert changes related to linux-flashplugin* removal.
Notes
Notes: svn path=/head/; revision=163192
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/linux-flashplugin6/Makefile53
-rw-r--r--www/linux-flashplugin6/distinfo3
-rw-r--r--www/linux-flashplugin6/pkg-descr11
-rw-r--r--www/linux-flashplugin6/pkg-plist7
5 files changed, 75 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 43d62a9736ec..ba7df0e137b4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -232,6 +232,7 @@
SUBDIR += linux-beonex
SUBDIR += linux-firefox
SUBDIR += linux-firefox-devel
+ SUBDIR += linux-flashplugin6
SUBDIR += linux-flashplugin7
SUBDIR += linux-flock
SUBDIR += linux-mozilla
diff --git a/www/linux-flashplugin6/Makefile b/www/linux-flashplugin6/Makefile
new file mode 100644
index 000000000000..7920cf8ac895
--- /dev/null
+++ b/www/linux-flashplugin6/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: linux-flashplugin6
+# Date created: 23 February 2003
+# Whom: Brandon D. Valentine <ports@brandon.dvalentine.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flashplugin
+PORTVERSION= 6.0r79
+PORTREVISION= 3
+CATEGORIES= www multimedia linux
+MASTER_SITES= http://download.macromedia.com/pub/shockwave/flash/english/linux/${PORTVERSION}/
+PKGNAMEPREFIX= linux-
+DISTNAME= install_flash_player_6_linux
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= ports@brandon.dvalentine.com
+COMMENT= The official Macromedia Flash Player for Linux Mozilla and Netscape 6+
+
+FORBIDDEN= http://vuxml.FreeBSD.org/83421018-b3ef-11da-a32d-000c6ec775d9.html
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
+
+RESTRICTED= "Redistribution not allowed"
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/install_flash_player_6_linux
+LATEST_LINK= flash6
+
+PLUGINSDIR= lib/linux-mozilla/plugins
+LIBFILES= libflashplayer.so flashplayer.xpt
+
+DOCSDIR?= ${PREFIX}/share/doc/${UNIQUENAME}
+
+PLIST_SUB= PLUGINSDIR="${PLUGINSDIR}"
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/linux-flashplugin6
+.for f in ${LIBFILES}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/lib/linux-flashplugin6
+.if exists(${PLUGINSDIR})
+ @${LN} -sf ${PREFIX}/lib/linux-flashplugin6/${f} ${PREFIX}/${PLUGINSDIR}
+.endif
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.htm ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/linux-flashplugin6/distinfo b/www/linux-flashplugin6/distinfo
new file mode 100644
index 000000000000..ccb8596f5be9
--- /dev/null
+++ b/www/linux-flashplugin6/distinfo
@@ -0,0 +1,3 @@
+MD5 (flashplugin/6.0r79/install_flash_player_6_linux.tar.gz) = a6f73da96f89d3dba4fadd4020dd7f38
+SHA256 (flashplugin/6.0r79/install_flash_player_6_linux.tar.gz) = e055f8207b93934845365bde0a7356cfc4deee207081f23b9bdf17da0d5d9738
+SIZE (flashplugin/6.0r79/install_flash_player_6_linux.tar.gz) = 707027
diff --git a/www/linux-flashplugin6/pkg-descr b/www/linux-flashplugin6/pkg-descr
new file mode 100644
index 000000000000..d9d2a463a3f4
--- /dev/null
+++ b/www/linux-flashplugin6/pkg-descr
@@ -0,0 +1,11 @@
+This is the official Flash Player from Macromedia. This plugin enables
+you to see .swf and .spl files on the 'net from your Mozilla and
+Netscape 6+ session.
+
+Version 6 of the Macromedia Flash Player no longer works with Netscape
+4.x or earlier. For Flash support in those browsers install the
+linux-flashplugin port.
+
+Please see the Macromedia home page for more information.
+
+WWW: http://www.macromedia.com/
diff --git a/www/linux-flashplugin6/pkg-plist b/www/linux-flashplugin6/pkg-plist
new file mode 100644
index 000000000000..84b7faabe534
--- /dev/null
+++ b/www/linux-flashplugin6/pkg-plist
@@ -0,0 +1,7 @@
+lib/linux-flashplugin6/flashplayer.xpt
+lib/linux-flashplugin6/libflashplayer.so
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%%%DOCSDIR%%/readme.htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rm -f %D/%%PLUGINSDIR%%/flashplayer.xpt %D/%%PLUGINSDIR%%/libflashplayer.so
+@dirrm lib/linux-flashplugin6