aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>2000-04-14 13:29:03 +0000
committerSatoshi Asami <asami@FreeBSD.org>2000-04-14 13:29:03 +0000
commita05ee332abf3339ba8dcecafbeff30a5d1942ef9 (patch)
treecb866b5dedbb384733e9acc3eb871628e0e3b9fb /www
parent65edb6c4e22585cd11e6715baa25e173e198269a (diff)
downloadports-a05ee332abf3339ba8dcecafbeff30a5d1942ef9.tar.gz
ports-a05ee332abf3339ba8dcecafbeff30a5d1942ef9.zip
Make sure PORTNAME/PORTVERSION are defined before inclusion of pre.mk.
There might be some better solutions but this should at least make them work for now.
Notes
Notes: svn path=/head/; revision=27519
Diffstat (limited to 'www')
-rw-r--r--www/bsdi-netscape47-communicator/Makefile3
-rw-r--r--www/bsdi-netscape47-navigator/Makefile3
-rw-r--r--www/netscape47-communicator/Makefile3
-rw-r--r--www/netscape47-navigator/Makefile3
4 files changed, 12 insertions, 0 deletions
diff --git a/www/bsdi-netscape47-communicator/Makefile b/www/bsdi-netscape47-communicator/Makefile
index e7a06b870bde..361526dc5b3a 100644
--- a/www/bsdi-netscape47-communicator/Makefile
+++ b/www/bsdi-netscape47-communicator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.if !defined(PRE_MK_INCLUDED)
.include <bsd.port.pre.mk>
.endif
diff --git a/www/bsdi-netscape47-navigator/Makefile b/www/bsdi-netscape47-navigator/Makefile
index 43c32b1762af..f0c2df7fb014 100644
--- a/www/bsdi-netscape47-navigator/Makefile
+++ b/www/bsdi-netscape47-navigator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/www/netscape47-communicator/Makefile b/www/netscape47-communicator/Makefile
index e7a06b870bde..361526dc5b3a 100644
--- a/www/netscape47-communicator/Makefile
+++ b/www/netscape47-communicator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.if !defined(PRE_MK_INCLUDED)
.include <bsd.port.pre.mk>
.endif
diff --git a/www/netscape47-navigator/Makefile b/www/netscape47-navigator/Makefile
index 43c32b1762af..f0c2df7fb014 100644
--- a/www/netscape47-navigator/Makefile
+++ b/www/netscape47-navigator/Makefile
@@ -5,6 +5,9 @@
# $FreeBSD$
#
+PORTNAME= netscape-${BROWSER_ARC}
+PORTVERSION= ${BROWSER_VER}
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"