aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-11-21 09:45:59 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-11-21 09:45:59 +0000
commitc625c70c21649adfefeb1958a240c262f77a6fd2 (patch)
treec880488ccb841a3443ea232a787a1e12486f9c55 /www
parentaba43df775b5360ee794cda77247f5c820779c4c (diff)
downloadports-c625c70c21649adfefeb1958a240c262f77a6fd2.tar.gz
ports-c625c70c21649adfefeb1958a240c262f77a6fd2.zip
kcgi is a minimal CGI library for web applications in ISC licensed ISO C. It was
designed to be secure and auditable. See a Comparison of CGI Libraries in C for alternatives. To start, download kcgi.tgz and run make install into your PREFIX of choice. The kcgi(3) manpage documents usage. kcgi is a BSD.lv project WWW: http://kristaps.bsd.lv/kcgi/
Notes
Notes: svn path=/head/; revision=372984
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/kcgi/Makefile20
-rw-r--r--www/kcgi/distinfo2
-rw-r--r--www/kcgi/files/patch-Makefile25
-rw-r--r--www/kcgi/pkg-descr6
-rw-r--r--www/kcgi/pkg-plist5
6 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e96675f28801..a27ab9aa3ed4 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -347,6 +347,7 @@
SUBDIR += jtoolkit
SUBDIR += junkbuster
SUBDIR += kannel
+ SUBDIR += kcgi
SUBDIR += kdewebdev4
SUBDIR += kpartsplugin
SUBDIR += kplaylist
diff --git a/www/kcgi/Makefile b/www/kcgi/Makefile
new file mode 100644
index 000000000000..3d177fe46815
--- /dev/null
+++ b/www/kcgi/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= kcgi
+PORTVERSION= 0.3.3
+CATEGORIES= www devel
+MASTER_SITES= http://kristaps.bsd.lv/kcgi/snapshots/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Minimal CGI library in C
+
+LICENSE= ISCL
+
+USES= tar:tgz
+
+OPTIONS_DEFINE= EXAMPLES
+
+HAS_CONFIGURE= yes
+MAKE_ARGS= DATADIR=${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/www/kcgi/distinfo b/www/kcgi/distinfo
new file mode 100644
index 000000000000..f04100da1eb1
--- /dev/null
+++ b/www/kcgi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (kcgi-0.3.3.tgz) = 932512d8dc57fecca18b277e500d86c90166981e71bbb769812f5270bfdb0b7d
+SIZE (kcgi-0.3.3.tgz) = 45010
diff --git a/www/kcgi/files/patch-Makefile b/www/kcgi/files/patch-Makefile
new file mode 100644
index 000000000000..c7ddf133e9ae
--- /dev/null
+++ b/www/kcgi/files/patch-Makefile
@@ -0,0 +1,25 @@
+--- Makefile.orig 2014-07-07 14:23:50 UTC
++++ Makefile
+@@ -67,14 +67,14 @@ installcgi: sample
+ install: libkcgi.a
+ sed -e "s!@VERSION@!$(VERSION)!g" -e "s!@DATADIR@!$(DATADIR)!g" kcgi.h >kcgi.h~
+ sed -e "s!@VERSION@!$(VERSION)!g" -e "s!@DATADIR@!$(DATADIR)!g" kcgi.3 >kcgi.3~
+- mkdir -p $(LIBDIR)
+- mkdir -p $(INCLUDEDIR)
+- mkdir -p $(DATADIR)
+- mkdir -p $(MANDIR)
+- install -m 0444 libkcgi.a $(LIBDIR)
+- install -m 0444 kcgi.h~ $(INCLUDEDIR)/kcgi.h
+- install -m 0444 kcgi.3~ $(MANDIR)/kcgi.3
+- install -m 0444 template.xml sample.c $(DATADIR)
++ mkdir -p $(DESTDIR)$(LIBDIR)
++ mkdir -p $(DESTDIR)$(INCLUDEDIR)
++ mkdir -p $(DESTDIR)$(DATADIR)
++ mkdir -p $(DESTDIR)$(MANDIR)
++ install -m 0444 libkcgi.a $(DESTDIR)$(LIBDIR)
++ install -m 0444 kcgi.h~ $(DESTDIR)$(INCLUDEDIR)/kcgi.h
++ install -m 0444 kcgi.3~ $(DESTDIR)$(MANDIR)/kcgi.3
++ install -m 0444 template.xml sample.c $(DESTDIR)$(DATADIR)
+ rm -f kcgi.h~ kcgi.3~
+
+ sample: sample.o libkcgi.a
diff --git a/www/kcgi/pkg-descr b/www/kcgi/pkg-descr
new file mode 100644
index 000000000000..c6dd81414dee
--- /dev/null
+++ b/www/kcgi/pkg-descr
@@ -0,0 +1,6 @@
+kcgi is a minimal CGI library for web applications in ISC licensed ISO C. It was
+designed to be secure and auditable. See a Comparison of CGI Libraries in C for
+alternatives. To start, download kcgi.tgz and run make install into your PREFIX
+of choice. The kcgi(3) manpage documents usage. kcgi is a BSD.lv project
+
+WWW: http://kristaps.bsd.lv/kcgi/
diff --git a/www/kcgi/pkg-plist b/www/kcgi/pkg-plist
new file mode 100644
index 000000000000..103c9e387901
--- /dev/null
+++ b/www/kcgi/pkg-plist
@@ -0,0 +1,5 @@
+include/kcgi.h
+lib/libkcgi.a
+man/man3/kcgi.3.gz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sample.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/template.xml