aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:12:10 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-12 14:12:10 +0000
commit4558cc5511ad1478b9bcd5757886bbdc155fea3d (patch)
tree033eff875c8406a1fcf8a2b9c9d38f3aa0b5a351 /www
parent24639f2536eabad2b5599d613e97d8729fd87496 (diff)
downloadports-4558cc5511ad1478b9bcd5757886bbdc155fea3d.tar.gz
ports-4558cc5511ad1478b9bcd5757886bbdc155fea3d.zip
The authentication plugin provides generic user support. It is the basis
for both authentication (checking the user is who they claim to be), and authorization (allowing the user to do what the system authorises them to do). WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication/ PR: ports/90271 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=150990
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Authentication/Makefile35
-rw-r--r--www/p5-Catalyst-Plugin-Authentication/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Authentication/pkg-descr6
-rw-r--r--www/p5-Catalyst-Plugin-Authentication/pkg-plist14
5 files changed, 59 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3a6d67b29b55..5c6ef597bd0f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -494,6 +494,7 @@
SUBDIR += p5-Catalyst-Model-CDBI-Sweet
SUBDIR += p5-Catalyst-Model-DBIC
SUBDIR += p5-Catalyst-Model-DBIC-Plain
+ SUBDIR += p5-Catalyst-Plugin-Authentication
SUBDIR += p5-Catalyst-Plugin-Authentication-CDBI
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
SUBDIR += p5-Catalyst-Plugin-FillInForm
diff --git a/www/p5-Catalyst-Plugin-Authentication/Makefile b/www/p5-Catalyst-Plugin-Authentication/Makefile
new file mode 100644
index 000000000000..e1ec19c8f2bf
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-Authentication
+# Date created: Dec 12, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Authentication
+PORTVERSION= 0.04
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Infrastructure plugin for the Catalyst authentication framework
+
+BUILD_DEPENDS= p5-Catalyst>=5.49:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::Authentication.3 \
+ Catalyst::Plugin::Authentication::Credential::Password.3 \
+ Catalyst::Plugin::Authentication::Store.3 \
+ Catalyst::Plugin::Authentication::Store::Minimal.3 \
+ Catalyst::Plugin::Authentication::Store::Minimal::Backend.3 \
+ Catalyst::Plugin::Authentication::User.3 \
+ Catalyst::Plugin::Authentication::User::Hash.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-Authentication/distinfo b/www/p5-Catalyst-Plugin-Authentication/distinfo
new file mode 100644
index 000000000000..724e141e81b3
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Authentication-0.04.tar.gz) = f3584ca9397a98e526b9e3334dede67f
+SHA256 (Catalyst-Plugin-Authentication-0.04.tar.gz) = dc4ef79a5b0bc464f8b9496c00f5de05c2aa7add0f01d664b92205e34374f5a1
+SIZE (Catalyst-Plugin-Authentication-0.04.tar.gz) = 26220
diff --git a/www/p5-Catalyst-Plugin-Authentication/pkg-descr b/www/p5-Catalyst-Plugin-Authentication/pkg-descr
new file mode 100644
index 000000000000..501122c960fd
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication/pkg-descr
@@ -0,0 +1,6 @@
+The authentication plugin provides generic user support. It is the basis
+for both authentication (checking the user is who they claim to be), and
+authorization (allowing the user to do what the system authorises them
+to do).
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Authentication/
diff --git a/www/p5-Catalyst-Plugin-Authentication/pkg-plist b/www/p5-Catalyst-Plugin-Authentication/pkg-plist
new file mode 100644
index 000000000000..5eb771db1d55
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Authentication/pkg-plist
@@ -0,0 +1,14 @@
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store.pod
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Credential/Password.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Minimal.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Minimal/Backend.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/User/Hash.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication/User.pm
+%%SITE_PERL%%/Catalyst/Plugin/Authentication.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store/Minimal 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Store 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/User 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication/Credential 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin/Authentication 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true