aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 09:11:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 09:11:28 +0000
commit1446aabaabf0b8668395a65887618153635e2024 (patch)
tree94992a8316f7d7e2c103ba44cd68a4031668b7b9 /www
parentc0fcaf379b661c1f8f4eaeb62c291d52fe6c042e (diff)
downloadports-1446aabaabf0b8668395a65887618153635e2024.tar.gz
ports-1446aabaabf0b8668395a65887618153635e2024.zip
pear-* ports: simplify path to devel/pear-PEAR/Makefile.common
.include <bsd.port.pre.mk> .include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common" can be simplified to: .include <bsd.port.pre.mk> .include "${PORTSDIR}/devel/pear-PEAR/Makefile.common" the latter version also doesn't make any assumptions about the path of including Makefile PR: ports/57152 Submitted by: Roman Neuhauser <neuhauser@bellavista.cz>
Notes
Notes: svn path=/head/; revision=96749
Diffstat (limited to 'www')
-rw-r--r--www/pear-APC/Makefile4
-rw-r--r--www/pear-HTTP/Makefile2
-rw-r--r--www/pear-HTTP_Header/Makefile2
-rw-r--r--www/pear-HTTP_Session/Makefile2
-rw-r--r--www/pear-HTTP_Session2/Makefile2
-rw-r--r--www/pear-HTTP_Upload/Makefile2
-rw-r--r--www/pecl-APC-devel/Makefile4
-rw-r--r--www/pecl-APC/Makefile4
8 files changed, 11 insertions, 11 deletions
diff --git a/www/pear-APC/Makefile b/www/pear-APC/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pear-APC/Makefile
+++ b/www/pear-APC/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
diff --git a/www/pear-HTTP/Makefile b/www/pear-HTTP/Makefile
index bdcd65fd90ed..95111cfe8c36 100644
--- a/www/pear-HTTP/Makefile
+++ b/www/pear-HTTP/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
do-install:
@${CP} ${WRKSRC}/HTTP.php ${PEARDIR}
diff --git a/www/pear-HTTP_Header/Makefile b/www/pear-HTTP_Header/Makefile
index 294f331c275e..7c388eb1c124 100644
--- a/www/pear-HTTP_Header/Makefile
+++ b/www/pear-HTTP_Header/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
${PEARDIR}/HTTP.php:${PORTSDIR}/www/pear-HTTP
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Session/Makefile b/www/pear-HTTP_Session/Makefile
index ba9efc793dd2..5b94c8a269f0 100644
--- a/www/pear-HTTP_Session/Makefile
+++ b/www/pear-HTTP_Session/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Session2/Makefile b/www/pear-HTTP_Session2/Makefile
index ba9efc793dd2..5b94c8a269f0 100644
--- a/www/pear-HTTP_Session2/Makefile
+++ b/www/pear-HTTP_Session2/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pear-HTTP_Upload/Makefile b/www/pear-HTTP_Upload/Makefile
index bb76d459f820..5bafc4824ccf 100644
--- a/www/pear-HTTP_Upload/Makefile
+++ b/www/pear-HTTP_Upload/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/www/pecl-APC-devel/Makefile b/www/pecl-APC-devel/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pecl-APC-devel/Makefile
+++ b/www/pecl-APC-devel/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index e5fa8bd38da5..7396299260d7 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -20,8 +20,8 @@ USE_PHPIZE= yes
CONFIGURE_ARGS= --enable-apc
.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../lang/php4/bsd.php.mk"
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+.include "${PORTSDIR}/lang/php4/bsd.php.mk"
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.if exists(${LOCALBASE}/bin/php-config)
EXT_DIR!= ${LOCALBASE}/bin/php-config --extension-dir | ${SED} -e \