aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 00:29:39 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-27 00:29:39 +0000
commit173c53f8e789764e943199957f589952c59f91b0 (patch)
treeefd934ad7f2018ad71375ed08b0c3aa20318f703 /www
parent6372ece33554964f27700600a647988e064fd256 (diff)
downloadports-173c53f8e789764e943199957f589952c59f91b0.tar.gz
ports-173c53f8e789764e943199957f589952c59f91b0.zip
- Fix build against ports krb5
- Register dependencies correctly - Bump PORTREVISION PR: ports/149370 Submitted by: Benjamin Lee <ben@b1c1l1.com> With Hat: apache@
Notes
Notes: svn path=/head/; revision=265225
Diffstat (limited to 'www')
-rw-r--r--www/mod_auth_kerb2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index b6cb867e2535..4558f34e0a77 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -10,7 +10,7 @@
PORTNAME= mod_auth_kerb
PORTVERSION= 5.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF/modauthkerb/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -28,14 +28,18 @@ GNU_CONFIGURE= yes
PORTSCOUT= limit:^5.3
-.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
+.if defined(KRB5_HOME)
+BUILD_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
+RUN_DEPENDS+= ${KRB5_HOME}/lib/libgssapi_krb5.so:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME} --without-krb4
-.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
+.elif defined(HEIMDAL_HOME)
+BUILD_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+RUN_DEPENDS+= ${HEIMDAL_HOME}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
CONFIGURE_ARGS+= --with-krb5=${HEIMDAL_HOME} --without-krb4
.elif exists(${DESTDIR}/usr/lib/libkrb5.a) && exists(${DESTDIR}/usr/bin/krb5-config)
CONFIGURE_ARGS+= --with-krb5=${DESTDIR}/usr --without-krb4
.else
-LIB_DEPENDS+= krb5:${PORTSDIR}/security/krb5
+LIB_DEPENDS+= gssapi_krb5:${PORTSDIR}/security/krb5
CONFIGURE_ARGS+= --with-krb5=${LOCALBASE} --without-krb4
.endif