aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 06:29:20 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 06:29:20 +0000
commit56377787c199f05ebaf2618258c26c191c30a94b (patch)
treeaac7afc85343a57e5653f97d19416cb7860a2e84 /www
parent372bf92c0b0a29fb9d19abaccea49d4cada53403 (diff)
downloadports-56377787c199f05ebaf2618258c26c191c30a94b.tar.gz
ports-56377787c199f05ebaf2618258c26c191c30a94b.zip
Add smb2www 0.0.980804, a Windows Network client that is accessible
through a web browser. PR: 26076 Submitted by: Roman Shterenzon <roman@xpert.com>
Notes
Notes: svn path=/head/; revision=41014
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/smb2www/Makefile33
-rw-r--r--www/smb2www/distinfo1
-rw-r--r--www/smb2www/files/patch-Install.pl74
-rw-r--r--www/smb2www/files/patch-smb2www.pm47
-rw-r--r--www/smb2www/pkg-comment1
-rw-r--r--www/smb2www/pkg-descr8
-rw-r--r--www/smb2www/pkg-plist35
8 files changed, 200 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 06529a11e6d0..a93baf5bccab 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -214,6 +214,7 @@
SUBDIR += screem
SUBDIR += sitecopy
SUBDIR += skipstone
+ SUBDIR += smb2www
SUBDIR += smb_auth
SUBDIR += snarf
SUBDIR += squid22
diff --git a/www/smb2www/Makefile b/www/smb2www/Makefile
new file mode 100644
index 000000000000..ba4e55556d99
--- /dev/null
+++ b/www/smb2www/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: smb2www
+# Date created: Mar 25 2001
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smb2www
+PORTVERSION= 0.0.980804
+CATEGORIES= www
+MASTER_SITES= http://us1.samba.org/samba/smb2www/ \
+ http://us2.samba.org/samba/smb2www/ \
+ http://us3.samba.org/samba/smb2www/ \
+ http://us4.samba.org/samba/smb2www/ \
+ http://uk.samba.org/samba/smb2www/ \
+ http://sunsite.auc.dk/samba/smb2www/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/0.0.//g}
+
+MAINTAINER= roman@xpert.com
+
+RUN_DEPENDS= httpd:${PORTSDIR}/www/apache13 \
+ smbclient:${PORTSDIR}/net/samba \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+
+IS_INTERACTIVE= yes
+NO_BUILD= yes
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}
+
+do-install:
+ @cd ${WRKSRC}; ${PERL} ${WRKSRC}/Install.pl
+
+.include <bsd.port.mk>
diff --git a/www/smb2www/distinfo b/www/smb2www/distinfo
new file mode 100644
index 000000000000..2a803b99a5bc
--- /dev/null
+++ b/www/smb2www/distinfo
@@ -0,0 +1 @@
+MD5 (smb2www-980804.tar.gz) = f779e40bed232135a1ee46adecdea60c
diff --git a/www/smb2www/files/patch-Install.pl b/www/smb2www/files/patch-Install.pl
new file mode 100644
index 000000000000..4b8c5f13d317
--- /dev/null
+++ b/www/smb2www/files/patch-Install.pl
@@ -0,0 +1,74 @@
+--- Install.pl.orig Sun Aug 2 21:31:40 1998
++++ Install.pl Sun Mar 25 17:53:37 2001
+@@ -19,24 +19,24 @@
+ if ($is_root == 1) {
+ while (! getpwnam($uname)) {
+ print "$uname is not a valid username.\n" if (! $uname eq "");
+- print "What username shall I use to install smb2www [www-data] ? ";
++ print "What username shall I use to install smb2www [nobody] ? ";
+ $uname=<STDIN>;
+ chop $uname;
+- $uname = "www-data" if ($uname eq "");
++ $uname = "nobody" if ($uname eq "");
+ }
+
+ while (! getgrnam($gname)) {
+ print "$gname is not a valid groupname.\n" if (! $gname eq "");
+- print "What groupname shall I use to install smb2www [www-data] ? ";
++ print "What groupname shall I use to install smb2www [nobody] ? ";
+ $gname= <STDIN>;
+ chop $gname;
+- $gname = "www-data" if ($gname eq "");
++ $gname = "nobody" if ($gname eq "");
+ }
+ }
+
+-print "Where shall I put smb2www [/usr/local/smb2www] ? ";
++print "Where shall I put smb2www [/usr/local/www/smb2www] ? ";
+ $dir=<STDIN>; chop $dir;
+-if ( $dir eq "") { $dir = "/usr/local/smb2www" };
++if ( $dir eq "") { $dir = "/usr/local/www/smb2www" };
+ print "\n";
+ die "Directory already exists ! Move first before continuing !" if ( -d $dir);
+ mkdir "$dir",0755 or die "Unable to create directory ! Check your permissions.";
+@@ -59,9 +59,9 @@
+
+ $smbc = "";
+ while (not -x "$smbc/smbclient" ) {
+- print "In which directory is smbclient located [/usr/local/samba/bin] ? ";
++ print "In which directory is smbclient located [/usr/local/bin] ? ";
+ $smbc=<STDIN>; chop $smbc;
+- if ( $smbc eq "") { $smbc = "/usr/local/samba/bin" };
++ if ( $smbc eq "") { $smbc = "/usr/local/bin" };
+ print "\n";
+ }
+
+@@ -100,9 +100,9 @@
+ if ( $cgiroot eq "" ) { $cgiroot = "/samba" };
+ print "\n";
+
+-print "Where is your mime.types file [/etc] ? ";
++print "Where is your mime.types file [/usr/local/etc/apache] ? ";
+ $mime=<STDIN>; chop $mime;
+-if ( $mime eq "" ) { $mime = "/etc" };
++if ( $mime eq "" ) { $mime = "/usr/local/etc/apache" };
+ $mime= $mime."/mime.types";
+ print "\n";
+
+@@ -124,7 +124,7 @@
+ cfgdir = $dir/etc
+ imgroot = $imgpath
+ cgiroot = $cgiroot
+-linkto_other = http://samba.anu.edu.au/samba/smb2www/
++linkto_other = http://www.samba.org/samba/smb2www/
+ background = cloud.gif
+ icon_other = world.gif
+ icon_all = network.gif
+@@ -209,6 +209,6 @@
+ print "\nAdd this to your apache config:\n";
+ print "-------------------------------\n\n";
+ print "Alias $imgpath $dir/images\n";
+-print "ScriptAlias $cgiroot/ $dir/cgi-bin\n";
++print "ScriptAlias $cgiroot/ $dir/cgi-bin/\n";
+
+ print "\nThank you for using SMB2WWW.\n\n";
diff --git a/www/smb2www/files/patch-smb2www.pm b/www/smb2www/files/patch-smb2www.pm
new file mode 100644
index 000000000000..60c879e9c855
--- /dev/null
+++ b/www/smb2www/files/patch-smb2www.pm
@@ -0,0 +1,47 @@
+--- cgi-bin/smb2www.pm.orig Thu May 25 11:07:02 2000
++++ cgi-bin/smb2www.pm Tue Jul 18 12:30:44 2000
+@@ -371,7 +371,7 @@
+ sub GetSMBShr {
+ my $share = $_[0];
+ my @ret = ();
+- my $lookup = "$cfg{bindir}/smbclient -L \"$share\" -d0";
++ my $lookup = "$cfg{bindir}/smbclient -N -L \"$share\" -d0";
+ my @out = `$lookup`;
+ my $line = shift @out;
+ while ( (not $line =~ /^\s+Sharename/) and ($#out >= -1) ) {
+@@ -406,13 +406,14 @@
+ sub GetSMBHosts {
+ my ($workgroup,$host) = @_;
+ my @ret = ();
+- my $lookup = "$cfg{bindir}/smbclient -L \"$host\" -W \"$workgroup\" -d0";
++ my $lookup = "$cfg{bindir}/smbclient -N -L \"$host\" -W \"$workgroup\" -d0";
+ my @out = `$lookup`;
+ my $line = shift @out;
+
+- while ((not $line =~ /^This machine has a browse list/) and ($#out >= -1) ) {
++ while ((not $line =~ /^\s+Server\s+Comment/) and ($#out >= -1) ) {
+ $line = shift @out;
+ }
++ shift @out;
+ if ($#out >= -1) {
+ $line = shift @out;
+ $line = shift @out;
+@@ -437,16 +438,14 @@
+
+ sub GetSMBGroups {
+ my @ret = ();
+- my $lookup = "$cfg{bindir}/smbclient -L \"$cfg{masterbrowser}\" -d0";
++ my $lookup = "$cfg{bindir}/smbclient -N -L \"$cfg{masterbrowser}\" -d0";
+ my @out = `$lookup`;
+ my $line = shift @out;
+
+- while ((not $line =~ /^This machine has a workgroup list/) and ($#out >= 0) ) {
++ while ((not $line =~ /^\s+Workgroup\s+Master/) and ($#out >= 0) ) {
+ $line = shift @out;
+ }
+ if ($#out >= -1) {
+- $line = shift @out;
+- $line = shift @out;
+ $line = shift @out;
+ $line = shift @out;
+ while ((not $line =~ /^$/) and ($#out >= -1) ) {
diff --git a/www/smb2www/pkg-comment b/www/smb2www/pkg-comment
new file mode 100644
index 000000000000..68224a565e28
--- /dev/null
+++ b/www/smb2www/pkg-comment
@@ -0,0 +1 @@
+Windows Network client that is accessible through a web browser
diff --git a/www/smb2www/pkg-descr b/www/smb2www/pkg-descr
new file mode 100644
index 000000000000..93699868111a
--- /dev/null
+++ b/www/smb2www/pkg-descr
@@ -0,0 +1,8 @@
+SMB2WWW, the gateway to Windows networking
+
+SMB2WWW is a Windows Network client that is accessible through a web browser.
+It is based on the samba package.
+
+WWW: http://www.samba.org/samba/smb2www/
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/www/smb2www/pkg-plist b/www/smb2www/pkg-plist
new file mode 100644
index 000000000000..b776e850c6cf
--- /dev/null
+++ b/www/smb2www/pkg-plist
@@ -0,0 +1,35 @@
+www/smb2www/bin/smbclient
+www/smb2www/images/archive.gif
+www/smb2www/images/share.gif
+www/smb2www/images/search.gif
+www/smb2www/images/printer.gif
+www/smb2www/images/network.gif
+www/smb2www/images/message.gif
+www/smb2www/images/help.gif
+www/smb2www/images/group.gif
+www/smb2www/images/folder.gif
+www/smb2www/images/file.gif
+www/smb2www/images/computer.gif
+www/smb2www/images/cloud.gif
+www/smb2www/images/world.gif
+www/smb2www/cgi-bin/smbfile.pl
+www/smb2www/cgi-bin/smbtar.pl
+www/smb2www/cgi-bin/smbhelp.pl
+www/smb2www/cgi-bin/smbshr.pl
+www/smb2www/cgi-bin/smbdir.pl
+www/smb2www/cgi-bin/smbgrp.pl
+www/smb2www/cgi-bin/smb2www.pl
+www/smb2www/cgi-bin/smbmsg.pl
+www/smb2www/cgi-bin/smb2www.pm
+www/smb2www/etc/smb2www.conf
+www/smb2www/etc/finnish_help.lang
+www/smb2www/etc/finnish.lang
+www/smb2www/etc/english_help.lang
+www/smb2www/etc/english.lang
+www/smb2www/etc/dutch_help.lang
+www/smb2www/etc/dutch.lang
+@dirrm www/smb2www/images
+@dirrm www/smb2www/cgi-bin
+@dirrm www/smb2www/bin
+@dirrm www/smb2www/etc
+@dirrm www/smb2www