aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-04 06:36:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-04 06:36:21 +0000
commit6bcda1dacf9e34906cff549275887d53b77d800e (patch)
tree09b90c98ab59c72cdcdd7b098c02a727b1514cad /www
parent6ec66a1081be04f426e77ba33e118390e49cd726 (diff)
downloadports-6bcda1dacf9e34906cff549275887d53b77d800e.tar.gz
ports-6bcda1dacf9e34906cff549275887d53b77d800e.zip
Update to 2.45.
Notes
Notes: svn path=/head/; revision=102877
Diffstat (limited to 'www')
-rw-r--r--www/mplayer-plugin/Makefile6
-rw-r--r--www/mplayer-plugin/distinfo4
-rw-r--r--www/mplayer-plugin/files/patch-Makefile.in10
-rw-r--r--www/mplayer-plugin/files/patch-Source_plugin-setup.cpp38
-rw-r--r--www/mplayer-plugin/files/patch-Source_plugin.h14
5 files changed, 19 insertions, 53 deletions
diff --git a/www/mplayer-plugin/Makefile b/www/mplayer-plugin/Makefile
index a32caeb3f818..a10270f03211 100644
--- a/www/mplayer-plugin/Makefile
+++ b/www/mplayer-plugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mplayerplug-in
-PORTVERSION= 2.11
+PORTVERSION= 2.45
CATEGORIES= www multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mplayerplug-in
@@ -41,8 +41,12 @@ HEADERS_SUFX= -devel
.else
.if ${WITH_MOZILLA}=="mozilla-devel-gtk1"
HEADERS_SUFX= -devel-gtk1
+CONFIGURE_ARGS+= --disable-gtk2 \
+ --enable-gtk1
.else
HEADERS_SUFX= -gtk1
+CONFIGURE_ARGS+= --disable-gtk2 \
+ --enable-gtk1
.endif
.endif
.endif
diff --git a/www/mplayer-plugin/distinfo b/www/mplayer-plugin/distinfo
index ef1e83d96b42..953f3db4d80b 100644
--- a/www/mplayer-plugin/distinfo
+++ b/www/mplayer-plugin/distinfo
@@ -1,2 +1,2 @@
-MD5 (mplayerplug-in-2.11.tar.gz) = 23d09660c0a0135079120470f8121bea
-SIZE (mplayerplug-in-2.11.tar.gz) = 125472
+MD5 (mplayerplug-in-2.45.tar.gz) = fab744dacb3675a992ff763e0ee99968
+SIZE (mplayerplug-in-2.45.tar.gz) = 138464
diff --git a/www/mplayer-plugin/files/patch-Makefile.in b/www/mplayer-plugin/files/patch-Makefile.in
index a52cce9ac9d0..434b2d2278ed 100644
--- a/www/mplayer-plugin/files/patch-Makefile.in
+++ b/www/mplayer-plugin/files/patch-Makefile.in
@@ -1,12 +1,12 @@
---- Makefile.in.orig Sat Feb 14 13:26:10 2004
-+++ Makefile.in Sat Feb 14 13:27:03 2004
+--- Makefile.in.orig Fri Feb 27 11:40:58 2004
++++ Makefile.in Thu Mar 4 01:28:16 2004
@@ -12,7 +12,7 @@
CC= @CC@
CXX= @CXX@
--CFLAGS= -Wall @CFLAGS@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @X_CFLAGS@ @GECKO_DEFINES@
-+CFLAGS= -Wall @CFLAGS@ @CPPFLAGS@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @X_CFLAGS@ @GECKO_DEFINES@
- LDFLAGS= @LIBS@ @X_LIBS@ @MOZPLUG_LIBS@
+-CFLAGS= -Wall @CFLAGS@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @X_CFLAGS@ @GECKO_DEFINES@ @GTK_CFLAGS@ @GTHREAD_CFLAGS@ @GTK_DEFINES@
++CFLAGS= -Wall @CFLAGS@ @CPPFLAGS@ -DXP_UNIX -DMOZ_X11 @MOZPLUG_CFLAGS@ -Iinclude -fPIC @X_CFLAGS@ @GECKO_DEFINES@ @GTK_CFLAGS@ @GTHREAD_CFLAGS@ @GTK_DEFINES@
+ LDFLAGS= @LIBS@ @X_LIBS@ @MOZPLUG_LIBS@ @GTK_LIBS@ @GTHREAD_LIBS@
LIBOBJS= @LIBOBJS@
OBJ= plugin.o nsScriptablePeer.o npp_gate.o np_entry.o npn_gate.o \
@@ -33,7 +33,7 @@
diff --git a/www/mplayer-plugin/files/patch-Source_plugin-setup.cpp b/www/mplayer-plugin/files/patch-Source_plugin-setup.cpp
deleted file mode 100644
index 4f1dfe02683c..000000000000
--- a/www/mplayer-plugin/files/patch-Source_plugin-setup.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- Source/plugin-setup.cpp.orig Fri Feb 13 09:45:47 2004
-+++ Source/plugin-setup.cpp Sun Feb 15 01:02:21 2004
-@@ -2,7 +2,7 @@
-
- #ifndef STATICDECLS
- #define STATICDECLS
--int DEBUG = 1;
-+int DEBUG = 0;
- int DESTROYED = 0;
- int enable_real;
- int enable_qt;
-@@ -76,7 +76,7 @@
- }
-
- if (config == NULL) {
-- config = fopen("/etc/mplayerplug-in.conf", "r");
-+ config = fopen("/usr/X11R6/etc/mplayerplug-in.conf", "r");
- }
-
- if (config == NULL) {
-@@ -153,7 +153,7 @@
- }
-
- if (customtypes == NULL) {
-- customtypes = fopen("/etc/mplayerplug-in.types", "r");
-+ customtypes = fopen("/usr/X11R6/etc/mplayerplug-in.types", "r");
- }
-
- if (customtypes != NULL) {
-@@ -439,7 +439,7 @@
- }
-
- if (config == NULL) {
-- config = fopen("/etc/mplayerplug-in.conf", "r");
-+ config = fopen("/usr/X11R6/etc/mplayerplug-in.conf", "r");
- }
-
- if (config == NULL) {
diff --git a/www/mplayer-plugin/files/patch-Source_plugin.h b/www/mplayer-plugin/files/patch-Source_plugin.h
index 11c0d7ccb513..25db268e948e 100644
--- a/www/mplayer-plugin/files/patch-Source_plugin.h
+++ b/www/mplayer-plugin/files/patch-Source_plugin.h
@@ -1,15 +1,15 @@
---- Source/plugin.h.orig Sat Feb 14 08:00:01 2004
-+++ Source/plugin.h Sat Feb 14 14:53:55 2004
-@@ -37,11 +37,8 @@
+--- Source/plugin.h.orig Mon Mar 1 13:29:02 2004
++++ Source/plugin.h Thu Mar 4 01:29:25 2004
+@@ -37,11 +37,9 @@
#ifndef __PLUGIN_H__
#define __PLUGIN_H__
+#include <cmath>
#define _XOPEN_SOURCE 500
--
+
-#ifndef _GNU_SOURCE
-#define _GNU_SOURCE
-#endif
-
- #include "pluginbase.h"
- #include "nsScriptablePeer.h"
+ #ifdef GECKOSDK_ENABLED
+ #include "mozilla-config.h"
+ #endif